Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Autotext label dimension units?

furtonb
Expert
Hi,

Maybe I've just overlooked it, but is there a way to set the units for the measurements in the autotext label?
The "Dimensions..." settings in the project preferences have no effect on them, nor the working units: e.g. every length measurement is always shown in meters.

For columns etc. though, it is common practice to give these overall measurements in centimetres. In AC22 there would be a workaround to create expression based properties, but
a, we are having AC21, which doesn't have this feature
b, even if we would switch, it's very tedious to keep track of all the required properties.

My question is: is there a way to control the units in which the labeled measurements are shown on autotext labels?

Thank you for your help!
actively using: AC22-25 INT | Rhino6-7 | macOS / win10
13 REPLIES 13

Laszlo Nagy
Community Admin
Community Admin
Have you tried to change Calculation Units in the Options > Project Preferences > Calculation Units & Rules Dialog?
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

furtonb
Expert
LaszloNagy wrote:
Have you tried to change Calculation Units in the Options > Project Preferences > Calculation Units & Rules Dialog?

Thanks, but I'm looking for way a view-specific way to set it (although I didn't say it). As far as I know the Calculation units cannot be set based on views, it gets applied to the whole project – I don't want the schedules to use centimetres for instance. I'm not sure what a better solution would be, but a more flexible approach would be very welcome – as a construction documentation often uses various units on the same plan, or even in the same sentence. The use of expression-based properties yield in the amount of flexibility I wish for, but a more structured way to set it would be beneficial in my opinion.

p.s. If the Calculation units can be set on a view basis, my bad (although I tried, didn't work).
actively using: AC22-25 INT | Rhino6-7 | macOS / win10

Anonymous
Not applicable
is it not under symbol label parameters, general settings?

furtonb
Expert
There is no possibility like that in the Autotext label - see my attached screenshot.

    If there would be such an option, that would be great!
    actively using: AC22-25 INT | Rhino6-7 | macOS / win10

    Anonymous
    Not applicable
    oh, i thought you're using the label - dimension label 21, which you can try

    uisanata
    Booster
    I think this would be possible with AC22 and the new Expressions in Properties function.
    However, I don't understand how to change the unit of measure for the string value. Can anyone help?
    arch. ernest atanasiu

    AC22/23/24 INT/GER/FR on Win 10 2004

    shpendazizi
    Contributor

    Did you manage to find a solution for this?

    I'm trying to auto text some of the openings and Autotext is the only option that gives me the desired values but it does it with some extra decimals which I don't need.

    Barry Kelly
    Moderator

    Have you tried changing the calculation units as Laszlo suggested early in this post?

    But that will affect all calculations - i.e. schedules too.

     

    Otherwise you need to create a property with an expression that will calculate a value with the required units and decimal precision that you want.

    Then autotext that property in your label.

     

    Barry.

    Barry.


    One of the forum moderators.
    Versions 6.5 to 25
    Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
    Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

    Hi, thanks for the quick reply.

    I don't know if this is the right thread but this is the closest one I could find to my problem.

    In the attached screenshot with green, you can see what I want my autotext to say, and with red is what it's showing right now.

    Hope this helps

    shpendazizi_0-1644419712653.png

     

    Can you show a screen shot of your calculation unit settings?

     

    Barry.


    One of the forum moderators.
    Versions 6.5 to 25
    Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
    Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

    Yup,

    Sorry, it's in german.

    shpendazizi_0-1644419948769.png

     

    OK your calculation units are fine - thanks.

    But what I think you have used is the autotext for "unit dimension"?

    Try using "height" x "width" instead.

    I don't know where the "unit dimension" gets the extra decimal precision from.

    I have checked calculation units, working units and dimension settings and none of those affect it.

     

    BarryKelly_0-1644420866260.png

     

     

    Barry.


    One of the forum moderators.
    Versions 6.5 to 25
    Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
    Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

    Thank you Barry,

    It does somehow work now except for the ^5 decimal.

    shpendazizi_1-1644421946094.png

     

     

    Thank you so much again for your help.

    Start a new conversation!

    Labels

    Still looking?

    Browse more topics

    Back to forum

    See latest solutions

    Accepted solutions

    Start a new discussion!