cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Can't publish to BIMx

Miha_M
Advisor
I have a problem. The "Publish BIMx Hyper-model" option used to do its job. Now it doesn't anymore.
I am logged in, have enough space available on the GS server, but I can't publish my BIMx model anymore.

The command under the "File" Menu is greyed out. If I try "Single file" output, the Publisher lets me publish in PDF only, no other option available. What could be wrong?

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

1 ACCEPTED SOLUTION

Solution
Daniel Kovacs
Graphisoft
Graphisoft
Hello,

Sorry for the late reply. We have been investigating the same issue on other channels as well, and I wanted to see how they would pan out. Good news though, we have found the source of the issue! You can find a detailed description of the issue and the solution in this article:
https://helpcenter.graphisoft.com/knowledgebase/86557/

Let me know if it helped!

Kind Regards,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

View solution in original post

12 REPLIES 12

Laszlo Nagy
Community Admin
Community Admin
If you start a brand new Project based on the default ARCHICAD Template, is the command available then?
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Miha_M
Advisor
Hi Laszlo! Sorry for taking so long, I was busy finishing a project phase. I have tried that before, Archicad restart, new Project file from default Archicad Template. Same thing. Then I tried a "New & Reset" file, same thing also. I guess the only thing left to try is a reinstall. I still have some .dwg exporting to do of that project phase and when I am finished, I will reinstall AC.

Any chance you could give me some advice how to export Window & Door Schedule to .dwg? As I wrote down on another page I get my layouts exported to .pdf correcty, but with .dwg I get only the last page of this auto - multiple layout Schedule. Is this my fault or a software error?

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

Laszlo Nagy
Community Admin
Community Admin
Sorry, I have no suggestion for that issue.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Daniel Kovacs
Graphisoft
Graphisoft
Miha_M wrote:
I have a problem. The "Publish BIMx Hyper-model" option used to do its job. Now it doesn't anymore.
I am logged in, have enough space available on the GS server, but I can't publish my BIMx model anymore.

The command under the "File" Menu is greyed out. If I try "Single file" output, the Publisher lets me publish in PDF only, no other option available. What could be wrong?
Hi,

I have seen reports like this recently, but no solutions yet (error #253706). Please try the following:
  • Uninstall ARCHICAD 22, and do a complete preference cleaning, and then reinstall it. See if that helps.
  • If that does not help, then uninstall ARCHICAD 21 (if you have it installed), and reinstall it. See if 'Publish BIMx Hypermodel' is still greyed out in ARCHICAD 22 after this. (It is a long shot, but I have heard of a person whom it helped).
  • If these suggestions didn't help, then please go to the Add-on folder of ARCHICAD 22 build 4023 and replace the BIMx.apx file with the one I attached. After this, please open ARCHICAD, place a few things, see if it is still greyed out, and then quit ARCHICAD.
This last option shouldn't fix the problem, but with the new APX file, there should be extra logs added to the ARCHICAD logs that might give us a clue about what the problem is.
Find the Fastlogger folder, compress it and send it to me, so that we can see if there's anything useful in them (also tell me when you did the test, so we would know what date to look for). Note that this APX should only work with ARCHICAD 22 build 4023!

Thanks,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Miha_M
Advisor
@dkovacs

Hi. I did everything you've asked for, but it still doesn't solve the problem.
Let me clear one fact first. I have recently had a system SSD crash, so I have a fresh and clean system installed on a new SSD, Windows 10 Pro with all scheduled system updates, also all drivers are up to date. The whole system environment should be very clean. I do have other software (which I need for work) installed.

This is what I did:
1. Uninstalled Archicad (with no older versions present),
2. Cleared all preferences,
3. Installed Archicad 22,
4. Created a new project file from the default template file,
5. Placed some elements,
6. Tried to publish out of the 3D window, but the option remains greyed out,
7. Saved the test file,
8. Closed Archicad.
9. Installed 4023 update,
10. Replaced the BIMx.apx file,
11. Started Archicad and created a new project file from the default template,
12. Placed some elements (2 walls, three columns, three windows, three chairs and a slab,
13. Logged into Graphisoft (inside Archicad) with my Graphisoft ID,
14. Tried to publish out of the 3D window, but the option remains greyed out,
15. Saved the test file,
16. Closed Archicad,
17. Copied the zipped logs folder,
18. Wrote this post with attached logs zipped file.

I tried all this today, 16.01.2019.

As the system is in a relativ fresh condition and only Archicad 22 has been installed, uninstalled and then installed again, this problem can't be in any relation with previous AC versions. Now please find out if this is a v. 22 or system or combined v.22 - system connected issue. Could any other software I have installed also cause this problem? Norton, MSOffice, LibreOffice, Notepad ++, Soda PDF 8, Paint.net, MegaSync, Sumatra PDF, FoxitPhantom PDF, Chrome, VLC Media Player, Linkbar, Macrium Reflect, NanoCad, PDF Creator, Wacom Tablet drivers, ...?

Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

Miha_M
Advisor
dkovacs wrote:
  • If these suggestions didn't help, then please go to the Add-on folder of ARCHICAD 22 build 4023 and replace the BIMx.apx file with the one I attached. After this, please open ARCHICAD, place a few things, see if it is still greyed out, and then quit ARCHICAD.

    This last option shouldn't fix the problem, but with the new APX file, there should be extra logs added to the ARCHICAD logs that might give us a clue about what the problem is.
    Find the Fastlogger folder, compress it and send it to me, so that we can see if there's anything useful in them (also tell me when you did the test, so we would know what date to look for). Note that this APX should only work with ARCHICAD 22 build 4023!
  • Any news? I am moving on to new projects and would need this online publishing option working again,

    Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

    Solution
    Daniel Kovacs
    Graphisoft
    Graphisoft
    Hello,

    Sorry for the late reply. We have been investigating the same issue on other channels as well, and I wanted to see how they would pan out. Good news though, we have found the source of the issue! You can find a detailed description of the issue and the solution in this article:
    https://helpcenter.graphisoft.com/knowledgebase/86557/

    Let me know if it helped!

    Kind Regards,
    Daniel Alexander Kovacs

    Professional Services Consultant

    GRAPHISOFT



    For Troubleshooting and useful Tips & Tricks visit

    Hello,

    I'm arriving here two years late, but I'm having the same issue on a Mac computer, and obviously the solution can't involve installing Visual Basic components for Windows. Any idea of how I can make the publish to BIMx function available on a Mac?

    Thank you in advance!

    Hello,

     

    Thank you for the report and I am very sorry about the experience!

     

    Previously, we only receive similar cases coming from Windows. This issue should not happen on macOS. Could you please let us know a bit more about the background system here: macOS version, Archicad version and build number? Furthermore, a screenshot of the issue would be helpful to make sure that we are looking at the right place.

     

    Looking forward to hearing from you!

    Best regards,

    Minh

    Minh Nguyen
    Technical Support Engineer
    GRAPHISOFT

    Hello and thanks for the quick reply,

     

    I'm currently working with Archicad 23, Build 3003 CHE (Swiss German language).

     

    My computer's specs are:

    - MacBook Pro (13-inch, 2018, Four Thunderbolt 3 Ports)

    - Processor: 2.3 GHz Quad-Core Intel Core i5

    - Memory: 16 GB 2133 MHz LPDDR3

    - Graphics: Intel Iris Plus Graphics 655 1536 MB

     

    I'm running with macOS Big Sur version 11.6 . A colleague at my office has the same issue with a new MacBook though, with up-to-date software and OS.

     

    Attached are the screenshots of the Publisher window and File menu, showing the same issue as in the old posts.

     

    screen2.jpgscreen1.jpg

     

    Best regards, and thank you for the support!

    Hello,

     

    Thank you very much for the screenshot! I found out what might be the problem in this case:

    In Switzerland, BIMx, like SwissTools, is only available for KEYMEMBER customers. BIMx and SwissTools are thus accessed via the SSA status. Thus, I suggest contacting your local seller about this problem. They will be able to help you with this process.

     

    Thank you very much for your understanding! Please let me know how it goes!

    Best regards,

    Minh

    Minh Nguyen
    Technical Support Engineer
    GRAPHISOFT

    Miha_M
    Advisor
    dkovacs wrote:
    Let me know if it helped!
    It does work. Thank you.

    Archicad 4.55 - 25 | HP Z840 | 2× E5-2643 v4 | 64 GB RAM | Nvidia Quadro M5000 @ Windows 10 Pro x64

    Start a new conversation!

    Labels

    Still looking?

    Browse more topics

    Back to forum

    See latest solutions

    Accepted solutions

    Start a new discussion!