Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Continually stuck on "updating" drawings on layout

Anonymous
Not applicable
I am working on a massive teamwork project and getting towards end of detail design, have over 100 A1 layouts, each layout with multiple drawings

Everything is set on Auto update so that anybody on the teamwork can publish PDFs without having to reserve the layout and manually update

However what is really frustrating is how long it takes for drawings on layouts to update. Sometimes I just want to have a quick look at what is on a layout and it takes several minutes and the cancel / abort button never seems to work

There has to be a way of "previewing" a layout quickly without having to update each drawing and waiting minutes on end

Indesign has a tool of "fast display" - wonder if there is anything close to what I am after here in AC...
11 REPLIES 11

Laszlo Nagy
Community Admin
Community Admin
Try this:

1. Go to the Drawing Manager, which lists every single Drawing placed in the Project file.
2. Select All Drawings.
3. Go to the Drawing Settings Dialog.
4. In the "Size and Appearance" panel, change the "On-screen Preview" field from the "Full Precision" option to the "Quick Preview" option. Then click "OK" to accept changes.

This way all Drawings will have this new setting.
If you are in Teamwork, you may have to reserve the Drawing Manager and all Drawings before being able to make these changes.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Anonymous
Not applicable
Thank you, that has helped

I have sent every drawing to "No Preview", yet still getting stuck on "Updating", see scerenshot, albiet it's not as long as before

Anonymous
Not applicable
I have updated to AC24 just in case and set all the drawings to No preview

However I am still getting stuck on "updating" - see screenshot. quite strange as if it's no preview there shouldn't be anything to update?

Barry Kelly
Moderator
I think you will find that they will always update unless you set them to 'Manual' update.

I am pretty sure the 'no preview' is just what you see on screen - it won't affect the output, so that still has to be updated just in case you print.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
I see - is the "no previous" supposed to make workflow faster? As I am not seeing much difference

Barry Kelly
Moderator
It is not really clear even in the manual.
The 'No Preview' is supposed to increase speed, but I think that is while you are working in the layouts.
When you edit the model the layout drawing will still update even though there is no preview.

This is from the manual ...
On-Screen Preview
Choose a format for the on-screen display of this Drawing on the Layout.
With large Layout Books, your choice here can affect navigation speed significantly:
• Full Precision (drawing shown with full details, always rebuilt)
• Quick Preview (faster navigation; Drawing rebuilt only upon explicit Rebuild of the Layout, or
when a Drawing update occurs)
• No Preview (fastest navigation)
If you choose Quick Preview, the text “Quick Preview” will be displayed. The drawing content is an
accurate vectorial preview, but you may lose certain details: certain dashed line types and fills will
be shown as solid.
If you choose No Preview, the Drawing frame will be shown with the text “No Preview” in place of
the Drawing content. (You may prefer this option to reduce redraw time if you are working on a
Layout with multiple drawings, and you do not need to see this Drawing’s content as you work.).

This preview display option is an on-screen effect only and does not affect output.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Thanks Barry

So I take it aside from setting the drawing to "Manual" there is no other way of increasing the speed of the drawing update? Do you know of any workarounds? It's quite annoying to be stuck there for a minute - and the right click abort never seems to work very well

Barry Kelly
Moderator
I am not sure if it will make a big difference with layouts, but in your Work Environment > User Preference Schemes > Model Rebuild Options ... do you have background updating turned on?
I believe this only affects tab windows that are open in the tab bar - so if you have your layouts closed then this may not do anything.
Even if they are open I think they will still have to 'Update'.

Also make sure you do not have any trace reference turned on while in the layouts as then Archicad will have to update that a well.


At least now Archicad updates many drawings at once.
Some versions ago it used to be one at a time!


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Thanks Barry. Below screenshot is what my settings are

I will try to Disable it to see whether this will improve it

Does the "Auto-rebuild Model View Control" affect the drawing update?

Barry Kelly
Moderator
benjamin_chan wrote:
Does the "Auto-rebuild Model View Control" affect the drawing update?

I think it is just for sections and elevations.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
I've done a test and disabling those options don't help unfortunately. Thanks for your help so far

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!