cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Custom Dimension Text Reverting to Measured

Dave Jochum
Enthusiast
Multiple dimension strings are doing this. If I dimension a door as centered between two walls, for example, and I change the text on both sides to "EQ", the next time I open the file, one of them reverts to the measured value--but not both. If there are more dimensions in the string than the two that have been customized, then BOTH custom texts revert to measured. To change back to "EQ" I select CUSTOM TEXT and "EQ" is pre-loaded. So it remembers the change, but not to display it.
Dave Jochum

J o c h u m A R C H I T E C T S http://www.jochumarchitects.com

MBP 16" (M1 Max) 64 GB•OS 12.5.1•AC 26 (latest build)
14 REPLIES 14

Barry Kelly
Moderator
I just tested quickly.
Shut down Archicad and re-opened file with no problems (see image).
I am on Windows system build 5002.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Dave Jochum
Enthusiast
Barry wrote:
I just tested quickly.
Shut down Archicad and re-opened file with no problems (see image).
I am on Windows system build 5002.

Barry.
This is a brand new problem for me, and I'm on Mac 4022 build. I'm not sure if is started with the build update, but it could have. Not sure of the timing.
Dave Jochum

J o c h u m A R C H I T E C T S http://www.jochumarchitects.com

MBP 16" (M1 Max) 64 GB•OS 12.5.1•AC 26 (latest build)

Barry Kelly
Moderator
Build 5002 preview is available here ...

http://archicad-talk.graphisoft.com/viewtopic.php?t=58211

You could try that or wait a while until the official update is released - I am sure I read somewhere it would be later this month.

Duplicate your current installed program before you update.
That way if you are not happy you can just delete the whole updated program and re-name the copy to go back to 4022 - to save having to reinstall from scratch.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Dave Jochum
Enthusiast
Barry wrote:
Build 5002 preview is available here ...

http://archicad-talk.graphisoft.com/viewtopic.php?t=58211

You could try that or wait a while until the official update is released - I am sure I read somewhere it would be later this month.

Duplicate your current installed program before you update.
That way if you are not happy you can just delete the whole updated program and re-name the copy to go back to 4022 - to save having to reinstall from scratch.

Barry.
Yes--good idea generally. Unfortunately, I am three days from submitting a permit package with the file in question, so will have to wait. Thanks.
Dave Jochum

J o c h u m A R C H I T E C T S http://www.jochumarchitects.com

MBP 16" (M1 Max) 64 GB•OS 12.5.1•AC 26 (latest build)

Daniel Kovacs
Graphisoft
Graphisoft
Hello Dave,

Unfortunately this is not a bug that will be fixed in that update, this is a limitation of current Library Parts. The hotspots you connect your dimensions to in the library part may disappear in a different detail level, and when you come back to this detail level, the dimension will basically regenerate (and thus forget it was supposed to be custom). This varies between different points of the same library part and different library parts.

What you should try, is to place several other dimension lines, and link that point to some other hotspot on the same edge (the inner corner of the reveal, the outer corner, where the casing and the wall meets, etc.). If none of the hotspots on that side give the desired results, you can still use a non-linked node (the little square instead of the circle, when you input the points).

Fixing this problem is on our to-do list, but it requires completely redesigning how doors/windows work, so it won't come easy (it has been like this since day one).

Thanks for understanding,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Dave Jochum
Enthusiast
dkovacs wrote:
Hello Dave,

Unfortunately this is not a bug that will be fixed in that update, this is a limitation of current Library Parts. ... Fixing this problem is on our to-do list, but it requires completely redesigning how doors/windows work, so it won't come easy (it has been like this since day one).

Thanks for understanding,
Thanks for the info, Daniel. It's odd that I've never encountered/noticed this issue in the past. I'm glad to know how to counter it so I won't have to continue fixing it each time I publish.
Dave Jochum

J o c h u m A R C H I T E C T S http://www.jochumarchitects.com

MBP 16" (M1 Max) 64 GB•OS 12.5.1•AC 26 (latest build)

laylag
Newcomer
Hello,

We seem to be having this issue a lot. We type text in a dimension in our interior elevations (they are not particularly linked to doors or windows - , maybe room heights, or cabinetry, etc... ), and then after a while, we realize some of them are showing the dimension and not the text. It is very annoying since we do this a lot, and it it very difficult for us to go through each one of them and re do them. Could this be fixed if we make them "static"? Will this make a difference or is it not worth it? Thanks.

Lingwisyer
Champion
@laylag

Refer to Daniels post:
Daniel wrote:
What you should try, is to place several other dimension lines, and link that point to some other hotspot on the same edge (the inner corner of the reveal, the outer corner, where the casing and the wall meets, etc.). If none of the hotspots on that side give the desired results, you can still use a non-linked node (the little square instead of the circle, when you input the points).
AC22-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200 RIP PSU
Win10 | R5 2600 | 16GB | GTX1660

JOTHOMAS
Participant

I have noticed this glitch has started cropping up in my project. I am using Archicad 24 with the latest update.

 

This conversation started in 2017 and it was acknowledged that this has been an issue since the start.

 

Why has this not been fixed yet?!  It seems this option is perhaps somewhat redundant unless it is useable. 

 

The work around I use is to copy a text box over the custom text.

Working on Archicad 24 build 7006 USA full on a Mac Studio. We are experiencing this STILL. Use text in dimension strings, send/receive, close down for the night. Reopen the file in the morning and a good portion of the dimension strings we have added text to default to the measurement. A lot of duplicated work for this. Has this ever been addressed or corrected? It is really time consuming to go back and redo work every time we have to publish a set of documents. 

JOTHOMAS
Participant

I am not aware of a bug fix for this. I work around by putting a text box over the dimension from the outset with an opaque white background fill to hide the dimension. Working in AC25 now and realising I didn't do this in the current project so I will keep an eye on the custom texts I have used. Perhaps it has been fixed in the latest iteration.

 

(Agreed, very tedious to redo work every time it is opened or published. It makes the option fairly redundant, in my opinion!)

 

AC22-25

Mac Pro 3.5 GHz 8-core Intel Xeon; macOS Big Sur 11.6.1; 64 GB

Windows Surface Pro: Intel(R) Core(TM) i7-1065G7 CPU @ 1.30GHz; Win10 Enterprise; 32 GB

Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni

Dear All,

 

Thank you very much for the reports and I'm very sorry for the trouble that this is causing!

We are aware of this issue, and a bug fix has been made in Archicad 25 Update 3. Unfortunately, the fix must be enabled via Registry Editor. From Archicad 26, this will be enabled by default.

 

Please open Registry Editor, then navigate to the location: \HKEY_CURRENT_USER\Software\GRAPHISOFT\ARCHICAD\ARCHICAD 25.0.0 INT R1\Dimensioning

and change the following keys:

  • KeepCustomDimensionTexts: 0 is the default value, changing it to 1 will allow dimensions to keep custom values, instead of reverting to measured value when dimension legs moves.
  • KeepNonAutomaticPositionOfDimensionTexts: 0 is the default value, changing it to 1 will allow dimensions to keep custom position of dimension texts

Note: right after installing Archicad, you may not see these keys available. The keys will only appear if the issue happens at least once.

 

Please let me know if you have any further questions, and thank you very much for your understanding!

 

Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Minh…thanks but sadly we are using 24 for this particular project. Build 7006 on a Mac. 

Hello,

 

I'm very sorry to hear that! I understand that it's not easy to migrate the project when it is still on-going, but unfortunately, the technology only allows us to make the fix in Archicad 25. 

The same fix can also be found on macOS when editing the PLIST. I encourage you to give it a try with Archicad 25 if possible.

 

Thank you for your understanding!
Best regards,

Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!