Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Dimensions text with background becomes black after placing on layout

Anonymous
Not applicable
Hello
In my current project, I have a lot of dimension text with background fill turned on and "Window background" as a background fill pen selected. When I opened my current project made in AC22 in AC23 on my layout pages, all this text is shown with a black background. Moreover, when I try to place any of my drawings on the layout, this dimension text is shown black while on drawing view itself, it looks ok. So I even tried to open a new file in AC23 and copy some drawing from the old one and then placed this drawing on a layout and the problem still existed.
9 REPLIES 9

Eduardo Rolon
Moderator
Select the drawing in the Layout and check that the Pen Setting under Size and Appearance is set to By View. If so then check that the saved view has the correct one
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Vectorworks 2022

Anonymous
Not applicable
It was the first thing I checked. With no success. It was "By View" and changing the pen set to other options doesn't give good results neither. I want to pay attention to the fact that the project was ok in AC22 and right after I open it in AC23 I got this problem. By the way, the drawings on layouts set to manual update look fine until I update them. It looks like a bug to me. I was hoping that the Archicad team would fix it in an update but after fresh update yesterday the problem still exists.

Eduardo Rolon
Moderator
Just tried it here and it works on a newly placed dimension. Check your Graphic Overrides or Renovation Filters
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Vectorworks 2022

Anonymous
Not applicable
When I tried to represent this scenario in a new file with default settings everything was ok. But when I create a new file with the latest project settings the problem exists either I copy a part of my old drawing or trying to create a new dimension. I can share a copy with a small piece of my drawing so you can check it out if you want.

Eduardo Rolon
Moderator
Definite a Bug since placing new Dims do not have the problem.
Work around use Pipette and Injection to update and they get fixed.
Also don't have "Custom" as part of your views, that means that they are not defined and you will get issues.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Vectorworks 2022

Anonymous
Not applicable
ejrolon wrote:
Definite a Bug since placing new Dims do not have the problem.
Work around use Pipette and Injection to update and they get fixed.
Also don't have "Custom" as part of your views, that means that they are not defined and you will get issues.
I use alt+f7 to place views on layouts so all views settings get set up automatically.

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Yudin,

Thank you for sharing the issue, and I am very sorry about the experience!

This looks like a defect to me, however, I am unable to reproduce it. A few things that I have tried (all tested on INT version with the latest update for both AC23 and AC22):
- Create a new dimension with any random background in the given file: background shown as black in layout
- Merge this file to a new default template: the problem does not happen on the new file
- Merge an AC22 file to the given file: new dimension lines from AC22 file shows black background in layout

At first I thought this might relate to one of the defects in AC23 with GO rule (which is scheduled to be fixed in the second update), however, after deleting all GO combinations, the issue still persists. I'm wondering if you could share with us a sample AC22 file so that I can dive deeper into what is happening? Let me know if you'll need a secure link to share the file!

Thank you very much for your help!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Yudin,

With the help from our developer, we found out that this turned out to be a defect. If you see inside the file, there is a fill called Solid Fill with Opacity set to 0%. I suggest either deleting this fill, or rename it to anything other than Solid Fill. After that, the fill color for the text background should be correct.

The reason for this is because this Solid Fill is a default attribute that is used in various operations. In this case, it messes up the drawing attribute (since the Solid Fill is set to 0% opacity), leading to the wrong appearance in the layout.

Let me know if this helps with the issue!

Thank you very much!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Had the same issue with blacked out dimension text when using AC24 after updating a file  begun in an older version.  Removing the Solid Fill with Opacity set to 0% worked--thank you!

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!