Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Finding a missing texture.

Anonymous
Not applicable
I thought it might be useful to highlight the solution to a small problem that had me scratching my head for a while.

The Library Loading Report displayed that the texture named 'CStone 67' was missing from the library, and that there were 4 instances of it in the project.

The Library Manager gave no further information, but looking for the texture in the materials tab of the Attribute Manager showed it was only associated with one material - '04|CS 08', and not four as I previously assumed it suggested.

Going to the Material Settings and selecting '04|CS 08' it was clear the internal engine was searching for 'CStone 67' (labelled 1. on image), while the related lightworks shader settings (2. 3. & 4.) were all empty so I thought simply pressing 'remove texture' would clear the missing attribute error.

After refreshing the element list in the library loading report, it was still showing 3 instances of this texture being missing!

Cutting a long story short, I discovered that even though boxes 2. 3. & 4. were very much empty in the lightworks settings, it was still triggering the error. Simply overwriting each box with a single space, then backspacing it was enough to clear the original texture reference, and the library loading error goes away.

Of course, the best practice would be to either correct the material settings to link them back to a valid texture, or delete the material completely if it isn't in-use or needed in the future!

Hope that helps!

missing_texture1.jpg
1 REPLY 1

Barry Kelly
Moderator
Once you have removed the texture from the Internal Engine version of the material would pressing the "Match With internal Engine" button reset all the textures in steps 2, 3, & 4?
Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!