cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Green shading on door and window plans

KeesW
Enthusiast
I've got green shading on door and windows plan out lines and need to remove them. But...I can't find where and how they are created. Please advise.
https://archicad-talk.graphisoft.com/download/file.php?mode=view&id=42858
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M
18 REPLIES 18

Barry Kelly
Moderator
Is it because of the renovation filter that you currently have active?
Those elements (existing?) are being overridden with the green fill/lines?

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Laszlo Nagy
Community Admin
Community Admin
Or maybe there is a Graphic Override applied to the Viewpoint.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

KeesW
Enthusiast
There are no green overrides in the Model View ot Renovation graphic overrides . It is probably a default somewhere but where?
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Barry Kelly
Moderator
Can you show a screen shot of your renovation filter options with the "05 Planned De...." filter selected?
I'd like to see what it is set to do.

Similar to this image, but of course I do not have your reno filters.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

I do notice that by default our GO setting uses a green pen to override new elements.

Edit: if you look at Barry's screenshot, at the bottom right there is a button to open the GO settings. At the top of the list of rules you will see the override settings for exiting, to be demolished and new.

I would not change these GO rules, however your renovation filter might be wrong and set to something to show new as 'schematic' by having the display option filter setting as 'override'.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

KeesW
Enthusiast
I've checked all graphic overrides in all the Renovation options and do not have any green ones. It is not my colour and I'd never choose it for anything like that.

One of my pet hates for Archicad is that selecting a colour for ,e.g. door and/or window frames or back grounds is not a simple selection in a box. My examples all have green filled frames (and green backgrounds) but these are not shown when I open the item and go through the boxes for fills and colours. If i see a green door frame fill, I should be able to change it by selecting a different colour in the appropriate element box. If there is default colour that cannot be changed, there should be a warning or explanation message. Am I asking too much?

This stuff takes hours to resolve. Would there be a change if experienced Archicad users were able to invoice Graphisoft for the time wasted on such issues?
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Barry Kelly
Moderator
So just to be sure, if you change your active Renovation Filter to something else (do you have a 'Show All' reno filter?) or your active Graphic Override to something else (do you have a 'No Overrides' GO?), the doors remain green?

If that is the case then the setting must be in the objects themselves.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

KeesW
Enthusiast
I've had a reply from Central Innovations. The issue has arisen because I changed my AC24 colour template and this also changed the colour numbers. The green referred to a couple of specific colours and colour numbers of the standard AC24 Australian template. I had expected this and changed the green colour numbers to a different colour number from my new template. Apparently one can't do this but I don't understand why. I don't want to be stuck with the standard supplied AC24 Aus template.
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Lingwisyer
Champion
So... you changed the index "A" from green to "red", and made index "B" green, then changed everything that used index "A" to use index "B" instead? But the objects still use "A" as green?
AC22-23 AUS 7000
Self-taught, bend it till it breaks.

Win10 | E5620 x 2 | 24GB | K2200 RIP PSU
Win10 | R5 2600 | 16GB | GTX1660

Barry Kelly
Moderator
The door and window objects you are using are scripted to use particular pen colours (line styles, fills, etc.) that work with a particular pen set (and other attributes) in the template.
If you are changing the pen colour in your pen set, the objects (as well as composites) will still be looking for a particular pen number (not the colour).
You are changing the pen colour only - the number remains the same.

So feel free to change the pen colours but you will also need to check everything else.
For objects (doors and windows), every time you place them you will have to change the pen colours in the parameters. Or you can save a favourite for each with the amended pen colours, then use the favourites everytime you want to place an object.
Or you need to edit the objects and save your own version of them - this gets messy whenever the objects are updated as you have to do it all again.
I have this problem every year when there is a new Archicad and library.
If I want to use the Graphisoft objects I have to amend them as they don't match with my template pen colours.
Hence I only use select Graphisoft objects and I don't update them every year.

You will also want to check composites and amend those if they happen to use those pens that you change.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

KeesW
Enthusiast
I've never used indexes and have been an AC user since version 5. (about 1996). When were these introduced into Archicad?

My problem setups are as follows:
After creating the new colour matrix as shown above on the screen print, I realised that the default window colour was green, represented by pen 103. This is the number used by the default AC24 Aus. template. for doors and windows.
Changing pen numbers on my own new template does not change the colour from green.
I can only change it by using a different pen set.
Why????
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

KeesW
Enthusiast
Hello Barry
Thank you for your response. I have been changing pen numbers as required because I know that changing colours won't do anything. Unfortunately, numbers 103 and 123, in my matrix, which generate the green colours, cannot be changed. What I expect is that the colour of the background should be findable and then, if I select a different pen number - which also has a different colour - the colour changes. But it doesn't. I am unable to change the green in my matrix. I've tried changing the colour of pen numbers 123 and 103 but this doesn't change the colour on the model. I've also tried using a different coloured pen (which also has a different number) to change the background colour and that doesn't work either.

Using a different pen set does work but I don't want to do this. Surely pen numbers and colours should be changeable by the user and should , when selected, show correctly on the model? Or am I being naive?

Also, what are indexes referred to in a previous comment on my colour query?
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Barry Kelly
Moderator
KeesW wrote:
I've never used indexes and have been an AC user since version 5. (about 1996). When were these introduced into Archicad?

103 is the index number of the pen you are using.
All attributes have index numbers which Archicad uses - we see it as a pen colour or layer name or composite name.
Archicad actually uses the index number that we don't see (except in the case of pen numbers which we can see).


When you change your pen colour, make sure that you "Store As" the pen set you want to change.
Otherwise you are just altering to a 'custom' pen set that is only temporary.
Any time you see 'Custom' for pen set or layer combination, you can not rely that what you see is what you will get in your documentation - as views should have 'saved' pen sets and layer combinations.
As soon as you open a view, it will switch to the pen set saved with that view.


By default your objects are using pen 103 as the background fill.
You need to have that set in all pen sets to be a colour that you want to use.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

KeesW
Enthusiast
Hello Barry
Thank you for your suggestions. I had done all that (except to change pen 103) and have now done this. It still doesn't work (see my attachment).

Archicad obviously can't do it and certainly hasn't got enough instructions to find where the green is generated and how to fix it. Central Innovation say that it is a user and not a technical issue. I've wasted enough time on this - thank you all. https://archicad-talk.graphisoft.com/download/file.php?mode=view&id=42905
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Barry Kelly
Moderator
Pen 103 is definitely white for that pen set.
So when ever you are using that pen set, anything using that pen should be white.

Unless there is a Graphic Override or Renovation Filter active that is changing that particular pen colour.
I know you say you have checked those, but try switching to a different GO and reno filter to see if that makes any changes.
If it does, then that is where the issue is.

Short of that I am out of ideas and would need to actually see the file in question.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Laszlo Nagy
Community Admin
Community Admin
Kees,

If you provide us with a file, we can take a look at it.
Just save the file under a new name, delete everything not completely necessary so the issue is still present.
Then upload it to Dropbox or similar and post the link.
I am becoming more interested in this issue because there must be a reason for those green fills.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

KeesW
Enthusiast
I have found the cause. I didn't check Glazing panel surfaces > Plan view attributes. I expected this stuff to be in Display Options and never thought of looking in a glazing section. I feel a bit stupid now, having made such a song and dance about and getting so many responses from puzzled users. My apologies to you all.
Cornelis (Kees) Wegman

cornelis wegman architects

AC 5 - 25 Dell XPS 8940 Win 10 1TB SSD 2TB HD RTX 3070 GPU
Desktop: Archicad 5.5 - 25, Win10 64, Core i7 , 16 GB RAM, NVidia GTX560 Ti, 1.5TB HD, 500GB SSD

Laptop: Archicad 16 - 24, Win10 64 Core i7, 8GB RAM, 2GB NVidia GT 540M

Laszlo Nagy
Community Admin
Community Admin
But in the end, you found the cause, which is a good thing.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!