Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

OPEN GL in V25

Tom Krowka
Booster

Hello all.......Am running V25...just upgraded.   I noticed that in the 3D styles dialogue box (after opening a 3D window) I only have engine choices of vectorial engine and hardware acceleration.     Is open GL not available any more?  Is my graphics card outdated?    Have been running V24 and it still shows up on that version.  

Thanks Tom 

Tom Krowka Architect

Windows 10, AC Version 25

Thomas@wkarchwk.com

www.walshkrowka.com
1 ACCEPTED SOLUTION

Solution
Laszlo Nagy
Community Admin
Community Admin

Archicad runs on both Windows and Mac, so I guess Graphisoft developers had two choices:

1. Keep calling it "OpenGL Engine" on Windows, and "Metal Engine" or something similar on Mac.

2. Come up with a naming that can be used on both platforms.

So they chose option 2., and renamed it to "Hardware Acceleration".

 

If you see textures in 3D, you are using OpenGL on Windows since the Vectorial Engine can not display textures.

CineRender was never available in the 3D Viewpoint.

In the Surfaces Dialog, you should have 3 options in Ac25 in the "Engine Settings" field:

  • Basic Engine
  • Cineware by MAXON
  • Hardware acceleration.

Is Cineware available in the "Engine" field of the PhotoRendering Settigns Palette?

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

10 REPLIES 10

runxel
Mentor

It has been renamed, since on Mac there is no OpenGL any longer (which has been replaced by Metal). Thus a more general term has been used.

AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Tom Krowka
Booster

Am running Windows 10, not MAC.  What is Open GL renamed to?  And how can I determine if it's running in any of the 3D views.  Am also missing Cinerender engine both in the 3D views and surface textures dialogue box. 

 

Thanks Tom 

 

Tom Krowka Architect

Windows 10, AC Version 25

Thomas@wkarchwk.com

www.walshkrowka.com

Solution
Laszlo Nagy
Community Admin
Community Admin

Archicad runs on both Windows and Mac, so I guess Graphisoft developers had two choices:

1. Keep calling it "OpenGL Engine" on Windows, and "Metal Engine" or something similar on Mac.

2. Come up with a naming that can be used on both platforms.

So they chose option 2., and renamed it to "Hardware Acceleration".

 

If you see textures in 3D, you are using OpenGL on Windows since the Vectorial Engine can not display textures.

CineRender was never available in the 3D Viewpoint.

In the Surfaces Dialog, you should have 3 options in Ac25 in the "Engine Settings" field:

  • Basic Engine
  • Cineware by MAXON
  • Hardware acceleration.

Is Cineware available in the "Engine" field of the PhotoRendering Settigns Palette?

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

Cineware does show up in Photorender settings.   Thanks for the info.   I thought I had missed something when loading up V25.  Tom 

Tom Krowka Architect

Windows 10, AC Version 25

Thomas@wkarchwk.com

www.walshkrowka.com

Thanks for the explanation and makes sense to align the reference. I’m wondering if there’s also been a change in setting as my models appear jaggy on screen in v25 compared to v24. To test this I created a simple 3D view of the same shape starting a new file from the same templates (only the relevant versions) and noticed that v25 3D views still look much more jaggy edges compared to v24. I just updated 25 to build 4013 to check and it’s still the same. All view settings and overides are exactly the same. 

Am I missing something new in v25 to adjust? I've added a side by side screenshot of the simple walls comparing the edges in 3D.  


3D styles v24 to v25.jpg
AMD Ryzen 5 5600X 6-Core 4.60 GHz | 32 GB RAM |M.2 500GB + M.2 1TB | 2x Dell 27” | WIN 10 Home 64
NVidia GeForce RTX 3060 12GB (Studio Driver)
Archicad 24 | 25 (Since v12)

In AC25, is the "3D Antialiasing" checkbox checked in the "Advanced Redraw Options" page of the Work Environment Dialog?

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

I checked that and it is checked. Set to the same as AC24  

AMD Ryzen 5 5600X 6-Core 4.60 GHz | 32 GB RAM |M.2 500GB + M.2 1TB | 2x Dell 27” | WIN 10 Home 64
NVidia GeForce RTX 3060 12GB (Studio Driver)
Archicad 24 | 25 (Since v12)

Hello! I have the same problem here. The only difference that I saw between AC24 and AC25 is that in AC25 there's no more OPENGL in the 3D Engine checkbox. 


AC24 vs AC25.JPG

OpenGL is now called "Hardware Acceleration".

 

It does not look so bad on my screen (I do not have a high res monitor).

There is slight pixelation, but it is not annoying.

 

However if I go into the Work Environment and turn "3D Antialiasing"  on or off, I can't tell the difference.

But I don't see any difference in 24 either.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

haymont
Participant

Sorry haven't replied. I noticed an improvement when I set up my preferred Work Environment and brought in some 3D styles from V24. Checking and unchecking the box for 3D Antialisng (Harware Accelerated mode) in the Advanced Redraw Options didn't do much to be honest.

I do definitely see a jaggered contour if I use the template 3D style settings over my own previous settings. The strange thing is if I match the settings of a 3D Style from v24 inside v25 it's not much help but if I import a v24 3D style it seems to help even though the exact same settings are ticked. Quite weird but it at least resolved it.         

AMD Ryzen 5 5600X 6-Core 4.60 GHz | 32 GB RAM |M.2 500GB + M.2 1TB | 2x Dell 27” | WIN 10 Home 64
NVidia GeForce RTX 3060 12GB (Studio Driver)
Archicad 24 | 25 (Since v12)

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!