Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Omitting Beam Segment and Column Segment from Schedule of Elements

Voytek
Contributor

Could anyone please advise how to omit Beam Segment and Column Segment from Schedule of Elements in AC25. I just would like to show Beam and Column. Thanks.

ArchiCAD Versions 5.0 - 25 (except 19) - Windows 10 Pro for Wokstations - Lenovo P70 - 2.8GHz Intel Xeon - ThinkPad Display 720 x 1280
2 ACCEPTED SOLUTIONS

Solution
Barry Kelly
Moderator

In the schedule selection criteria, add a field 'Element type IS beam' or 'Element type IS NOT beam segment'.

Just depends how you want to do it.

The same goes for the column.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

Solution

Thank you Barry for the quick response and another helpful reply.

ArchiCAD Versions 5.0 - 25 (except 19) - Windows 10 Pro for Wokstations - Lenovo P70 - 2.8GHz Intel Xeon - ThinkPad Display 720 x 1280

View solution in original post

13 REPLIES 13

Solution
Barry Kelly
Moderator

In the schedule selection criteria, add a field 'Element type IS beam' or 'Element type IS NOT beam segment'.

Just depends how you want to do it.

The same goes for the column.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

View solution in original post

Solution

Thank you Barry for the quick response and another helpful reply.

ArchiCAD Versions 5.0 - 25 (except 19) - Windows 10 Pro for Wokstations - Lenovo P70 - 2.8GHz Intel Xeon - ThinkPad Display 720 x 1280

View solution in original post

Hello,

When there are simple rectangular beams and Huanch beams (contains 3 segments) designed with segment option,

then it is not possible to list all beams in one single schedule. I have to list Hunch beams separately.

Is there any solution for it?

AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram - 16.0 GB
System - Windows 10 Ultimate, 64 bit

NVEDIA GForce 8400GS

Archicad 9..., 24

Laszlo Nagy
Community Admin
Community Admin

Could you show us a screenshot of how the Scheme Setup Dialog is set up and what is the resulting Schedule?

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Hi Laszlo Nagy,

Here are  screen shots.Haunch beam.JPGProperty manager 2.JPG

AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram - 16.0 GB
System - Windows 10 Ultimate, 64 bit

NVEDIA GForce 8400GS

Archicad 9..., 24

Laszlo Nagy
Community Admin
Community Admin

Change your Criteria so it is:

 

Element Types IS Beam OR

Element Type IS Beam Segment

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Hi Laszlo Nagy,

Here is I am sending screenshot by doing changes as you suggested though I have already tried it before.

Fields marked with arrow are not needed but still they are being listed, thus making quantities double or extra. (Same problem is coming with Coumn schedule too)Haunch beam 1.JPG

 

AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram - 16.0 GB
System - Windows 10 Ultimate, 64 bit

NVEDIA GForce 8400GS

Archicad 9..., 24

That is because in your criteria you have both beam or beam segment.

A beam is a beam and has beam segments - that is why they are listing twice.

 

You want just one in you criteria.

If you want just the entire beam, just use beam.

If you want info on each beam segment, then use beam segment.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Hi Barry Kelly,

Thanks for suggestion but if you see earlier post in this thread, i have done it that too.

This problem occures when simple rectangular beam and segmented beams comes together in a project and we need schedule for simple beam as normal but for segmenetd beam we need listing for individual segment.

AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram - 16.0 GB
System - Windows 10 Ultimate, 64 bit

NVEDIA GForce 8400GS

Archicad 9..., 24

Laszlo Nagy
Community Admin
Community Admin

Modify the Element IDs of those Beams and Beam Segments so that the Element ID of those Beams and Beam Segments you do not want in the Schedules have a certain value, then add to the Criteria:

 

Element ID "IS NOT" <whatevervalue>

 

Then, those Beams and Beam Segments that have <whatevervalue> for Element ID will not be included.

If you do not have to use the Element ID for this, you can also create a new Property, make it available for Beams, and use that, set one value for Beams and Beam Segments you want to be included in the Schedule, and set another value for Beams and Beam Segments you do not want to be included in the Schedule. Then modify the Criteria to filter out the Beams and Beam Segments you do not want in the Schedule.

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Thank you so much!

Finally got the answer by both ways.

Actually, I have tried this by using ID option but may be I was making mistake somewhere in scheme setting dialog box.

Sharing both screen shots here.By ID.JPGBy property.JPG

AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram - 16.0 GB
System - Windows 10 Ultimate, 64 bit

NVEDIA GForce 8400GS

Archicad 9..., 24

Laszlo Nagy
Community Admin
Community Admin

The AND and OR logical operators have priorities: the AND logical operation is executed before the OR logical operation.

You need to put your two "Element Type" criteria in parentheses, and also put your two "Element ID" criteria in parentheses:

 

BeamCriteria.png

If you don't use parentheses, then the following will be included in the Schedule:

1. All Beams

2. All Beams Segments the Element ID of which start with "BEAM"

3. All elements the Element ID of which start with "HA"

 

However, if you use parentheses like on the above screenshot, then the following will be included in the Schedule:

All Beams and Beams Segments the Element ID of which starts with "BEAM" or "HA".

 

Actually, from your previous screenshots, this may not even be what you want. Maybe you want the following will be included in the Schedule:

1. All Beams the Element ID of which starts with "BEAM".

2. All Beams Segments the Element ID of which starts with "HA".

Let me know if this is the case.

....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Yes, I will keep parentheses part in my mind.

Element ID criteria option is good and what is needed here.

Thank you so much!

There is another issue regarding listing, I will come up soon with screen shots.

AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram - 16.0 GB
System - Windows 10 Ultimate, 64 bit

NVEDIA GForce 8400GS

Archicad 9..., 24

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!