Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Saving Labels in 23 and 24 - difference

lukaso
Booster
When I save 2D Objects with autotext elements I can Create my own labels. Great.

If I save 2D Objects with other labels as labels it works too!!! this is what i need. But it only works AC23 not in 24!?
Why not?

(In 23. it puts a "call" into the GDL)
Mac OSX - up to date

Archicad 6 to 25
10 REPLIES 10

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hello,

Thank you very much for the report and I am very sorry about the issue!

I was unable to reproduce the issue. Could you share with me a small PLA file containing the setup you used to create the label in Archicad 24 for further investigation?

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

runxel
Ace
Yeah, works for me as well.
Tried with the OOTB template and on Windows 10. No issues.
A "CALL" gets inserted just fine.
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

lukaso
Booster
Thanx you two!

Working on a Mac 10.14.6
AC 24 4018 GER Full

Still not working....put the here
https://www.dropbox.com/s/lmpny3b8j76p1lv/no%20call%20label%2024.zip?dl=0

Lukas
Mac OSX - up to date

Archicad 6 to 25

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hello Lukas,

Thank you very much for the file!

I saw that the label you're trying to save as a new custom label is "Classification and Properties Label" (or the equivalent in GER version). This label works by pulling out properties of the attached element (in this case, the wall). If you save this label again as a custom label (regardless of whether it comes with another 2D element or not), the function of the label will be lost, therefore it cannot display anything.

When I tested with Archicad 23, the same thing happens, so I don't know whether it works in any previous versions or not. Could you confirm whether the same workflow creates a usable label in previous versions?

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

runxel
Ace
Having access to file I understand the task at hand. Was slightly misunderstanding it first.

So yeah, it doesn't work in Archicad 24, but indeed, it does work in Archicad 23. Even stranger: just not with all labels tho, making it kinda erratic.
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

lukaso
Booster
Hi Minh,
the function of the label will be lost, therefore it cannot display anything.
I cannot confirm that!

In 23 exactly the same thing works. You can download the testlabel here.

https://www.dropbox.com/s/xr1yque6ei4eu92/no%20call%20label%2023.pln?dl=0

Lukas
Mac OSX - up to date

Archicad 6 to 25

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Lukas,

Thank you very much for the file!

Unfortunately, I was still unable to create a working label using the given file on AC23 GER and INT, running different builds (5010 and 6004). I will ask my colleagues for more info about this. As soon as I have an answer I will let you know!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Lukas,

I asked the help of my colleagues to see why the label creation worked for you but not for me. It turned out that this function worked on Archicad 23 GER, but it never worked on INT version. In Archicad 24 GER, this function also did not work. Let me ask the developers to see why it behaved like this. As soon as I have an answer I will let you know!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

lukaso
Booster
Thanx Minh!

Looks like I found a german Easter Egg

Mac OSX - up to date

Archicad 6 to 25

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hello,

I have received an answer from the developer: saving an associative symbol label as a GDL object is not prohibited by AC, but it is strongly contraindicated because the result is unstable. Most important technical reason: labels receive some of the important information through GDL globals, which have wrong values in the saved Library Parts when placed as labels (their "original" values were hardcoded into the saved Library Part's GDL script). In the Classifications and Properties label's current implementation, this might not cause a problem, but other labels (or this label's later implementations) might show absolutely bad information after saved as a new label libpart.

The workaround here is: with associative labels, if you uncheck "Hide with associated element" in the Lable's Settings Dialog. So if you uncheck this, the new label will appear with the correct saved label.

I hope this explains the situation. Please let me know if you have any further questions!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!