Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Stairs underfloor to be hidden

tomyg
Participant
Is there a way to make the stairs be hidden under the floor?

I have the floor coming in over the first two treads but on the upper floor i cannot make them to be hidden under the midfloor. I have the mid floor slab setup with a solid white fill. I can make it display correctly with display orders but then the display orders on the lower floor are the same resulting in the stiars and walls not displaying correctly.

Surely i'm over looking something? I can't beleive a program of the level wouldn't be able to do this. Previously i've just been "masking" the bottom two treads with a white fill - not ideal.
4 REPLIES 4

Marc H
Beginner
There are a couple of things you may want to check. The first is that you have an opening in your floor above and that it is visible in your view. The other thing is the Floor Plan display settings of your stair.

Here is a quick sample wherein I inserted a stair, created an opening (shorter than the full run stair as you noted) and adjusted the Floor Plan display settings for both the Relevant Story and Above Relevant Story. I did not make other improvements (e.g., solid outline of slab opening, rails, etc.), but just to give the basic idea 'out-of-the-box'.

I hope this helps.
“The best thing about the future is that it comes one day at a time.” - Abraham Lincoln

AC24USA on 16” MBP (2.4GHz i9 8-Core, 32GB DDR4, AMD Radeon Pro 5500M 8G GDDR5, 500GB SSD, T3s, Trackpad use) + 2 Asus ProArt PAU32C (4K)

tomyg
Participant
Seems to be not possible. I've tried setting it as you've showd but with no luck. The only way i can get it to work and by using the draw order and pushing the stairs to rear but then it doesn't display on the ground floor correctly and i also use the down/ up text on the first floor.

jl_lt
Newcomer
i ve encountered this too. it would be nice if archicad detected more easily when things are on top of other things, specially slab related stuff. but i understand there are many situations where it doesnt apply so i guess thats why they leave it up to the user to fix it with the display order.

The only way i have found is using cover fill for the slab and then sending the stair to the back, and then in the ground floor you send the ground floor slab to the back too so you can see the stair in ground floor.

also, make sure in your absolute display límits that you are not displaying below the current floor plan.

Barry Kelly
Moderator
jl_lt wrote:
The only way i have found is using cover fill for the slab and then sending the stair to the back, and then in the ground floor you send the ground floor slab to the back too so you can see the stair in ground floor.

Exactly what you have to do.
Without a cover fill, you only see the slab outline in plan.
So you need to add the cover fill to a slab so you can see the surface in plan.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!