cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Text Editing

jss
Contributor

My husband uses Archicad 20. He double clicks the mouse to edit text without having to right click the mouse to get into the text to edit. Due to a disability he cannot right click the mouse so this double click option is important.  Today this option stopped working, and we do not know how / where to find that option to turn it back on.  Would appreciate any help.

Thank you, Jill

1 ACCEPTED SOLUTION

Solution
Rex Maximilian
Advisor

I just tried it and it works... I think what may be happening is that you have your magnet/quick selection button turned off in your Info Bar. When "off" you can NOT double click on text to edit. When turned "on" then you can. I just tested it and it works.

 

Screen Shot 2022-08-05 at 10.24.27 AM.jpg

Rex Maximilian, Honolulu, USA - www.rexmaximilian.com
ArchiCAD 25 (user since 3.4, 1991)
16" MacBook Pro; M1 Max (2021), 32GB RAM, 1 TB SSD, 32-Core GPU
Creator of the Maximilian ArchiCAD Template System

View solution in original post

12 REPLIES 12

Lee Hankins
Advisor

If you press and hold alt (option on mac) on the keyboard and click the mouse to pick the properties of the text up it will auto activate the text tool and then you can single click in the text to edit it. I’ve not used double-click before. Maybe there is an accessibility option in the computer preferences to activate that feature which may have turned off. 

Lee Hankins
ArchiCAD 4.5 - ARCHICAD 26UKI Intel 3010 and Apple Silicon
macOS Monterey (12.5)

I have tried highlighting the magnet as suggested and that doesn't seem to do it. I hve tried the idea Lee mentioned. But he can only use one hand. I am now sure it is in the accessibility option in the computer. preferences. Thanks for the suggestions.

You may be able to set a selection of keyboard shortcuts with a single letter to activate certain tools like ‘T’ for text. I haven’t tried it so I’m not sure. Then you can click and edit the text after activating the tool. 

Lee Hankins
ArchiCAD 4.5 - ARCHICAD 26UKI Intel 3010 and Apple Silicon
macOS Monterey (12.5)

Solution
Rex Maximilian
Advisor

I just tried it and it works... I think what may be happening is that you have your magnet/quick selection button turned off in your Info Bar. When "off" you can NOT double click on text to edit. When turned "on" then you can. I just tested it and it works.

 

Screen Shot 2022-08-05 at 10.24.27 AM.jpg

Rex Maximilian, Honolulu, USA - www.rexmaximilian.com
ArchiCAD 25 (user since 3.4, 1991)
16" MacBook Pro; M1 Max (2021), 32GB RAM, 1 TB SSD, 32-Core GPU
Creator of the Maximilian ArchiCAD Template System

Well… you learn something new every day. Does it work if you temporarily activate quick select with the space bar and double-click?

Lee Hankins
ArchiCAD 4.5 - ARCHICAD 26UKI Intel 3010 and Apple Silicon
macOS Monterey (12.5)

Yes, but if you hold the space a millisecond too long it starts typing spaces 😂

Rex Maximilian, Honolulu, USA - www.rexmaximilian.com
ArchiCAD 25 (user since 3.4, 1991)
16" MacBook Pro; M1 Max (2021), 32GB RAM, 1 TB SSD, 32-Core GPU
Creator of the Maximilian ArchiCAD Template System

I get that all the time when I have changed a Layout name and then use spacebar to quick select on the open model window, it ads a load of spaces to the end of the name and then errors when they are published! 🤦🏻

Lee Hankins
ArchiCAD 4.5 - ARCHICAD 26UKI Intel 3010 and Apple Silicon
macOS Monterey (12.5)

Hello, you suggesting about the magnet/quick selection does work. My earlier response about this was incorrect. With the magnet on it is working.  Thank you so much

Laszlo Nagy
Community Admin
Community Admin

Currently I do not have Archicad with me but as far as I remember, there is a way of entering edit mode in the Text Tool. If you have the Text Block selected, you can press CTRL+ENTER, or CTRL+ENTER on the numeric pad instead of the normal ENTER key, and Archicad will enter the Text Editor. 

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

I have just checked this today, and I am sorry to say, but it does not seem to work. I could not find a key combination that would enter the Text Editor when a Text Block is selected.

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

The OP was asking about double-clicking on selected text and editing. It was because their magnet/quick select button was turned off. It's been resolved and is working.
👍

 

However, regarding your method of hitting the enter key, if the text is selected and the cursor is "floating" above the selected text, hitting return or enter will make open the text editor.

Rex Maximilian, Honolulu, USA - www.rexmaximilian.com
ArchiCAD 25 (user since 3.4, 1991)
16" MacBook Pro; M1 Max (2021), 32GB RAM, 1 TB SSD, 32-Core GPU
Creator of the Maximilian ArchiCAD Template System

Laszlo Nagy
Community Admin
Community Admin

Rex, you are right. The cursor floating above the selected Text element was the missing piece for me. My cursor was somewhere else and this is why pressing the ENTER key did not open the Text Editor.

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!