Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Wall intersection, shallow angle

Titiriga
Newcomer
Hello, I have a problem.
When I have 2 walls that intersect at a shallow angle, the intersection becomes the continuation of one of the walls instead of the bisector of the angle between them. All the walls use the same building material.
To illustrate the problem, I've presented a situation where a shallow angle between two equal thickness walls affects a adjacent wall that has a smaller thickness.
The problem only becomes visible in 3D, in 2D it looks fine (if you select the walls one by one the problem becomes visible in 2D as well, but otherwise it looks OK)
Thank you.
5 REPLIES 5

Laszlo Nagy
Community Admin
Community Admin
What happens if you set the Intersection Priority of the right thick Wall to a higher value, so that it is higher than that of the right thick Wall?
I guess that that right now the two Walls have the same Building Material, so it is random that the left Wall's body cuts the right Wall's body (or maybe the Wall drawn earlier will cut the Wall drawn later, possibly). But if you set the Intersection Priority of the right Wall higher, IT should cut the left Wall. At least this is how it works in my ARCHICAD 23 copy when I tried it.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

James B
Graphisoft
Graphisoft
This article on helpcenter should help describe it as well:
https://helpcenter.graphisoft.com/user-guide/88747/
Technical Product Manager, Graphisoft

Anonymous
Not applicable
Hello,
I am new to Archicad (testing it out - AC 23 build 3003) since I decided to switch to BIM or leave architecture.
I have a design situation like this:
Wall junction with shallow angle (ca. 170 degree) and in distance of ca. 1m from the junction the construction of the wall changes (different composite wall: thinner insulation different cladding etc. etc.) -> picture 1


Problem description: The junction is solved incorrectly: the wall partition on the left side (wall no.1) intersects correctly with short partition with same material definition, however it intersects further incorrectly with the partition on the right side – there is an iron/thorn shaped volume of the left wall partition (wall no.1) that lives inside brick wall on the right. -> pictures 2-4


The easiest fix would be to force the shallow wall junctions to join by bisector. (In my opinion it should happen when both junction order values are set equally. I do not see a practical reason for randomizing the junction type when order values are equal). It seems AC is implementing the bipolar junction when executed on noticeably short wall partitions -> pic. 5 (if I delete the brick wall on the right the junction works as demanded.
Is there a way to force bipolar junction between the walls? Thanks for help!

runxel
Mentor
This behaviour was changed in AC 23 (or 22?), actually.
Before that it was indeed more like a miter cut.
The change made scheduling more reliable, but there were other complaints with the walls display now.

So, regarding you issue: Try to lower the Junction Order on the longer wall.
What this does is more like to "shift" the problem to the other side, but it shouldn't cause any trouble now.


EDIT: But I still support the request for an optional miter cut for walls.
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi Maciej,

Thank you for your question, and welcome to Archicad!

As runxel mentioned, this is indeed a limitation with the current method of intersection in Archicad (before Archicad 17). We can always switch back to the old intersection method by going to Options > Project Preferences > Legacy, tick the checkbox "Use legacy intersection...", but I would not recommend this, as it may bring some potential issues when the project grows.

I entered it as a wish in our Wish List database to improve the current intersection method (please refer to it as #12899). Hopefully, our Product Management team will adopt this one in the future!

Thank you very much for your understanding. Have a great day!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!