Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Document & Visualize forum

Why do my lights not export to Artlantis

Not applicable
Hi all,

Why do my lights in ArchiCAD not export to Artlantis, they appear in Artlantis but i cant alter them and they dont admit any light?


Sorry, one more idea

It might be that your just NOT SEEING the light effect because of the sun..

In the HELIODON tool, create a new Heliodon and turn the CLOCK to midnight...

Don't forget, you have to ACTIVATE that heliodon IN CURRENT VIEW also..
(so right click on the name of the heliodon in the controller palette and choose ACTIVATE IN CURRENT VIEW).

Visual Frontiers

AC25 :|: AC26 :|: Enscape3.4:|:TwinMotion

DellXPS 4.7ghz i7:|: 8gb GPU 1070ti

Karl Ottenstein
Lockers wrote:
Hi guys,

What am i missing here!! I've attached a screen shot of my model in Artlantis, how do i: A) add lights in Artlantis and B) how do i control the ones I've exported from ArchiCAD?????

Have you worked through the (albeit limited) user manual / help file? There are zillions of settings in Artlantis that you will not discover without readying about them.

You have to understand that Artlantis has views, somewhat like ArchiCAD. So, in the Perspective Inspector (shown below), you can choose which of several heliodons (suns) to use and you can enable as many (or none) light 'groups' as you want, as well as control layer visibility. All of this is saved with a view. There are perspective, axo and many other views.

So, if you do not have a heliodon selected and your light groups checked, it does not matter if the lights are on in the light groups, or that the sun is bright - nothing will be lit.
perspective inspector.gif
One of the forum moderators   •   AC 26 USA and earlier   •   macOS Ventura 13.2.1, iMac Pro 10-Core, Radeon Pro Vega 64

Karl Ottenstein
Lights in Artlantis are created in the Light Inspector shown here. You have 9 basic lamp types to choose from as shown ... then power, color, falloff, etc ... and of course location. By opening the 2D window, you can position your lights within your ArchiCAD fixtures.

You can drag multiply existing lights and more ... see the videos on the Artlantis web site ... a lot of useful training tips there. Note that you can lock (the padlock icon) a light or any other object so that it can't accidentally be moved once you have it where you want it.

You can name/rename your light groups and add lights to them by opening the 'tray' seen in the screenshot.

One of the forum moderators   •   AC 26 USA and earlier   •   macOS Ventura 13.2.1, iMac Pro 10-Core, Radeon Pro Vega 64

I know this is an old thread but for anybody reading this in future might want to check the following:
Make sure that in the 3D perspective window they are using to export to Artlantis has the lights turned on. To check go to Document / Creative Imaging / Photorendering settings. Select Internal engine and then tick the checkbox next to lights as it is off by default for me.
Once you have done this it activates the greyed out checkbox for lights in the artlantis export window. Check the box and lights should now be present in your artlantis project.
Freelance architectural technician from Staffordshire, UK.

32 years experience

Archicad (v11-25).

Windows 11 on 32gb 11th Gen Intel(R) Core(TM) i7-11700K @ 3.60GHz
Nvidia RTX A4000

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!