Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

loaded image texture changes color!

Anonymous
Not applicable
hi everyone!

i'm trying to load an Image texture to render a tiled floor. (see attachments) the tiles should have brownish colours but when i use the cinerender to render it changes to greenish gray? in the internal renderer the colours are fine so the Image is correctly loaded.

any ideas on how to preserve the image's natural colours during Rendering?

thanks

Unbenannt.PNG
11 REPLIES 11

The colour changes, because it is hit by light, which in turn has a colour. It can also be reflecting some of the surroundings, etc etc.

You can try changing the colour of sun / other light sources to close to white, but if you are aiming for photo-realism, this might not be what you want.

Floors especially are affected by light, as they catch a lot of it. The same material on a wall, ceiling or floor, will look different, due to the amount of light that is hitting it.

Also take a look at the reflective settings of the surface in the cinerender settings.

Read up on all the surface channels, to see how they react to light etc http://helpcenter.graphisoft.com/guides/archicad-19-int-reference-guide/user-interface-reference-2/d... to make a better attempt at solving the change in colour.
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Anonymous
Not applicable
hmm i've worked my way through all the Settings and cahnged the sunlight and Skylight Colors to White. but as you can see the Colors are wrong in the Settings window . that is before it is even rendered 😕

alemanda
Beginner
sometime the default windows photo viewer applies a different color profile to the picture ... especially jpgs
AC 19 and AC21 latest hotfix
Win 10 Pro 64bit
Double XEON 14 CORES (tot 28 physical cores)
32GB RAM - SSD 256GB - Nvidia Quadro K620
Display DELL 25'' 2560x1440
www.almadw.it

Anonymous
Not applicable
interestingly the Colors are displayed correctly in the internal engine mode 😉 .. i'm clueless.

Internal engine uses the internal sun settings (see below), cinerender does not use that.

As you can see, I've set the sunlight and ambient light to pure white there as I got 'tired' of having to adjust for the colouring in openGL view/internal engine.

Cinerender is a very advanced renderer, which sometimes, unfortunately, means there are a lot of settings to adjust.

Maybe start by ticking off settings in the detailed settings to see what is affecting the colour the most.
sun.jpg
Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-24 NED FULL
Windows 10 Pro
Adobe Design Premium CS5

Anonymous
Not applicable
Hi, If you can't get the right color with the light settings, here is another way to get the right color you want, by using the filter in the color channel of the surface.
Besides this have in mind that the diffuse color can also change the final appearance of the surface, and also the specular color.

http://screencast-o-matic.com/watch/cDhFI3ic76

Anonymous
Not applicable
Additionally to what I just told you, you can also play around with the mix mode in the color channel, using the multiply, add or substract mode (each one will give you different results), this way you can "tint" the final color of the surface.

Anonymous
Not applicable
Hi, in case you haven't found a solution, you need to add the texture to the cinerender settings

go to options - element attributes - surfaces.
find the surface that you want to edit and go to engine settings, choose cinerender.

check the color tab, then expand it , click image , in the settings page on the right choose filename, browse for the same texture u want to use and apply it there, you can play around with the other settings..

hope this helps..

PS. Im still trying to prevent my textures from tiling, if anyone has any ideas they are welcome

Lingwisyer
Virtuoso
coxy761 wrote:
Im still trying to prevent my textures from tiling, if anyone has any ideas they are welcome

You can change the physical size of the texture in the first tab in the CineRender settings, or next to the image in the Internal Settings. You will need to set it to be equal or larger than the surface you are applying the texture too. In that way it will not tile. The down side of this is the required resolution of the textures you use. An alternative is using a seamless texture as this will this will allow tiling without the harsh joints you are getting. With a bit of duplicating, blending and recropping, you can make a "seamless" texture in Photoshop from most unidirectional textures.



Ling.


ps. Coxy's post, and this reply, should be split from this thread as they are not relevant to the OP.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Win10 | R5 2600 | 16GB | GTX1660

Barry Kelly
Moderator
coxy761 wrote:
PS. Im still trying to prevent my textures from tiling, if anyone has any ideas they are welcome
I am not a rendering expert.
But your texture has a very big difference in colour from one side to the other.
It also has a fixed size, so a texture image will always tile based on that size, but you can control how they join.
In your image there is a setting to mirror x and mirror y - this will flip the alternate joining textures, rather than just laying them out next to each other.

Also in the 'Size' options, you can specify the size of the area you want your texture to fill.
Make this size bigger and you will get less tiling, but if you only have a small texture image, you will be stretching it and it may look bad.
Large texture images will allow you to cover a larger area without tiling, but may also slow things down.

Your other option is to not use a texture image at all, but use a procedural texture instead that will have no different edges, so you won't notice the tiling.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso
Barry wrote:
use a procedural texture

Give your texture is just a rough rendered surface, this might actually be the best option as there would be no repetition. The ridges can probably be made from a combination of Noise Channels within you Colour, Bump and possibly Displacement Channels with an additional combination under Diffusion.



Ling.
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

Win10 | R5 2600 | 16GB | GTX1660

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!