Choose your top Archicad wishes!

Read more
Documentation
About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.
SOLVED!

Change suffix of Zone value

Malin_AochD
Booster

Is there someone here who knows how to change the suffix/text after the value in a Zones value?

The standard is to display the zones area (in this example 33) and then add "m²" after it. I have a client who wants it to read "33 kvm". This is the extended word for square meter in swedish. Is there anyway to change the text after an automatic value like the area of the zone?

 

NOTE: I do NOT want to change the actual value (33) here in any way. I just want to replace the text after it from m² to kvm.

 

Anyone who knows how to edit the library part "Zonestamp 02 27"?

Is there anything I can do in propertys?

 

Malin_AochD_0-1713946047751.png

 

Operating system used: Windows

2 ACCEPTED SOLUTIONS

Accepted Solutions
Solution
Yves
Advocate

Hi Malin,

Sorry I opened the quantity_text_writer macro by keyboard shortcuts.
To open it you must do the same operation as you did with "Zone_stamp_macro" (see screenshot)

Object 24 is certainly compatible with version 27. I can send it to you but it is in French.
Is this not a problem for you?
I think the Zonestamp 02 is the same for many languages and archicad versions.
So I can also send you the two macros quantity_text_writer-SWE and quantity_text_formatter-SW.
You would then just have to load these objects into your library and replace "quantity_text_writer" by "quantity_text_writer-SWE" in your Zone_stamp_macro-SWE to keep your object in the language of your archicad

I already put the two macros in this post

 

Capture d’écran 1.png

Yves Houssier
Belgium
Archicad 19 -> 24
iMac - Mac Os 10,13

View solution in original post

Solution

Start off by creating a P_Set, and a property with a data type of String, the name doesn't really matter, just be aware of the fact that the name of the property will be displayed in the zone, In my example, the property's name is Areal: (The name of the property can be changed at any point)

 

Kamelite_0-1714136800219.png

Select Expression,  And make the same expression as you see in the attached image.

 

Its important to assign the correct value to it (in lack of a better term)

Kamelite_1-1714136962095.png

As shown, do this process for both the group, and the property itself.

 

Tag a zone, hit CTRL-T:

Kamelite_2-1714137352519.png

You might need to do some trial and error as to how you want your label to look.

 

Kamelite_3-1714137525825.png

Find the part of the settings that look like this, you might have another language. Enter first row, and at the Areal-property you just made. It is important to tick the "Show Classifications and properties", otherwise you will not get the desired outcome.

 

Do this in both 1:50 and 1:100, and you are, as far as I could tell, pretty much covered regardless of scale.

 

If this is something that you will use a lot, I would strongly recommend to make this a favorite in your TPL...

 

Hope this was of some help. And if you struggle to make it work, I don't mind sharing the file that contains the example.

 

 

.Kamelite

Windows 10, Archicad 27

View solution in original post

10 REPLIES 10
Ricardo Lopez
Expert

Hi @Malin_AochD 

 

There is a kind of easy workaround if you don't use (delete) the zone stamps and instead you create your own Text / Autotext label favorite using #Zone Name and #Measured area with that "kvm" as sufix.

Then you could select and delete all your original zone stamps and replace them by reselecting all your zones and Document> Annotation> Label Selected Elements.

 

Regards.

RicardoLopez_0-1713978193178.png

 

M. Arch. Ricardo López
BIM Consultant | Project Solutions and Services | Panama
AC17-27 SPA+INT | Windows 11 | MSI WE75 9TK, 32GB, Nvidia Quadro RTX 3000

Thank you Ricardo! This would be an okay work-around that I did not think of.

I would still prefer a way where I could just use a Zone and not additional elements. Does anyone know how to edit the Zonestamp in a way that would change the suffix?

Yves
Advocate

Hi,

It is possible but you will have to make a copy of the zonestamp and its macros
Here is a video where I do it in a few minutes

https://youtu.be/mqhyKB8Ajeo

Yves Houssier
Belgium
Archicad 19 -> 24
iMac - Mac Os 10,13

Thank you so much Yves!

It's not often someone takes the time to put together a personal youtube-tutorial for someone. Very kind of you!

 

Unfortunately my scripting abilitys are not quite good enough. I tried following your video but I get stuck when I can't open or save the text "quantity_text_writer".

 

I sent you a private message with my email adress. Is there any way you can send me the zonestamp you created?

Also; is this new zonestamp compatible with archicad 27? I noticed you created it in 24.

Kamelite
Advocate

Did this using properties and expressions...

 

Kamelite_0-1714072403276.png

Sufficient?

 

.Kamelite

 

Windows 10, Archicad 27

That would definately work! How did you do that in expressions and propertys?

Solution
Yves
Advocate

Hi Malin,

Sorry I opened the quantity_text_writer macro by keyboard shortcuts.
To open it you must do the same operation as you did with "Zone_stamp_macro" (see screenshot)

Object 24 is certainly compatible with version 27. I can send it to you but it is in French.
Is this not a problem for you?
I think the Zonestamp 02 is the same for many languages and archicad versions.
So I can also send you the two macros quantity_text_writer-SWE and quantity_text_formatter-SW.
You would then just have to load these objects into your library and replace "quantity_text_writer" by "quantity_text_writer-SWE" in your Zone_stamp_macro-SWE to keep your object in the language of your archicad

I already put the two macros in this post

 

Capture d’écran 1.png

Yves Houssier
Belgium
Archicad 19 -> 24
iMac - Mac Os 10,13
Solution

Start off by creating a P_Set, and a property with a data type of String, the name doesn't really matter, just be aware of the fact that the name of the property will be displayed in the zone, In my example, the property's name is Areal: (The name of the property can be changed at any point)

 

Kamelite_0-1714136800219.png

Select Expression,  And make the same expression as you see in the attached image.

 

Its important to assign the correct value to it (in lack of a better term)

Kamelite_1-1714136962095.png

As shown, do this process for both the group, and the property itself.

 

Tag a zone, hit CTRL-T:

Kamelite_2-1714137352519.png

You might need to do some trial and error as to how you want your label to look.

 

Kamelite_3-1714137525825.png

Find the part of the settings that look like this, you might have another language. Enter first row, and at the Areal-property you just made. It is important to tick the "Show Classifications and properties", otherwise you will not get the desired outcome.

 

Do this in both 1:50 and 1:100, and you are, as far as I could tell, pretty much covered regardless of scale.

 

If this is something that you will use a lot, I would strongly recommend to make this a favorite in your TPL...

 

Hope this was of some help. And if you struggle to make it work, I don't mind sharing the file that contains the example.

 

 

.Kamelite

Windows 10, Archicad 27

Thank you, Kamelite!

I managed to get it to work in my file! Excellent instructions with the step-by-step och images!

Setup info provided by author