Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Archicad 27 doesn't work on Intel-based iMac with AMD graphics card

fabioferrini
Enthusiast

Good morning Graphisoft,
in our office, we have 3 iMacs with AMD graphics cards, specifically AMD Radeon R9 and AMD Radeon Pro 580, running MACOS Ventura 13.6 and Archicad 27, but we're experiencing significant issues. After performing a few simple actions in the 3D window, the background of the window turns red, and from that point on, it becomes unresponsive. The mouse stops working in both the 3D and 2D windows. We can still save, navigate through menus and toolbars, but with no success. The only solution is to exit the program, which is very inconvenient. We're also encountering problems when trying to migrate files from AC26 to AC27 on BIMcloud as a service. Some files fail to load, and we receive a network connection error message right at the end of the process, causing Archicad to crash.

I'm sorry to have to be critical because we have been using Archicad since version 4.5, but paying for 3 biennial licenses in advance to Graphisoft for functional and cutting-edge software, I find it rather frustrating to find ourselves in this situation every time. A couple of years ago, when AC25 was released, we had a similar problem and had to wait six months before things were resolved. Reading in the forum, I see that we are not the only ones experiencing this issue with Intel-based Macs. I hope that someone from Graphisoft will let us know how to quickly resolve these common issues because we are not beta testers but paying customers. Thank you in advance for any assistance you can provide. Fabio Ferrini

1 ACCEPTED SOLUTION
10 REPLIES 10
TBuildConsultants
Participant

Thank you for this post and feedback @fabioferrini 
I have a 2019 Intel-based MacBook Pro with an AMD graphics card. I had considered doing the update from AC 26 today but perhaps its wise to wait. 

ArchiCAD user version 12 to 26
2019 Intel-based MacBook Pro (15-inch)
Mac OS 12.7 (Monterey)
Intel Core-i9 (2.3Ghz)
16Gb RAM (2400Mhz - DDR4)
AMD Radeon Pro 560X 4Gb
simoneciavatta
Newcomer

Good morning Fabio, thanks for your content.

I have the same problem working on an iMac with AMD graphic card. I hope Graphisoft will resolve the problem soon in order to use 27 version.

Simone Ciavatta

Marco De Luigi
Newcomer

Thank you Fabio for this post,

I have the same problem with iMac with AMD Radeon Pro 580. I hope Graphisoft will solve this problem in order to allow us to use the new software. 

Romans
Expert

Thank you, Fabio, for confirming this issue too and posting it here. IT NEEDS TO BE SOLVED VERY SOON GS!
It is a welcome addition to my post here:
AC27 IntelMacs: 3D view causes the freezing of all views

Apple iMac Pro with macOS Sonoma, AC 5.0 to 27 INT and GER, all the latest

Hopefully helpful input: I am running a solo AC27 release version on a 2019 MBP and it is functioning fairly well. It is slower, but that may be due to my settings and files.  I’ve also read comment that migration files (as mine are) may be slow. 

“The best thing about the future is that it comes one day at a time.” - Abraham Lincoln

AC27 USA on 16” 2019 MBP (2.4GHz i9 8-Core, 32GB DDR4, AMD Radeon Pro 5500M 8G GDDR5, 500GB SSD, T3s, Trackpad use) running Sonoma OS + extended w/ (2) 32" ASUS ProArt PAU32C (4K) Monitors
Solution
Frank Rutjens
Participant

Hello Fabio,

 

on the website of the Dutch distributor of archicad they mention a workaround: 

https://helpcenter.kubusinfo.nl/portal/nl/KB/articles/grijs-scherm-in-3d-en-geen-reactie-mac#Workaro...

 

Gray screen in 3D and no response (macOS) | 09-10-2023
Archicad 27 shows a gray screen when the 3D window is opened and then it does not respond.
This problem occurs only for computers (macOS) with a certain GPU, AMD and some Intel graphics cards.

Graphisoft is aware of this and has planned the fix for Archicad 27.

Workaround
Until then, it is recommended to deactivate '3D Antialiasing (with Hardware accelerated mode)' in the working environment:
Go to the Options > Work Enviroment > Advanced Redraw Options menu
Turn off '3D Antialiasing (with Hardware accelerated mode)

 

perhaps this helps?

 

Best regards,  Frank

Romans
Expert

This 'workaround' is not helping on our machines. No effect.

Apple iMac Pro with macOS Sonoma, AC 5.0 to 27 INT and GER, all the latest

Hi Frank, 

thanks a lot, the workaround works with new files created with AC27, problems persist with old AC 26 files converted in AC27. 

joelsdg
Enthusiast

I don't want to hijack your thread, and it may be entirely unrelated, but your issues seem vaguely similar to ones I've been experiencing.  And as a longtime AC user, I am also frustrated to find myself in this situation with the new versions of Archicad.

 

I have slow to almost unresponsive performance issues since AC26. AC27 is not any better.  I don't know if it related to my configuration, but as you can see in my signature, I also have an Intel processor with AMD Graphics, albeit in a 2019 MacBook Pro, running MacOS Ventura.

 

And we don't use BIMCloud, but I also get an unresolvable error ("Cannot save plan file") when trying to save an AC27 project to an AC26 project.  It may not be the same thing as your issue, but I can't help but think it is.

 

I'd like to hope the troubleshooters at Graphisoft can use this info to fix these problems.

Joel

AC 6.5-26; macOS Ventura; 2019 MacBook Pro 2.4gHz, i9

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!