Installation & update
About program installation and update, hardware, operating systems, setup, etc.

Foreign Language Fonts in Archicad

Anonymous
Not applicable
Does anyone know a way to turn off foreign language font styles eg Arial Greek, Arial Central European etc etc - its a pain scrolling down and trying to find fonts
11 REPLIES 11
Jacek
Contributor
You don't mention what system (Operating) you use. Fonts are controlled by the operating system.
If Mac, open the Fonts folder and delete -or move to a safe location, the unwanted fonts. Use the FontBook, it is in the Applications/Utilities folder. There are also special applications that allow you to select the unwanted fonts into separate packages.
jacek lisiewicz
----------------------------------------------
arkhos-tekton, architects
carmichael, ca

Mac OS X 10.15.5
IMac Retina 5K, Intel Core I7
32 GIG Memory, AMD Radeon R9
ArchiCAD 24
Anonymous
Not applicable
I use Windows 2000 P4 1.7 Ghz Archicad R8.1.0 R1 Australian (1410)
Anonymous
Not applicable
see:
ArchiGuide
Anonymous
Not applicable
Thanks for the link (content below) but it doesnt seem to remove any font sets only add them ....
How to See Foreign Characters of library parts in the Object Settings Dialog
Written by Balázs Biacs

How to see foreign (i.e. Russian) characters of library parts in the Object Settings dialog if using international ArchiCAD

E.g. the library of the Russian version 6.5 does not show russian letters when used in the international verison 7.0.

Do as follows:

Quit ArchiCAD.
Open the Registry editor. [Start menu/Run.../type "regedit" and run it]
Open the key:
HKEY_CURRENT_USER/Software/Graphisoft/ArchiCAD/ArchiCAD 7.0 INT/Font Description

Choose Font Script Code [doubleklick on it]. A small dialog appears: Edit DWORD Value.
First set the radio button on the right to the Decimal position, then enter 204 into the Value Data field, then choose OK.
Now if you open Your ArchiCAD 7.0 International, all menus will be displayed in English, but you'll have the Russian characters in the Object Settings dialog. If you would like to revert to the International settings, set the same value to 0 again.

Other values for other character sets:

ANSI_CHARSET 0
DEFAULT_CHARSET 1
SYMBOL_CHARSET 2
SHIFTJIS_CHARSET 128
HANGEUL_CHARSET 129
HANGUL_CHARSET 129
GB2312_CHARSET 134
CHINESEBIG5_CHARSET 136
OEM_CHARSET 255

JOHAB_CHARSET 130
HEBREW_CHARSET 177
ARABIC_CHARSET 178
GREEK_CHARSET 161
TURKISH_CHARSET 162
VIETNAMESE_CHARSET 163
THAI_CHARSET 222
EASTEUROPE_CHARSET 238
RUSSIAN_CHARSET 204

MAC_CHARSET 77
BALTIC_CHARSET 186
Rob
Graphisoft
Graphisoft
it is a good point Maurice, that scrolling drives me mad...
yes, it seems to be a problem to get the fonts filtered based on the local settings ('regional options' in case of Win) of particular OS and I do not think it is possible to change that with the current version of AC (after seeing the Archiguide link)
I will add it to the wish list.
::rk
Anonymous
Not applicable
This foreign font thing has always been a pain in the neck using ArchiCAD in Windows. I don't understand why it occurs since there is no such problem in any other program (AFAIK). It is clearly a Windows related problem since it does not happen on the Mac, but it does not seem to be necessary or inevitable since it doesn't occur in Word, Photoshop, etc. on Windows. It is also not properly a wish list item so much as a long standing bug which needs fixing.

Please excuse me if I am a bit of a curmudgeon, but this thing has always annoyed me.
Anonymous
Not applicable
i had a problem when i tried to open files made with Greek versions of AC(any version) into international versions.
The greek font displayed like chinese.
When i changed the value in the registry from 0 to 161 as Maurice said my problem solved.
Thank you Maurice!
Anonymous
Not applicable
What about MAC OSX? Is there any way to use foreign characters not only in the text box, but for example in the Project Info dialog.
How can I change font script code on OSX 10.4?
rubstein wrote:
see:
ArchiGuide
Anonymous
Not applicable
Switch to AC9! It os ok there!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!