Random crashes with macOS 10.15 or newer

Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni

Affected versions: Archicad 23, 24 | Severity: workaround applicable | ID: DEF-376, DEF-345, DEF-373

A small number of customers with AMD video cards from macOS 10.15 Catalina may experience heap corruption crashes in different scenarios while working in Archicad. They may seem random and they can happen multiple times throughout the day.

Issue

Archicad can crash randomly while:

  • Leaving it in the background;
  • Putting the computer to sleep when Archicad is still running;
  • Working with documentation;
  • Switching between multiple Archicad instances;
  • Switching to another application while Archicad is running;
  • etc...

There is no concrete answer to what could trigger this type of crash, as it appears randomly. If you are unsure, please contact your local support.

Cause

These crashes are caused by the AMD driver when it attempts to allocate the same resources that are already used by Archicad. The system either makes it inaccessible or reuses it for other purposes. 

Workaround

From Archicad 23 Update 3 (60xx) and Archicad 24 Update 2 (40xx), we implement a solution that will help to mitigate this issue via disabling Geometry Shader. 

Disabling the Geometry Shader will result in the following feature loss

  • The contour lines in OpenGL will be only 1 pixel
  • The size of the PointCloud’s will be 1 pixel instead of 2by2

To disable the Geometry Shader, we can use a Preferences editor program to edit the required PLIST. For more details, please check out our article on this topic.

We will demonstrate the workaround using Prefs Editor:

  1. Open Prefs Editor.
  2. In the Filter search field, look for the PLIST by typing its name, in this "case com.graphisoft.AC xx.0.0 <regioncode> v1.plist".
    • xx is your Archicad version (23 or 24)
    • <regioncode> marks the language version of your Archicad.
    • An example: com.graphisoft.AC 24.0.0 INT v1.plist.
      wp-content_uploads_2020_12_Screenshot-2020-12-22-at-11.30.30.png
  3. Select the PLIST file. Click Open.
  4. The file is opened in a new window. Enter "geometry" to look for the required key.
    wp-content_uploads_2020_12_Screenshot-2020-12-22-at-11.35.45.png
  5. Put a tick for "DisableGeometryShader" checkbox.
    wp-content_uploads_2020_12_Screenshot-2020-12-22-at-11.36.33.png

Once the modification is made, it is automatically saved to the PLIST file. We can close the window and exit Prefs Editor.

To reenable Geometry Shader, we can go through the same process as described above. In step 5, untick the checkbox "DisableGeometryShader" to enable Geometry Shader.

 
NOTE: Please contact your local support if Archicad still crashes with the workaround above.

 

Solution

This issue has been fixed in update 11.3 for macOS Big Sur. Please update your macOS to this version in order to prevent the crashes from happening.

Comments
mi_jan
Enthusiast

Is this workaround still required for Big Sur? 

I had done this process in the past when I was on Catalina, I need to work with some point cloud files, and with the "Geometry Shader" disabled it's proving almost impossible to use the point cloud as the points are so small that I can't really see anything when I get up close. 

Barry Kelly
Moderator

 

Is this workaround still required for Big Sur?

 

The very last sentence of this article reads...

BarryKelly_0-1646786714261.png

 

Barry.

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!