Libraries & objects
About Archicad and BIMcloud libraries, their management and migration, objects and other library parts, etc.

Why is ArchiCAD showing textures in my objects in 2D View?

lan_raleigh
Beginner
4 REPLIES 4
Karl Ottenstein
Moderator

That's not a texture, it is a fill.  For a library object to display an unusual fill like that, the attributes for your project file must have been modified so that the standard fills are not at the standard index numbers, or there is a graphic override affecting the normal fill for that basin.

 

If you open the Object Settings dialog and look for the fill parameter for the basin and it does not show the pavers (?) that are in your screenshot, then there must be a graphics override applied to your view.  If it shows the pavers, then either the fill has been manually changed for that instance of the basin... or someone has modified your fill attributes for the project file.

 

One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

It seems that the attributes are changed in the project file because it does show the paver texture in every object I place. Is there a way to reverse this?

You can use the Attribute Manager/Palette to overwrite the attributes "By Index Number" from the default template back into that file.

But be warned that this may mess up other attributes if this new file has been customised.

Try it and if you don't like the results, don't save the file.

Or you can overwrite just that one fill.

 

Attribute management is a bit of an art form.

If you are not watching what you are doing, it can get out of hand very easily.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
Lingwisyer
Guru

Is this a default AC object, or a 3rd party one? You could try editing the script if file attribute modification is not an option.

 

 

n = REQUEST ("Pen_of_RGB", "255/255 255/255 255/255", penindex)
PEN penindex

 

 

 

That will find the first fill in your file that is white and assign it to "penindex". You can change the 3 values to match whatever colour you want, R/255 G/255 B/255. Change "penindex" to "gs_fill_pen" or 

 

Why am I talking about pens when the issue is fills...

 

You could search the 2D script for a FILL command and replace the parameter after it with "Solid Fill" or the name of what ever fill you want to use.

 

 

Ling.

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win10 | R5 2600 | 16GB | GTX1660 

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!