BIM Coordinator Program (INT) April 22, 2024

Find the next step in your career as a Graphisoft Certified BIM Coordinator!

Modeling
About Archicad's design tools, element connections, modeling concepts, etc.

AC27 3d window performance broken on Windows, developers refusing to help

MASz
Enthusiast

I have been dealing with severe 3d performance problems in Archicad 27 (frame rate drops, stutter, unresponsiveness) that are not present in 26. 3d window is the default Detailed Shading, no shadows. These mostly affect medium sized projects. I have lodged a ticket through Central Innovation (reference number #142104) and have been discussing this issue for months. I am very reliant on using the 3d window for my modelling and it needs to perform properly for me to be able to work in Archicad.

 

So far the Graphisoft developers have failed to carry out a proper investigation or even attempt to understand what my issue is. They have come back with nonsensical responses that don't address anything I've raised.

 

The problem is so severe that I have been unable to use Archicad 27 and have had to stick with 26. I have attempted to investigate on my own, provide workarounds, provide videos demonstrating, perform cleans, run FastLogger and suggest avenues of investigation, PLA files. Yet, much of this has been ignored and misunderstood by the developers.

 

This is clearly an unacceptable state of affairs. I am still waiting for a proper response and to be actually able to use 27. This is on top of the 2d drawing infrastructure being completely broken with scaling. So, both the 2d and 3d are broken - I am trying to help and it hasn't gone anywhere so far.

 

I am not sure if this is just isolated to Windows and if other users are experiencing similar issues to me? I am also not sure what everyone else's experience is dealing with technical issues but I don't often hear much positive on that front.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
16 REPLIES 16
Lingwisyer
Guru

Your rant contains very little information for anyone on here to try to help you... Have you turned off Physically Based Rendering? Though thinking about it, maybe you are just here to rant...

AC22-23 AUS 7000Help Those Help You - Add a Signature
Self-taught, bend it till it breaksCreating a Thread
Win11 | i9 10850K | 64GB | RX6600 Win10 | R5 2600 | 16GB | GTX1660
MASz
Enthusiast

It's just regular Detailed Shading, no shadows. It's not physically based rendering I experience stutter, frame rate drops and unresponsiveness in medium sized projects (I have added this now to the main post). The same settings work just fine in 26. I am using top end hardware on a fresh installation of Windows. I have tried playing around with 3d Styles, looking at registry settings, nothing really works. Even generally it feels unusually unresponsive.

 

My workaround involves turning on shadows, and then moving around the project such that it disables the shadows while moving the camera. This somehow returns performance back to normal. The latest response I got from GS was something to the effect of - "shadows have always been slow", which doesn't address anything.


I have asked questions such as "what is different between Archicad 27 and 26 that the 3d window would perform so differently?" as a suggested avenue of investigation and received no explanation.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
Daniel Turanyi
Graphisoft
Graphisoft

I apologize for any inconvenience you've experienced. I want to inform you that the investigation is ongoing, and the ticket will not be closed until we have a proper answer to your problem.

Thank you for your patience.

MASz
Enthusiast

Thanks Daniel. Yes, I hope so. This certainly did not come across in the responses to my ticket so far, which seemed to leave me at a dead end. I am more than happy to talk 1 on 1 in a meeting if anything is unclear, but I have not been provided that opportunity.

 

I have since tested on other machines, but them being less powerful makes it harder to compare. I can at least say that the workaround seems to improve frame rates across the board, which is quite odd. The good thing is that my performance is better than ever after the workaround is applied - which does not happen in 26. My frame rates are at a silky 144, so Archicad is capable and feels very nice like this. But somehow it feels like 3d window is not activated properly by default? It's hard to provide detail here when I don't know what is going on really. Performance issues also affect Physically Based Rendering, but I am not sure if the issue is linked.

 

When it comes to unresponsiveness, it is typically with actions such as panning or activating 3d explore. There sometimes seems to be an unusually large delay.

 

I have tried messing around with NVIDIA program settings as well, but nothing there makes a difference.

 

Still, it does not seem that GPU is being properly utilised by default. The usage goes up after I apply the workaround. It goes from 25% to something like 50%. There has got to be an explanation for that kind of behaviour.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
Botonis
Advisor

What kind of mouse are you using?

Have you checked its polling rate?

Is there a possibility for a different polling rate between Archicad 26 and 27? 

Archicad can handle 500Hz but it is better to set it even lower 250 or 125.

Can you confirm this? 

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.
MASz
Enthusiast

Polling rate is 1000 with a G402 mouse. I have tried setting it lower but it makes no difference for 3d navigation. The 3d navigation is a problem using just the keyboard as well.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
Botonis
Advisor

It is strange that you could work with polling rate set to 1000.Even 500 which is considered the upper limit for archicad is problematic in both 2d and 3d.I have set it to 250 and both 3d and 2d are fine. Can you test another mouse with archicad.....? Have you checked your bios if EHCI

for usb3 is enabled. Disable XHCI. What confuses me is that 26 works fine with a same project. Have you used 3dGuru uninstaller for the NVIDIA driver to have a clean Gpu driver instalation?

 

Clean uninstall Logitech LGHUB and reinstall and set a profile for Archicad with a polling rate of 125.

Botonis Botonakis
Civil Engineer, Enviromental Design MSc., BIM Manager for BS ArhitectsVR
Company or personal website
Archicad 27. Windows 11. Intel Xeon 2699x2,64 GB RAM, Nvidia 3080Ti. 2 Monitors.
MASz
Enthusiast

I have tried with a different mouse and it is the same result. Everything is running off a fresh install with a new system drive/motherboard, but I also had the same problem with my previous install. Plus, it was similar behaviour on other computers I have tested, so it is not just isolated to my PC.

AC27 AUS, Windows 11, i9-13900KF, RTX3090, 128GB DDR5, 4k144 display
jl_lt
Ace

Thanks to prompt input from early users in this forum, we never updated to 26, much less 27.  Hope they fix this and get their act together in 28.

Learn and get certified!