Project data & BIM
About BIM-based management of attributes, schedules, templates, favorites, hotlinks, projects in general, quality assurance, etc.

Accuracy of calculations and display units in Schemes

gap
Booster

I need to display some areas in a scheme using "merge items". When I set the area unit in calculation units to have 4 decimals I get these values: 

gap_0-1701372914700.png

which add to 6,0000 when I check the "merge items" option. But I have 4 decimals in my display, which is not what I want.

When I set the area unit in calculation units to have 2 decimals, the same values display as:

gap_1-1701373141419.png

which add to 5,98. Now I have 2 decimals in my display but not the accuracy that I want.

 

Is there a way to calculate areas without rounding but display them to two decimals?

 

archiCAD 26
1 ACCEPTED SOLUTION
10 REPLIES 10
Barry Kelly
Moderator

@gap wrote:

Is there a way to calculate areas without rounding but display them to two decimals?


No.

If you are using a lower accuracy, then it will only total based on that accuracy.

If you want the higher accuracy, you must use more decimal precision.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

I came to this conclusion too. I'll have to copy this post to wishes

archiCAD 26

There is probably really not much to wish about.

If you are showing rounded figures, why would you want/need to show a total that does add up to those figures?

If you need a more accurate total, surely you would want more accurate individual figures?

Just my thoughts.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

My wish is simple:

I need the calculations to be as accurate as it can be, so I use 4 decimals in Calculation Units. When I merge them in my scheme the sum up, as expected, to the correct amount.

I wish there was a way to print this amount in my Scheme with two decimals instead of four.

When I set Calculation Units to 2 decimals, the merged total is calculated incorrectly due to the individual roundings.

archiCAD 26

@gap wrote:

When I set Calculation Units to 2 decimals, the merged total is calculated incorrectly due to the individual roundings.


0.77+0.77+0.96+0.96+1.17+1.35 = 5.98

It does not add up to 6.00 and would not make sense if that is the total you want to see.

 

There is nothing inaccurate about that.

It is totalling what you see.

 

If you want a more accurate total then use 4 decimal precision.

 

If I was to say 1+1 = 2.8, you would call me a fool.

But 1.4+1.4 does indeed = 2.8.

If you don't see all the figures, it makes no sense.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Barry, it's really simple: No roundings in calculations, they should sum up to 6,0000. We are OK so far. Can you point out a way for that 6.0000 to be printed in my drawings with 2 decimals? That is what is missing

archiCAD 26

So you want to show the 4 decimal accuracy in the individual values but you only want the total to have 2 decimals?

I didn't get that impression.

I am afraid you can't - the calculation units apply to the entire schedule.

 

I thought you are wanting to show the 2 decimal accuracy in the values but have it total to 4 decimals, but still only show the 2 decimals.

There is no way it can do that.

If you are using 2 decimal calculation units, it can not add the extra hidden decimal values - you have just told Archicad they are not important to you.

 

If you want 4 decimal accuracy, you have to use 4 decimal accuracy, but you can not tell it to then only show 2 decimal accuracy - the figures would not add up and it would not make sense.

The schedule can only add what you can see.

 

Barry.

One of the forum moderators.
Versions 6.5 to 27
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

I don't mind for the individual values. I'll only print the sum and I need it to be calculated correctly but to be printed with two decimals.

I found a sort of a workaround: If I set the Calculation Units to two decimals and also set extra accuracy to 01 then it is calculated and displayed as I want. But somewhere else in my table I get values with the extra accuracy in the form of an exponent, which I don't want.

archiCAD 26
Solution
gap
Booster

The solution was in front of my eyes and I didn't see it:

gap_0-1701422933239.png

There is an option in the Calculation Units menu for it. When I set it to 'Exact values' it works

archiCAD 26

Start a new conversation!

Didn't find the answer?

Check other topics in this Forum

Back to Forum

Read the latest accepted solutions!

Accepted Solutions

Start a new conversation!