cancel
Showing results for 
Search instead for 
Did you mean: 

macOS 10.15 Catalina

Ghaleb Khadra
Newcomer

Apple released the new macOS 10.15 Catalina on October 7, 2019.

wp-content_uploads_2019_07_macOS-Catalina-100x100.png

We advise you to proceed with caution when upgrading to macOS 10.15 Catalina. It is highly recommended to read the macOS and Archicad article to learn more about this process and see our recommendations.

GRAPHISOFT plans to maintain the compatibility of Archicad 22, 23, 24 and BIMcloud.

Archicad 21 and older will not be made compatible with this future macOS.

Important Note

Users installing Archicad for the very first time on their computer, which is running macOS 10.15 Catalina, will not be able to manage licenses using the LMT unless they update their WIBU driver.

To learn how to update the WIBU driver and for more information, read the License Manager Tool: Your WIBU-Key driver is missing on macOS 10.15 Catalina article.

 

Important Note

Customers with AMD video cards from macOS 10.15 Catalina may experience random crashes in different scenarios while working in Archicad. Please have a look at this article for more detail.

Next Steps:

I am considering to upgrade to macOS 10.15 Catalina

If you are considering to upgrade to macOS 10.15 Catalina, we strongly encourage you to read the entirety of this article and all the articles linked within it to fully get acquainted with the current situation regarding macOS Catalina and understand the risks.

Our advice is to consider postponing the migration if you currently have any business-critical project(s) ongoing.

Checklist:

☑ - Create a full system backup to ensure rollback possibility.

☑ - If you are using Archicad 22, make sure to update to Archicad 22 - Build 6025.

☑ - If you are using Archicad 23 or 24, then you are all set.

☑ - Make sure to grant Archicad Full Disk Access after migrating. Learn how here.

☑ - Make sure all GRAPHISOFT products are installed under the (/Applications/...) directory.

If GRAPHISOFT products are installed under a directory other than the default one (/Applications/...), the permission restrictions on macOS 10.15 Catalina will prohibit the programs from running reliably if at all. Please uninstall all products not on the default directory and reinstall them to the default one.

I have already upgraded to macOS 10.15 Catalina

If you already upgraded to macOS 10.15 Catalina, we highly advise you to keep up-to-date backups of your business-critical projects.

Checklist:

☑ - If you are using Archicad 22, make sure to update to Archicad 22 - Build 6025.

☑ - If you are using Archicad 23 or 24, then you are all set.

☑ - Make sure to grant Archicad Full Disk Access. Learn how here.

☑ - Make sure all GRAPHISOFT products are installed under the (/Applications/...) directory.

If GRAPHISOFT products were installed under a directory other than the default one (/Applications/...), the permission restrictions on macOS 10.15 Catalina will prohibit the programs from running reliably if at all.

Please follow these steps: (the uninstaller will not be able to uninstall the applications due to permission restrictions)

  1. Drag the folder(s) (e.g. Archicad folder) to the Trash and Empty Trash to ensure deletion.
  2. Install the product (e.g. Archicad) only to the default directory (/Applications/GRAPHISOFT/Product_Name).

About macOS 10.15 Catalina:

Security Features:

With the security changes implemented in macOS 10.15 Catalina, applications will not be able to access system files and run unless they are prepared for this new process. This implies that any application released before macOS 10.15 Catalina will not run reliably until it is made compatible.

Enhanced Gatekeeper

The changes in the Gatekeeper functionality in macOS 10.15 Catalina prohibits any application from running unless it is from the Apple Store or Identified Developers.

Code-Signing & Notarization

Non-Apple applications will be able to run only if they are from Identified Developers. Developers become Identified if their application(s) are checked and tested for malicious behavior by Apple and pass.

Dedicated System Volume

The new macOS 10.15 Catalina differs from its predecessors by having its own dedicated partition on the disk where only Operating System files are stored. Many applications request access to system files (for read/write purposes) however, access can be granted by the user only after Apple code-signs and notarizes the application.

For more information on access to system files, please read the Why does Archicad need Full Disk Access on macOS 10.15 Catalina article.


Archicad Compatibility:

Archicad 25
  • Archicad 25 FULL: is fully supported on macOS 10.15 Catalina. It is code-signed and notarized.
  • Archicad 25 SOLO: is fully supported on macOS 10.15 Catalina. It is code-signed and notarized.
Archicad 24
  • Archicad 24 FULL: is fully supported on macOS 10.15 Catalina. It is code-signed and notarized.
  • Archicad 24 SOLO: is fully supported on macOS 10.15 Catalina. It is code-signed and notarized.
Archicad 23
  • Archicad 23 FULL: is code-signed and notarized. The new version (Archicad 23 - 3003) provides compatibility with macOS 10.15 Catalina.
  • Archicad 23 SOLO: is code-signed and notarized. The new version (Archicad 23 - 3005) provides compatibility with macOS 10.15 Catalina.
Archicad 22
  • Archicad 22 FULL: is made compatible on a basic level with the Build-6025 mac-only update.
  • Archicad 22 SOLO: is made compatible on a basic level with the Build-6032 mac-only update.
  • Archicad START Edition 2019: is made compatible on a basic level with the Build-6033 mac-only update.
Archicad 21 & Earlier
  • Archicad 21 FULL & Earlier: will not be made compatible with macOS 10.15 Catalina and will not be supported.
  • Archicad 21 SOLO & Earlier: will not be made compatible with macOS 10.15 Catalina and will not be supported.
  • Archicad START Edition 2018 & Earlier: will not be made compatible with macOS 10.15 Catalina and will not be supported.

BIMcloud Compatibility:

BIMcloud 2019.3

Is not compatible with macOS 10.15 Catalina. Upgrading to macOS 10.15 Catalina may result in BIMcloud not being able to start.

BIMcloud 2019.4

Is code-signed and notarized. The new build provides compatibility with macOS 10.15 Catalina.

Please Note

We advise you to carefully evaluate your current circumstances before proceeding with upgrading to the new macOS 10.15 Catalina. If you choose to upgrade, make sure to back up all your data before proceeding to minimize the risk of data loss.

 

We recommend you to read the Changes in the Installation Process of BIMcloud on macOS and the Important Steps for BIMcloud / BIMcloud Basic Customers After macOS is Upgraded to macOS 10.15 Catal... articles to learn more about BIMcloud 2019.4 and macOS 10.15 Catalina.


Known Issues

Existing issues and OS specific behaviours:


We will keep this article updated with any news, fixes, workarounds, issues, or limitations as we continue using macOS 10.15 Catalina.

Still looking?

Browse more articles

Back to articles

See latest solutions

Accepted solutions

Start a new discussion!