Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

3D TEXT APPEARANCE

thinhphamkts
Newcomer
Hello everyone,
Could you please help me with this issue (as in attached image)?
As you can see the letter N is shown differently, although all the properties are the same with other letters. If I change it onto another letter then it appears normally. So, it is only happening with letter N.
__Archicad 22 NL and Enscape__
5 REPLIES 5

Barry Kelly
Moderator
I am assuming you are using an object to do this.
Is it the 'Text 3D 22' object that comes with the standard library?
If so what font are you using?

It looks like it is having trouble interpreting the hollow inside the N.
I assume if you use a different font that is OK as well.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Lingwisyer
Virtuoso
How have these been made? 3D text object? My first thought would be that the surface is degenerating due to the acute angles. Do other letters such as V and M have the same issue?



Ling
AC18-23 AUS 7000
Self-taught, bend it till it breaks.
Win10 | E5620 x 2 | 24GB | K2200

thinhphamkts
Newcomer
Hi,
I used normal 3d text.
I figured it out that it happens with few other letter when I make it become BOLD. You can see in the attached file. The "N" has to be normal style.
I use font "Swis721 BlkOul BT Greek"
__Archicad 22 NL and Enscape__

dkovacs
Graphisoft
Graphisoft
Hi,

Yeah, it clearly looks like at the sharp angles on the outside of the N, the lines cross themselves when you set it to bold. I don't have such an empty font (and I can't find that specific font online), but I think this is not a generic issue, but a problem with this specific font design.

As you can see in the picture of the non-bold version, right before the corner where it goes wrong, it has a slight change of angle. When you set the font to bold, the edges will be offset, and because of this change of angle, it will intersect itself. This results in a degenerated polygon, so the surfaces fail to properly generate.

Please try it with a different font, or avoid using the bold option for this one. If you need this font and need the letters to be bolder, you can still convert them to morphs and change them manually.

I hope you will be able to work on with this information.

Regards,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Barry Kelly
Moderator
Sorry I never got around to checking this out.
I don't have the BOLD option in my 3D text object - it is probably an old version.

The standard font works for me but I don't have the 'Greek' version if that makes any difference.


There is a small curve in the internal corners of the 'N' that maybe is what is causing the problem when the bold font is chosen - creating an invalid polygon.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!