Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

AC22 problem when zooming (scroll wheel)

Anonymous
Not applicable
I have a problem in AC22 when using scroll wheel to zoom
it keeps resetting the view to a view seemingly where the layout was saved to a particular zoom
even though i have changed the layout settings to 'ignore zoom and rotation when opening in this view'
I have drawn a line larger than the extent of the zoom to test if it was fitting to extents, but it is not fitting extents automatically

just as im using the scroll wheel it is as if it is resetting the view to this pre-determined zoom level, no matter what zoom i am at this is also affected with drafting
if i zoom out and draw a line larger than the view extent and then click to draw a new line, once the scroll wheel is used the start of the line being drawn is as if the view was at the 'set zoom view' im not sure what else to call it, was clicked as if it was already at this set zoom level, it makes using ac22 basically un-usuable to do any drafting without making the user MAD!
10 REPLIES 10

Daniel Kovacs
Graphisoft
Graphisoft
Hello Jason Clark,

Most of the times when there's a problem like that, it is due to the hardware/driver of the peripherals. Please try to uninstall the drivers of your keyboard and mouse, and try it with a different set.

Also, see if zooming any other way works (like using the option from the Quick Options Bar).

If that doesn't help, then there's a higher chance it is caused by ARCHICAD itself. Let me know if that was the case.

Regards,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Barry Kelly
Moderator
Has a problem been discovered here I wonder?
Someone else is having trouble with zooming - not sure what version though at the moment.

https://archicad-talk.graphisoft.com/viewtopic.php?f=7&t=14651&p=286165#p286165


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

BBD
Newcomer
Hi Barry and Jason,
I’ll try the mouse and keyboard driver redownload and get back to you.
A quick fix was just closing the program down completely and restarting... so I’m assuming it’s an ArchiCad thing because it only happens in ArchiCAD.

Barry Kelly
Moderator
BBD wrote:
A quick fix was just closing the program down completely and restarting... so I’m assuming it’s an ArchiCad thing because it only happens in ArchiCAD.
If a complete restart fixes the problem then I would suspect it may be dwindling system resources rather than the Archicad program.
Archicad may be more sensitive to it because it is trying to use those resources.

I make a habit of closing files and logging off every night.
I have known people to keep files open for days and even a week without shutting down and they wonder why Archicad is responding slowly.
A restart has always fixed the problem for me when this happens.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Tendenz
Participant
I have the same problem with AC22. Never had the problem before, just downloaded AC22, and now scrolling won't make AC22 zoom... It just scrolls up and down instead. Restarting AC didn't fix it, and there are no options in system preferences for the Magic Mouse that fixes it either.
iMac OS X 11.6

2,3 GHz Intel Core i9, 16 GB 2667 MHz DDR4

ArchiCAD 25

James B
Graphisoft
Graphisoft
Tendenz wrote:
I have the same problem with AC22. Never had the problem before, just downloaded AC22, and now scrolling won't make AC22 zoom... It just scrolls up and down instead. Restarting AC didn't fix it, and there are no options in system preferences for the Magic Mouse that fixes it either.
In AC22 for Mac user, go to AC Work Environment > Input Constraints and Guides.
You can switch the Magic Mouse and Trackpad behaviour between preferring Pan or Zoom.
Technical Product Manager, Graphisoft

Tendenz
Participant
James wrote:
Tendenz wrote:
I have the same problem with AC22. Never had the problem before, just downloaded AC22, and now scrolling won't make AC22 zoom... It just scrolls up and down instead. Restarting AC didn't fix it, and there are no options in system preferences for the Magic Mouse that fixes it either.
In AC22 for Mac user, go to AC Work Environment > Input Constraints and Guides.
You can switch the Magic Mouse and Trackpad behaviour between preferring Pan or Zoom.
Oh, wow! Thank you SO much!
iMac OS X 11.6

2,3 GHz Intel Core i9, 16 GB 2667 MHz DDR4

ArchiCAD 25

Ralph Wessel
Mentor
Tendenz wrote:
I have the same problem with AC22. Never had the problem before, just downloaded AC22, and now scrolling won't make AC22 zoom... It just scrolls up and down instead. Restarting AC didn't fix it, and there are no options in system preferences for the Magic Mouse that fixes it either.
Hold down the <alt> key for the other behaviour. So if you have the default to panning, hold down <option>/<alt> to zoom.
Ralph Wessel BArch

Anonymous
Not applicable
Ever since I have updated to ArchiCAD 22 I am also experiencing an issue that the navigation starts acting weird in the 3D window. In AC 19 and 21 I am not experiencing the same issues. When I click on the "mouse" icon in the toolbar all is normal. I doubt that it has anything to do with the drivers in my case. Maybe it is a bug in ArchiCAD 22?

I am using AC on Windows 10 with a GTX1070 and an I7 (8th generation) so I doubt that it can be a performance issue in my case.

Anonymous
Not applicable
I have the same issue, as described in the original post. It happens to any member of a specific team, so it does not seem to be related to computer hardware. They are either using WIN7 or WIN10. Restarting ARCHICAD helps the problem, but it's a big TW project and logging back can take up to 15 minutes, which is an issue, when it happens 1-2 a day.

Zooming seems to reset to a specific view at each scroll. If I select the zoom from the drop down list from the navigation bar at the bottom, it will remember that and will snap to that value at the start of each scroll.

Similarly, it will reset to a preferred location at the start of each pan, regardless of where the pan has started. This makes certain areas of the plan inaccessible.

So only restart will help, but we want to avoid that, as it takes so much time for users to log back in.

Any other ideas?

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!