Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

AC25 3D window shows blank unless limited by marquee

RGGPhnx
Participant

So I've searched the forum for "3d window blank" and this seems to be a repeating topic without an answer, and my circumstances seem a little different. Symptoms:

* Open 3d window and all I see is the background.

* Yes, the model is within the view of the camera per the Perspective Settings.

* No difference in using parallel settings. Zoom to model button does not affect output.

*  The ONLY ways I have been able to get the model to show up is to

    1. marquee it, and "Show Marquee in 3D." Toggling F5 makes the model disappear, and not come back until going through the show marquee command in the menu again; or

   2. Show Selected works, with the same results - going back to Show All makes it disappear. 

* This is unique to the drawing file. Opening other projects shows normal functionality. Early in the project it was OK, but just stopped working all of a sudden (after reopening the previous days' work).

*Double checked all the model-limiting functions I could think if - parial structure display, cutting plane, etc. and none are active. 

 

Having to use the marquee is a workaround, but far from ideal.  I have a lient meeting tomorrow and would really like this working correctly without having to reconstruct the whole file!

1 ACCEPTED SOLUTION

Solution
Gerry Leonor
Expert

if the marquee view is showing OK, but the Show All isn't, there might be something/s that's 10kms beyond your working model in the 3D window. when you do your normal, non working, 3D view,

 

when you Select All & you get a number next to "All Selected"

GerryLeonor_0-1649720987672.png

& yet still see nothing, then yes, there might be an element or two that far enough from your model that when AC tries to Show All in 3D, all you see is a blank background. but you're actually seeing, in one end, your working model, the stray elements in the other end, & large empty space in the foreground.

AC22 | Win10 | 64 bit | 16Gb RAM |Intel i7 8700 @ 3.20Ghz

come join our Discord server
https://discord.gg/XGHjyvutt8

View solution in original post

6 REPLIES 6

Solution
Gerry Leonor
Expert

if the marquee view is showing OK, but the Show All isn't, there might be something/s that's 10kms beyond your working model in the 3D window. when you do your normal, non working, 3D view,

 

when you Select All & you get a number next to "All Selected"

GerryLeonor_0-1649720987672.png

& yet still see nothing, then yes, there might be an element or two that far enough from your model that when AC tries to Show All in 3D, all you see is a blank background. but you're actually seeing, in one end, your working model, the stray elements in the other end, & large empty space in the foreground.

AC22 | Win10 | 64 bit | 16Gb RAM |Intel i7 8700 @ 3.20Ghz

come join our Discord server
https://discord.gg/XGHjyvutt8

Gerry gets the prize, with Barry soon after.

There was indeed an orphaned object out in space somewhere that was causing the failure. Deleting the object fixed the problem.

However, it is still a mystery to me how you could manually set the viewpoint and the target locations to look right at the model and still not have it show up in 3D. Also, preset 3D view settings had no effect. But delete this one object and they work again. 

Gotta be a bug in there somewhere, but it's fixed now so I won't worry about it too much.

 

Thanks for the suggestions!

 

Bob Graham

Morley Design

Phoenix, AZ

That is why when I am modelling, I prefer to use an Axonometric view rather than Perspective.

No camera position and target position.

You just see what is there.

 

Perspective is fine for views you want to document/render of course.

I just find it easier to navigate with Axonometric.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

By the way, the offending object was from a SketchUp file downloaded from 3d Warehouse. Something buggy in that object appears to have been taking up a gigantic amount of "space" which also encompassed my model, rendering it invisible.

Axon or perspective, makes no difference.

 

Bob

Barry Kelly
Moderator

I would suggest something far from origin as well. It may even be something miles up in the air or down below the model like a wall or object with the wrong height.

 

I would change from perspective view to Axonometric in the 3D window (I think it is easier to control than a perspective view).

Zoom to extents - have a look at the zoom percentage - is it very small?

Select all and you should see the back selection dots.

Zoom in on those and see if you can spot what is far away.

 

Barry.

 


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

kim
Contributor

Sometimes I find I have either 3D Cutaway turned on [View>Elements in 3D View>3D Cutaway] Or I have Filter and Cut Elements in 3D  [View >Elements in 3D View>Filter and cut elements in 3D]. Adjusting or turning them off may help. If the cutting plane is not causing it, perhaps its the filter option?

 

Regards

Kim

 

 

 

 

--------------------------------------------------------------------------------------------------------
AC25+earlier - Monterey 12.2.1 - 2021 Macbook Pro16 / M1 Max / 32GB

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!