Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

AC25 + Mojave

March_ Bruce
Contributor

... can anyone explain why AC25 cannot run on Mojave on a metal capable mac, or if there might be a workaround, with many thanks...

3 REPLIES 3

Laszlo Nagy
Community Admin
Community Admin

The official Graphisoft site says that Archicad 25 requires at least macOS 10.15 Catalina:

 

https://graphisoft.com/resources-and-support/system-requirements

 

These compatibility things are probably always based on development decisions. They have probably implemented features in Archicad that were not yet available in macOS 10.14, only in macOS 10.15 and later.

Even Metal can have different versions. Maybe Archicad 25 needs a Metal version that was not yet available in macOS 10.14. 

I do not know that exact reason, I am just saying that there can be such decisions in the background that if an application want to support some operating system feature, it will not be able to support older operating system versions. Of course, there could even be other reasons as well.

 

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Hi Lazlo,

 

Thanks for your reply...

 

It remains a mystery, and raises the question of switching to Windows 10 which seems to offer broader usability. I have AC16 & AC25 both running in W10 in Parallels 17 in High Sierra for example, which seems somewhat counter intuitive... I understand W10 has also retained support for customer licensing and workflow investments in 32 bit apps.

 

Additionally I understand a maxed out 2010 mac pro with vega56 gpu and Mojave may be close to or faster than a base 2019 mac pro & yet offer 32 bit app compatibility for significant options such as the persistent license adobe master collection.

 

One might ask if Mojave deserves special extended support rather than early depracation?

 

Also I understand http://dosdude1.com/catalina/ unbricks Catalina on older macs and generally works well, if unsupported...

 

I have noted that the Maxon Redshift just released for AC25 only runs on Big Sur 11.3 and since Monterey is so far advised against so it seems support has narrowed to a single macOS to use the full capability of Archicad 25...?

 

Thanks...

Laszlo Nagy
Community Admin
Community Admin

These are question I do not have the knowledge or information to answer. 🙂 Sorry.

But soon those Monterey-related bugs will be fixed in upcoming updates, as far as I understood.

....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!