Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Annoying Dialog Box when opening Archicad

Ted Taylor
Contributor
Anytime I open Archicad from the finder, I get the Dialog box shown below. The setting in the Firewall pane is set to accept incoming network. Anyone else getting this.

Does not appear to do any harm, but it is annoying.
Ted Taylor
Atlanta, GA , USA
iMac (Retina 5K, 27", Late 2015)
3.3 GHz Intel Core i5 32GB
AMD Radeon R9 M395 2GB
OS10.14.2,
Latest Archicad 22
6 REPLIES 6

Karl Ottenstein
Moderator
Same thing. Would love to know how to get rid of it.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.3, iMac Pro

Eduardo Rolon
Moderator
I know it has to do with the firewall settings under "Security & Privacy".
Sometimes adding the app to the "Firewall Options" makes it stop asking.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro 2.4 i9 32GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Karl Ottenstein
Moderator
Doesn't stop the prompts though.

In the past (pre-Mavericks), you wouldn't be asked again. The problem then, was that all versions of AC were just called "ArchiCAD" - so if you launched Archicad 15 and then 16 - you would be prompted by the firewall because it would detect that the Archicad.app for 16 was different from the one previously 'approved' for 15 (etc).

Not, Graphisoft has named the app Archicad 17.app so it can have its own entry in the firewall table. But, even with it there, the firewall prompt for AC (as well as QT) happens on every launch. I have to assume that this is an Apple issue with Mavericks and not a GS one, but don't know... since Ted is on Mountain Lion, this may be a GS issue after all...
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.3, iMac Pro

Ted Taylor
Contributor
Oops. I need to update profile. I'm on 10.9.1 too.
Ted Taylor
Atlanta, GA , USA
iMac (Retina 5K, 27", Late 2015)
3.3 GHz Intel Core i5 32GB
AMD Radeon R9 M395 2GB
OS10.14.2,
Latest Archicad 22

jameshart
Newcomer
I am also on 10.9.1 and this pesky dialog box appears each time I open ArchiCAD even though ArchiCAD 17 is set to allow incoming connections in the Firewall settings.
ArchiCAD 22 (6021 USA Full), 2.5 GHz Intel Xeon W iMac Pro, 64 GB RAM, MacOS 10.14, AMD Radeon Pro Vega 64

Stress Co_
Expert
I get them constantly.
(AC15, AC16, AC17)
Running 10.8.5
Marc Corney, Architect

Red Canoe Architecture, P. A.



Mac OS 10.15.7 (Catalina)

Processor: 3.6 GHz 8-Core Intel Core i9

Memory: 48 GB 2667 MHz DDR4

Graphics: Radeon Pro 580X 8GB

ArchiCAD 24 (5000 USA Full)
ArchiCAD 25 (4013 USA Full)

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!