Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Backward compatibility

Anonymous
Not applicable
Hiya, I have been using ArchiCAD since version 4.5 (!), always on macs. I upgraded archives for repeat clients & files I wanted to keep for formats etc. However keeping Apple & Archicad updates running along together became a chore for a small office so I left much behind at Archicad 8.6. I upgraded my WIBU key in 2013 to run ArchiCAD16Solo with the added motivation that v16 is backward compatible with v8.6 & therefore I could retrieve a few needed archives. However this purchase gave me an upgrade option to v17 so I would like to upgrade my software that extra step.

Questions: do I then lose backward compatibility again?
Could I alternatively load & use v16 & 17 in parallel under the same Key?
Will files upgraded to v16 make the jump to v17 or would they lose too much to be worth the bother?

Hope you can help - architecture is a long-term business. Fran
2 REPLIES 2

Frances:

I am running Mac OSX10.6.8 with a WIBU key and can open AC back to version 7 under Rosetta, later operating systems will restrict you to AC10, and Mavericks to AC12. I am currently in the process of upgrading to Mavericks, but will keep a separate hard drive or partition to be able to boot into OSX10.6.8 when needed. There are also File Converters on the Graphisoft web site to help with this.

A few terms I don't know from your post:
ArchiCAD16Solo: Is this the full program, or a restricted version?
v8.6: There were 8.0 and 8.1, I don't know what 8.6 is

With the full version you should have no issues running different versions of AC simultaneously (I don't know about the Start editions). As to taking a file from AC16 to AC17: it takes an effort due to the addition of the new attribute Building Material, you can read the help guide and threads on this forum to see if it is worth the effort in your case.

You should add a Signature to your Profile (click the Profile button near the top of this page) with your ArchiCAD version and operating system (see mine for an example) for more accurate help in this forum.

David
David Maudlin / Architect

www.davidmaudlin.com

Digital Architecture

AC24 USA • iMac 27" 4.0GHz Quad-core i7 | 24 gb ram • MacBook Pro 2.8GHz | 16 gb ram • OSX10.15.7

Anonymous
Not applicable
Thank-you for the help David. Yes, slip of the pen (as it were) v8.1 are my oldest retrievable files. I am missing the updates that you have, but v16 very usefully can import direct from v8 & 9. I am contemplating moving up to v17 but dont want to lose that backward compatibility if the upgrade simply overwrites my current version.

Your answer has clarified that I should probably consult my local software supplier. Archicad Solo is a UK only restricted version for small practices, but not as restricted as Start. My solution possibly is to keep v16 on one computer & v17 on another and move the Codemeter as necessary if I need archived work. My supplier will hopefully tell me if that is 'allowed'.

Thanks again
Fran

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!