Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Desactivate Bug Reporter

amgam
Booster
Has anyone found a way to deactivate this annoying "feature"?
Or maybe ArchiCAD made this option possible finally?
ArchiCAD 25 FRA 3011 + TwinMotion 2021.1.4
iMac Retina 27 2020 3,8 GHz Intel Core i7 8 cœurs
64 Go 2667 MHz DDR4
AMD Radeon Pro 5700 XT 16 Go
7 REPLIES 7

Podolsky
Mentor
It's important feature for developers. They need it.

amgam
Booster
Don't care, I want it gone.
ArchiCAD 25 FRA 3011 + TwinMotion 2021.1.4
iMac Retina 27 2020 3,8 GHz Intel Core i7 8 cœurs
64 Go 2667 MHz DDR4
AMD Radeon Pro 5700 XT 16 Go

Podolsky
Mentor
Interesting to look into legal part of it. What licence agreement is saying that anyone click 'agree' but never read it.
If for example (I don't know, I'm guessing) licence agreement says that you agreed to provide reports to Graphisoft about software crash and let Graphisoft to collect information about your hardware - so how then after you want to change an agreement.

The only possible solution I can see here - to switch that bug reporter would work on the background, without showing interface, but do the same - making report and sending in Graphisoft.

Barry Kelly
Moderator
Why would you want to disable the bug reporter?
If you keep getting it appear (only when Archicad crashes), that means you have a problem that should be fixed.
Take note of the bug ID number, send off the report and follow it up with your local Archicad support people.

If I kept getting the bug reporter show up, I would want to know what is causing the problem.


Or are you just talking about the warning messages that pop up while using Archicad?
They can be turned off in the Work Environment settings.
Again I wouldn't as you should be fixing the problems so you don't get these messages- not avoid them.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Podolsky
Mentor
Barry,
Sometimes pips using 'medically cured' ArchiCAD versions. They don't need bug reporter and they don't care. See my posts about version 25.

amgam
Booster
Barry wrote:
Why would you want to disable the bug reporter?
Because I don't need it. It only takes my precious time. I understand the utility, I just don't want it. I can fix the problems on my own. It amazes me how ArchiCAD won't let users choose to see/not see it. ArchiCAD is already crazy slow as it is, it's wasting even more of my time and I'm force-quitting the Bug Reporter every time anyways.

So if anyone knowns a way to disable this annoying "feature"?
ArchiCAD 25 FRA 3011 + TwinMotion 2021.1.4
iMac Retina 27 2020 3,8 GHz Intel Core i7 8 cœurs
64 Go 2667 MHz DDR4
AMD Radeon Pro 5700 XT 16 Go

Barry Kelly
Moderator
amgam wrote:
Because I don't need it. It only takes my precious time. I understand the utility, I just don't want it. I can fix the problems on my own.
It amazes me how ArchiCAD won't let users choose to see/not see it. ArchiCAD is already crazy slow as it is, it's wasting even more of my time and I'm force-quitting the Bug Reporter every time anyways.

It appears to me that you aren't fixing the problem if the bug reporter keeps coming up.
However that is up to you.

Why is Archicad 'crazy slow'?
It shouldn't be.

amgam wrote:
So if anyone knowns a way to disable this annoying "feature"?

You don't say what version of Archicad you are using or what operating system you have.
I am not aware of any options to disable the bug reporter however there are a couple of things you can try AT YOUR OWN RISK.
I am writing this from a Window OS perspective - I have no idea with Macs but there will be similar.

In the program folder for Archicad you will find a program called "GSReprt.exe".
You could try re-naming that file (don't delete it in case you have to put it back) - not sure if it will work as I don't get many crashes to test it.
It may just cause an error message saying it can't find the file - so you will be no better off.

Or in the Registry under 'current user > software' you will find keys for Archicad.
In one of those is a section for 'Bug Reporting'.
In there is a key for 'disableOOPReporting' - you could try activating that.

Again I stress - DO THIS AT YOUR OWN RISK.


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!