Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 
Setup & License forum

Elements are dragged on Mac

I've been having this problem on Mac (Yosemite) but not on PC starting from AC18 (I have the latest update)
I draw a wall or put in a window or any element for that matter - if i want to select it to edit it freezes for a second and then this element is being dragged in the direction my mouse moves like it is stuck to the cursor. To edit I need to select, wait for 2-3 sec for it to stop sticking, then click again to access edit menu.
I turned off CAD-like option, installed latest update, uninstalled and installed back logitech control center, used a different mouse - no change.
On PC this problem doesn't exist. Also on PC when I turn off CAD-like function I have to click and hold to draw a wall but on a Mac the wall is drawn without holding, I just click and draw with both Mac-like and CAD-like option on.
This dragging is really annoying and I can't figure out where the problem is...
Does anyone else have this problem? I looked online - couldn't find anything

Thank you all!

Karl Ottenstein
Not an AC issue, but something on your system... check System Prefs > Accessibility and scroll down to mouse options.... see if Mouse Keys is checked perhaps?
One of the forum moderators   •   AC 26 USA and earlier   •   macOS Ventura 13.2.1, iMac Pro 10-Core, Radeon Pro Vega 64

Thank you for the idea, I looked - nope, not checked.
Do you think there could be anything else I could look at?
Could it be a issue between AC18 and Yosemite?

Thank you!


I believe I have a similar problem that only seems to occur with AC18 on my Mac with Yosemite. It did not happen before I installed the lastest Mac OS...and it still does not happen on AC 17 with Yosemite but it sure is a drag on 18. I call it an aberration...

The last event occurred when modifying a circle. The screen would shift away from my work and the circle never completed its modification. I tried various times before I realized I was in shift/shape mode. Typically I can reboot the computer and it resolves the problem...for a few hours to a day or two.

I too have tried different settings, different mouses, quitting AC, etc., but nothing seems to work. This aberration problem only happens on 18, NOT 17. And I did not have the problem before switching to Yosemite, I'm current on AC fixes and it still happens. AC 18 is a waste, because I can rarely work a full day without the graphic ghosting double image shift-shape aberrations. And yet I keep trying to use hitting my head against a wall.

I have no idea what to do...other than stay with 17.
Dave Olufs
Just 4 Measure, Ltd

iMac Pro 3.2GHz Quad, 32GB, OSX 10.13.6, AC-5, 6, 6.5, 7, stopped for a few years--started again with 12 thru 17, 18 or 19 didn't work, then 20, 21, now skipped to 23. Started in 1976 hand-drafting ink on mylar...

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!