cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Setup & License forum

File Associations Problem - Older Installs Open PLNs

Anonymous
Not applicable
My office has used ArchiCAD since Version 7.0 and often I need to load and print older projects. I have versions 8.1 through 11 installed on my machine. Regardless of which order I install the different versions, windows seems to randomly pick a certain version to associate PLN files with and will always try to open them with that version.

Example: If I browse with Windows Explorer to a version 11 pln, and double click, ArchiCAD 9 opens and then gives me an incompatible version error. Right clicking and selecting 'open with' does not fix the problem (I assume because all versions are just named archicad.exe). Is there any way to make ArchCAD 11 the default application for opening PLNs while other versions are installed?

P4 3.0GH 2GB RAM
Win XP SP2
AC11US, AC10US, AC9US AC8.1US
40 REPLIES 40

Anonymous
Not applicable
It is recommended that you start Archicad first, then select the file you want to open.

henrypootel
Graphisoft Partner
Graphisoft Partner
It will generally use the last version of ArchiCAD that was installed. beyond that, i'm not sure why it would mess that up.
Josh Osborne - Central Innovation

HP Zbook Studio G4 - Windows 10 Pro, Intel i7 7820HQ, 32Gb RAM, Quadro M1200

Anonymous
Not applicable
I generally do load ArchiCAD and then open a file, but there are enough times that people here in the office want to open from Windows Explorer that this is quite annoying. It seems that the latest install doesn't always grab the file association. If anybody else has thoughts, I'm still interested.

Djordje
Advisor
No it does not. I have everything since 8.1 installed, including 8.1, and double click ALWAYS opens 8.1

Regardless of the last install.

So there ...

Software first, file later.
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen

Anonymous
Not applicable
right-click on a PLN file -> open with... -> select the version of archicad you want to be the default to open -> check the checkbox with always use the selected program... -> click ok

and that's it

Djordje
Advisor
zucoc wrote:
right-click on a PLN file -> open with... -> select the version of archicad you want to be the default to open -> check the checkbox with always use the selected program... -> click ok

and that's it
Hmmm ... if you say so

Maybe I am installing and uninstalling too much 😉
Djordje



ArchiCAD since 4.55 ... 1995
HP Omen

Anonymous
Not applicable
zucoc wrote:
right-click on a PLN file -> open with... -> select the version of archicad you want to be the default to open -> check the checkbox with always use the selected program... -> click ok

and that's it
That, may be the standard Windows procedure, but it doesn't work for me (note the original comment). When I try to select a different version in the 'Open With' dialog box, it still defaults to whatever version it wants. Looks like we're stuck with opening ArchiCAD and then browsing to the file, though if Graphisoft wants to fix that, I'd love to see it.

Barry Kelly
Moderator
BasisArchitecture wrote:
zucoc wrote:
right-click on a PLN file -> open with... -> select the version of archicad you want to be the default to open -> check the checkbox with always use the selected program... -> click ok

and that's it
That, may be the standard Windows procedure, but it doesn't work for me (note the original comment). When I try to select a different version in the 'Open With' dialog box, it still defaults to whatever version it wants. Looks like we're stuck with opening ArchiCAD and then browsing to the file, though if Graphisoft wants to fix that, I'd love to see it.
You can always set up an Archicad shortcut on your desktop.
Then just drag and drop the file from Explorer onto the shortcut and it will open.
Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Srinivas
Booster
Barry wrote:
You can always set up an Archicad shortcut on your desktop.
Then just drag and drop the file from Explorer onto the shortcut and it will open.
Barry.
Thanks for such a nice tip Barry.
ArchiCAD Services
ArchiCAD since v9 to latest
iMac, Windows 10

Da3dalus
Enthusiast
zucoc wrote:
right-click on a PLN file -> open with... -> select the version of archicad you want to be the default to open -> check the checkbox with always use the selected program... -> click ok

and that's it
I've got this problem, too. I just recently had to install AC9 to open some old Plotmaker .LAY files (wish list item... allow ArchiCAD to open older file types, perhaps with a "goodie"). Anyway, I went to do the "Open with..." thing, but ArchiCAD 11 is NOT a choice. When I manually browse, and select the AC11 application, it still only opens with AC10.

If I had time to burn, I'd mess with the registry. Any of you programmer guys know how to fix this? I imagine you're all on vacation, now that AC12 is out.
Chuck Kottka
Orcutt Winslow
Phoenix, Arizona, USA

ArchiCAD 25 (since 4.5)
Macbook Pro 15" Touchbar OSX 10.15 Core i7 2.9GHz/16GB RAM/Radeon Pro560 4GB

Anonymous
Not applicable
I am also having this problem. I have updated to 12. But the pln extension is still associated with ver 11. It's very annoying. Maybe it's not the "right" way to start archicad but it is often the convenient way. When I try to change pln to associate with ver 12, ver 11 is listed as the default, when I browse to archicad ver 12 in the archicad 12 folder, select "archicad.exe" in that folder, the only option I have to take is "open". I select that option and archicad pln extension still defaults to version 11

Archicad 11 & 12, XP pro, 4 gig ram, dual opteron 270's, nvidia quadro fx 3400/4400

Eduardo Rolon
Moderator
Try changing the name of the archicad.exe in the AC11 folder and double click a pln to see if it works. Afterward you can change it back.
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08
Puerto Rico, BVI, Miami

Vectorworks 2022

Anonymous
Not applicable
Well it was a good suggestion to try, but it didn't work.
But thnks a lot for the suggestion.
Jack

Thomas Holm
Booster
The safe way is to always start the application first, then use the File>Open menu command.
It's the price to pay for having several working versions installed.
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Anonymous
Not applicable
Oh well. I'm probably too picky. I may even go to the extreme of uninstalling 11 getting the pln association set to 12 and then re-installing 11.

Thomas Holm
Booster
jackrog1 wrote:
Oh well. I'm probably too picky. I may even go to the extreme of uninstalling 11 getting the pln association set to 12 and then re-installing 11.
Interesting. On the Mac, the association always defaults to the last installed version. So you would do the opposite.
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Anonymous
Not applicable
Ordinarily it does default to the latest installation. Theres something strange going on, for some reason when I installed 12 it did not get the chance to default .pln files to 12.
I am not having this problem with software other than archicad.

Link
Expert
I don't believe there's any validity to opening ArchiCAD first, then opening the file. In fact I think it is quite a slow method.

I have every version of ArchiCAD in my quick launch bar, and just drag the files onto the respective version. Unless it is an AC12 version, which is what my pln is associated to, so I just double click the file.

IME Windows will associate the extension with the last ArchiCAD version that was installed.

To permanently change how the file is opened (in Windows):

1. Open a Window in Windows Explorer
2. Go to Tools> Folder Options... and select the Fie Types tab
3. Type in PLN quickly or scroll down to 'PLN ArchiCAD Solo Project'
4. Hit the Advanced button
5. Click on open in the Actions pane
6. Hit the Edit... button
7. Hit the Browse button and browse to "C:\Program Files\Graphisoft\ArchiCAD XX\ArchiCAD.exe"
8. Hit OK
9. Hit OK
10. Hit Close

That's all there is to it. I am sure one of my Mac counterparts could provide equivalent OSX instructions.

Cheers,
Link.

Eduardo Rolon
Moderator
Mac OS X instructions

1. select file
2. right click and select "Get Info" or use command+i as a shortcut
3. expand "Open With"
4. select your AC (Applications->Graphisoft…)
5. click on "Change All"
6. Ok to accept changes
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08
Puerto Rico, BVI, Miami

Vectorworks 2022

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!