Setup & License forum
Showing results for 
Search instead for 
Did you mean: 

Hotfix #5 (5014) install problem

Attempts to update ArchiCAD 17 with Hotfix #5 (5014) have resulted in a halt to the install and showing the following error message.

(Hotfix #5 error.png attached)

We insured that any virus scanner is off (we use CalmX AV). We shutdown and re-booted the MacPro (early 2008) and did a Permissions Repair and Repair Disk operation on the boot drive. We then attempted installation again with same result . Please advise any possible fix. This is the first time we have had any problem with updates.

Karl Ottenstein
I had the same issue, and thought it was just something messed up on my machine. Fix is easy - the updater for some reason doesn't have write access to some files in the folder. I'm guessing that the previous hotfix messed up the permissions. (Repair permissions in Disk Utility only repairs OS X system file permissinos... it doesn't know what permissions are supposed to be for apps or user data files.)

Update AC 17 permissions:
In Finder, go to Applications > Graphisoft > ArchiCAD 17
1. Right click the folder and click on Get Info
2. Click the faded gold padlock in the bottom right and enter your admin password to unlock the permissions panel
3. Give the owner (probably you), group (probably admin) and 'everyone' read/write access
4. Click the gear icon at the bottom of the Info window and click on "Apply to enclosed items..." This will copy those full read/write privileges to all files within the AC 17 folder.

Now, run the update again.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.6, iMac Pro

Thanks Karl, that did the trick. Didn't think about specific permission for ArchiCAD 17.

Karl Ottenstein
Glad that worked!
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.6, iMac Pro

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!