Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

How to delete X ref Layers imported from a autocad file

avishiplu
Newcomer
Hello Everyone,
I am having a problem with my Layers.
At the beginning of my project, I imported a dwg file in a Worksheet, using 'Attach X ref' . (See Fig-1)
After completion of the modeling, I deleted that file. But Layers from dwg file still existing in my layer as 'X ref Layer. (See Fig-2) I failed to delete those layers manually because The delete option is inactive now. It's really annoying.
Can you please suggest me a way to delete those Layers?
Avi Shiplu
Archicad Version-23
Windows-10
1 ACCEPTED SOLUTION

Solution
Laszlo Nagy
Community Admin
Community Admin
You should be able to select all those XREF Layers and delete them in either the Layer Settings Dialog or in the Attribute Manager.

In the future, you are better off using the Drawing Tool to place DWG files in your project. That way attributes coming from the DWG file (Fills, Lines Types, Layers) do not become part of the attribute set of the Project, either.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

4 REPLIES 4

jl_lt
Enthusiast
Hi Mr. Avishiplu, if you are using the Cad file as a guide for modeling, i recommend using the "place external drawing" which you can find in the same menu instead of Xref, and placing them in a worksheet, which you can later reference using the trace tool. This way you wont need to deal with layers in your file, but you can still control the visualization of the placed drawing.

Solution
Laszlo Nagy
Community Admin
Community Admin
You should be able to select all those XREF Layers and delete them in either the Layer Settings Dialog or in the Attribute Manager.

In the future, you are better off using the Drawing Tool to place DWG files in your project. That way attributes coming from the DWG file (Fills, Lines Types, Layers) do not become part of the attribute set of the Project, either.
....................................................................................................
Laszlo Nagy, Lead Moderator, Community Admin
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, NVidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

View solution in original post

avishiplu
Newcomer
LaszloNagy wrote:
You should be able to select all those XREF Layers and delete them in either the Layer Settings Dialog or in the Attribute Manager.

In the future, you are better off using the Drawing Tool to place DWG files in your project. That way attributes coming from the DWG file (Fills, Lines Types, Layers) do not become part of the attribute set of the Project, either.

Dear Laszlo Nagy
Thanks for ur Solution & Suggestion. Although The layer Settings Dialogue didn't work, the attribute Manager worked fine.
Avi Shiplu
Archicad Version-23
Windows-10

loann_vu
Newcomer

If that missing xref also had missing attributes, then instead of deleting the layers in the Attribute Manager, I would just make a dummy xref file with the exact name as the missing xref. Then I would Attach that xref. Then, Detach that xref, along with all associated attributes. That would take care of the layers and anything else that came along with it. 

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!