Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

I cannot download ArchiCAD 17 educational version

Anonymous
Not applicable
Hello, I'm so frustrated...I registered for the student version, got my confirmation email/1-year license, which gave me a link to myarchicad.com, where I found my serial #. Next to the serial number, there was a "download" button. I've tried six ways to Sunday to click on that Download button (and also on the name of the program) to download the program, but nothing happens. For kicks I tried to hit the "download"buttons next to all the other programs listed on that page too, and nothing happens, no "waiting" circle or anything. I have windows 7 and am using Internet Explorer 11 if that makes any difference. Please help! Thanks.
11 REPLIES 11

Karl Ottenstein
Moderator
Something peculiar to your setup, as I just checked and the site seems to be working OK.

Might be something with your firewall/antivirus. Try temporarily disabling, refresh the page and try again? Try on another computer?
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.7, iMac Pro

Anonymous
Not applicable
I’m a student. I registered for the ArchiCAD 17 educational version and obtained the serial number. When I’m logged at my account I can see the serial number left to the software.

However when I click <Download> button nothing happens, no download starts. I installed also the IDM (Internet Download Manager) but it does not download either.

Could you please advise ?

Best Regards,
Maria

Anonymous
Not applicable
I just tried deactivating my firewall, turning off my spyware, etc. and it still doesn't work. I get the "finger" when I hover over the "download" link, but nothing when I click. I will try it on my old laptop and see if it works on that; I don't understand why it wouldn't work on the newer one. Do you think it would be helpful to bring it to a computer repair place to see if they can get it to work? Thank you for your quick response BTW!

Karl Ottenstein
Moderator
Something must be amiss with the site for educational users, as another report identical to yours has been posted. I'm going to merge your thread with the one started by Maria, since it is the same issue and will contact GS. Hopefully someone will have an answer Monday when they return to work.

When I'm logged on, it isn't as an educational user... and so that must be the difference in why I get the proper download.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.7, iMac Pro

Eduardo Rolon
Moderator
Logged in as Faculty and I am able to download the EDU version.

Just to be sure, you are "right-clicking" on the link and selecting save-as?
eduardo rolón AIA NCARB
Another of the forum moderators.
Macbook Pro M1 Max 64GB ram
OS X 10.XX latest
AC25 US/INT -> AC08

Vectorworks 2022

Anonymous
Not applicable
ejrolon, I couldn't even get to the point that you show in your screenshot. BUT I was able to download it on my old laptop, which was running w/ Safari. So out of curiosity, I opened the myarchicad.com page on Google Chrome (instead of Internet explorer) on my newer laptop (the one I was having the problem w/) and it seems to be downloading fine as we speak! Not really sure what that means and I still don't know why it wasn't working, but....let's hope it finishes downloading and I'll be all set for the start of classes tomorrow. Thanks to both of you for your help!!!!

Anonymous
Not applicable
Maria are you using Internet Explorer? Try opening the internet using something else (Google Chrome - Safari - Mozilla Firefox - you can download all of these for free). I was having the same issue and this fixed it. Good luck!

Barry Kelly
Moderator
If using Internet Explorer you could try this.
Go to the TOOLS menu and choose "Compatibility View Settings" and then add the MyArchicad website address to the list.
I had similar trouble on a completely unrelated website and this fixed the problem (I was using Internet Exploree 11 out of interest).
Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Karl Ottenstein
Moderator
I've heard back from Csaba in tech support about this issue: The problem is with Internet Explorer 11.

Tech support advises trying again with a different browser. E.g., try Chrome, etc.

I'd try Barry's suggestion of Compatibility View first, as some other sites also report that being added to that list restores functionality.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.7, iMac Pro

Barry Kelly
Moderator
Karl wrote:
I'd try Barry's suggestion of Compatibility View first, as some other sites also report that being added to that list restores functionality.
I had a PM back from Maria saying that it did work.
Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Csaba Kezer
Graphisoft
Graphisoft
Karl wrote:
I've heard back from Csaba in tech support about this issue: The problem is with Internet Explorer 11.

Tech support advises trying again with a different browser. E.g., try Chrome, etc.

I'd try Barry's suggestion of Compatibility View first, as some other sites also report that being added to that list restores functionality.
Hey guys,
I just tried Barry's suggestion and it works with the myarchicad site! (I tried it with IE version 11.0.9600.16476)

Cheers,
Csaba
Csaba Kézér
Graphisoft

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!