cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Setup & License forum

Java issues

Anonymous
Not applicable
Hi,

I was given a copy of Archicad 17 to roll out, but noticed it needs java 17. Java 17 causes issues with our oracle forms so we are stuck on 16. What would break if I remove 17?

Thanks

Stuart.
1 REPLY 1

Barry Kelly
Moderator
Hi Stuart,
Looking on the Graphisoft website I see that both Java 6 & 7 can be installed at the same time.
In fact we need to have both as we use WIBU keys for our licenses.
Here is a quotefrom the Graphisoft website ... http://www.graphisoft.com/downloads/java.html
About Java 7

ArchiCAD 17

If you installed ArchiCAD 17 with Wibu protection you might need to install Java 6 separately in order to run ArchiCAD with your key. WkConfig requires Java 6, so if it is not present on your computer use Java 6u32 installer from the above list.


ArchiCAD 16 Hotfixes

If you are installing an ArchiCAD 16 Hotfix on Windows platform, Java 6 will be required even if Java version 7 has been already installed on your computer. If Java 6 is not present on your Windows you can download and install from the links above. The two Java versions will not interfere.

If both 6 and 7 are installed can Oracle Forms automatically use Java 6?
It seems the different Archicads can choose which Java they need so just wondering if Oracle Forms can as well.
You can always test it on my machine
I have 17 installed but have no need for these oracle forms so I wouldn't have noticed any problems.

By the way isn't Java distributed by Oracle?
Shouldn't they update their software? - or is that too much drama in an office the size of ours.
Here's a quote from the Java website.
Do I need older versions of Java?

The latest available version is compatible with the older versions. However, some Java applications (or applets) can indicate that they are dependent on a particular version, and may not run if you do not have that version installed. If an application or web page you access requires an older version of Java, you should report this to the provider/developer and request that they update the application to be compatible with all Java versions.
Just as an experiment I just removed Java 7 from my laptop and Archicad 17 still opens.
Whether it will have problems I don't know as I haven't fully tested it.
But I think when there are updates or the next version 18 then Java 7 will get re-installed.

Now that J7 has been removed (I still have J6) this forum and the Internet Explorer seem very slow.
Coincidence?
I haven't restarted my machine so I might try that in a minute.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!