Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Layer Combinations

Anonymous
Not applicable
After I changed the story height of the main floor in Story Settings none of the plan views (Navigator-View Map) will include their Layer Combination when I switch between them. The Sections and Elevation views still work properly, so I am sure that this is a story
problem only.

When I switch views the information on the Navigator Properties pane changes to show the correct layer combo set for that view. Incorrectly however, pulling down the Layer Settings menu shows that the last Layer Combo is still in effect, although none is highlighted. when I click the Settings button in Navigator and then click “get current window settings” the Layer combo item changes to Custom and a yellow triangle appears on the Properties pane of the Navigator.

If I try to change the combination setting first in either Layer Settings or in the Quick Options pallet it doesn’t help; Quick Options immediately goes to Custom and won’t support any of the plan view combo’s, and changes to Layer Settings won’t stick either.

I’d like to find a way to correct this before I have to copy & paste into a new file. I’ve tried to reverse the changes I made in the Story Settings and tried the usual experiments on a copy of the file...no luck. Even perused the manual and searched here. Anyone have an idea of how to salvage this ?

Thanks,
6 REPLIES 6

Anonymous
Not applicable
I just encountered a case where a particular Layer Combination wasn't sticking. I'd select the combination (one that has resided in my Template file for donkey's years), the layers changed, but the Navigator Properties and Quick Layers both displayed "custom". Strange.

So I went to the Layer settings, (no layer combination was highlighted, as in Wally's case), selected the Layer combination, picked a layer at random and turned it off then on again, and updated the Layer Combination.

It now works fine, shows the right layer combination in navigator and quick layers.

Barry Kelly
Moderator
s2art wrote:
I just encountered a case where a particular Layer Combination wasn't sticking. I'd select the combination (one that has resided in my Template file for donkey's years), the layers changed, but the Navigator Properties and Quick Layers both displayed "custom". Strange.

So I went to the Layer settings, (no layer combination was highlighted, as in Wally's case), selected the Layer combination, picked a layer at random and turned it off then on again, and updated the Layer Combination.

It now works fine, shows the right layer combination in navigator and quick layers.

I have had a similar experience to what you describe Stuart.
Seems to happen only on old version 8.1 files that we have updated with the Attribute Manager.
We have Cadimage add-ons loaded which I expect may be the culprit as we quite often get 2 or more "ArchiCAD - master only" layers.
Also I remember in the early days of V10 there was a bug with Cadimage leaving the layer combinations showing as "Custom" when they were used which makes me think the problem may be related to the add-ons.

I found that the layer combination when selected would revert to "Custom" in the "Quick Options".
Looking in the layer list, the combination would not be highlighted and one of the layers that was supposed to be on was turned off.
Oddly though the little tick next to the layer combination showed that that layer should have been turned on.
Turn it on and "Update" and all was fine.
This same layer was off in all layer combinations where it was supposed to be on, but because the tick showed next to the combination still it was very easy to track down where it needed fixing.

So maybe it would be a good idea to check that the correct layers are actually still on.
There may be one that you haven't noticed that is turned off.

Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Barry wrote:
So maybe it would be a good idea to check that the correct layers are actually still on.
There may be one that you haven't noticed that is turned off.

Barry.
I have seen the Quick Option state "Custom" for many of my saved views. In the Navigator View Map, the Layer combination shows correct though. Opening the Layer Dialog box shows that the Layer combination is not actually highlighted, and if the layer combination is selected the one layer that seems to show on is the " ArchiCAD - master only" Layer. Even with out doing an update of the layer combination, the view now states the proper layer combination in the shows correct in Navigator view map and the Quick Option. Strange. It seem that just opening the Layer DBX sets it correct.

At first I thought that the " ArchiCAD - master only" must of had to be on and part of the layer combination, but this is not the case. some views "work" in Quick Options and have that layer locked and off.

I can make no sense of it. I guess it is good advice to check and double check what AC is doing. Is this a bug? will it be fixed before AC11? Or is AC10 now what AC10 ever will be?

Anonymous
Not applicable
Barry

I've had the exact same issue with the Cadimage addon and the layer
combs switching to custom.
I've found a work around for this.
In the folder - C:\Program Files\Graphisoft\ArchiCAD 10\Add-Ons\CadimageTools - is a file MasterLayers.ini
This contains the ArchiCAD - Master Only layer string.
I simply deleted all strig and saved it and have had no issues since.


Kristian

__archiben
Newcomer
Kristian wrote:
I've found a work around for this.
In the folder - C:\Program Files\Graphisoft\ArchiCAD 10\Add-Ons\CadimageTools - is a file MasterLayers.ini
This contains the ArchiCAD - Master Only layer string.
I simply deleted all strig and saved it and have had no issues since.
putting aside thoughts concerning add-ons writing attributes without the user's say-so, cadimage did acknowledge this as a bug and fixed it with patch some months ago now. downloading and re-installing their latest batch of tools should fix things.

of course, add-ons not writing project attributes would solve things once and for all

~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
s2art wrote:
So I went to the Layer settings, (no layer combination was highlighted, as in Wally's case), selected the Layer combination, picked a layer at random and turned it off then on again, and updated the Layer Combination.

So logical, but not what I did. I re-built all of my Plan View Layer Combinations, and as I set-up Layers by tools there are many...

cheers

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!