cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Setup & License forum

OpenGL issue with latest ARCHICAD 21 Update

Anonymous
Not applicable
A colleague has installed the 5010 update, and now when she goes to 3D window there is no Open GL option. In the 3D Styles dialogue there is only the Vectorial Engine option available from the drop down 3D Engine setting for all styles. Is this a bug or should she run the update again? Or go back to the previous (3009) update?
9 REPLIES 9

Barry Kelly
Moderator
I just updated to 5010 and it is all good for me.

Try the old IT fall-back of re-start the machine.
If still no luck run the update again.
Last resort roll back or re-install.

Barry
3D_styles.jpg

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Anonymous
Not applicable
Thanks Barry.

Tried a full re-install and restart but that doesn't seem to have fixed the problem

I'm wondering now if it is specific to the file itself, or to a particular computer. The file has this issue on a couple of computers here, but not mine, and other files work OK for everyone. On one of the machines where it did not work we got an "OpenGL has been disabled" error message (attached).

So in summary:
Computer no. 1 - No OpenGL in any file
Computer no. 2 - No OpenGL in one file, OpenGL OK in other files
Computer no. 3 - OpenGL OK in problem file and all others too.

Maybe this discussion should be moved somewhere else, as I now don't think it is related to the update.
Error message.jpg

Anonymous
Not applicable
I have the same problem. I wanted to install AC21 on my laptop to work at home in the holiday. I had already AC 20 on it, OpenGL works still fine in that version. But now I need 21, I see OpenGL in the folder but not in the Add-on Manager in AC21. I cannot even add it manually.

win10pro hp powerbook 6470b intel i5 intel hd graphics 4000

Driver up to date. OpenGl Entensions Viewer 5.0.6 shows I have OpenGl 4.0, up to date too.

Anonymous
Not applicable
Yes, the Open GL is not an option on my AC21. See the Add-On Manager screenshot. How do I solve this? I am running the trial version and have burned up 4 days trying to get this to work.

Anonymous
Not applicable
And could you find the solution?

Anonymous
Not applicable
I did find a solution.

Make sure the video drivers are up to date.

I use Windows 10. I had to uninstall AC21.
Restart.
Installed AC21 build 3005.
Installed AC21 Update 5010.
Restart.
When I checked the OpenGL add-on, it was there and the 3D views were showing correctly and panning smoothly.

Also I made sure that nothing else was open or running.

Anonymous
Not applicable
An update: The solution with Open GL is corrected. I can see the Open GL in the Add-On Manager, BUT AC21 is crashing within five minutes of starting every time. I am using the trial version. Could the trial version be a factor?

Anonymous
Not applicable
For me it turned out to be a problem with the video drivers installed on my HP ProBook 6470b with an Intel HD Graphics 4000 video card. With the default (and latest, officially supported) driver from HP, which is 9.17.10.4229 (26.05.2015), I got the "OpenGL has been disabled" error, though the OpenGL version supported by this driver is 4.0 (I verified it also with a third party tool).

The solution was upgrading the driver manually using the guidelines from Intel: https://www.intel.com/content/www/us/en/support/articles/000005629/graphics-drivers.html. With the latest driver 10.18.10.4653 (07.04.2017) it seems to work now, I can select and use the OpenGL option in the 3D-Engine dropdown menu.

It does not crash on my computer.

TMA_80
Booster
On my side, I Had this issue too, here is the way I solved this ( In ArchiCAD20):

1- Downloaded the latest nvidia driver ( from the nvidia website)
2- as read somewhere, dowloaded ddu ( nvidia uninstaller)
3- In windows safemode , lunched the ddu
4- from ddu; choose nvidia and clean
5- restarted the machine
6- installed the latest nvidia driver

There was apparently an issue ( conflict?) with the microsoft default nvidia driver, now everything seems running alright.
AC12_20 |Win10_64bit|

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!