cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Setup & License forum

Pen Set gets overwritten

Bruce
Booster
I am encountering an interesting problem where ARCHICAD overwrites my Modelling pen set (coloured) with my Publishing pen set (B&W). This has happened often enough that I know it's not me, but too infrequently for me to figure out a cause.

I have 6 pen sets in the file, but it's only these two that it's happening to. The Modelling pen set doesn't get overwritten by any other pen set, and no other pen set gets overwritten.

I am working on the hypothesis that if I have the Publishing pen set active in a section / elevation / interior elevation window, and flick to another window often enough, ARCHICAD gets confused. Not sure though.

Has anyone else encountered this?
Bruce Walker
http://www.brucepwalker.com
https://www.mindmeister.com/65450406
-- since v8.1 --
AC25 5010 AUS Full | Windows 10 64 Pro | 12th Gen Intel i7-12700H 2.30 GHz | 64 Gb RAM | NVIDIA GeForce RTX 3060 32 Gb
15 REPLIES 15

Laszlo Nagy
Community Admin
Community Admin
When you say that it gets overwritten, what exactly do you mean by it? That in the Pens and Color Dialog the definition of every Pen in the Pen Set becomes different?
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Bruce
Booster
Yes, that's right.
Bruce Walker
http://www.brucepwalker.com
https://www.mindmeister.com/65450406
-- since v8.1 --
AC25 5010 AUS Full | Windows 10 64 Pro | 12th Gen Intel i7-12700H 2.30 GHz | 64 Gb RAM | NVIDIA GeForce RTX 3060 32 Gb

Laszlo Nagy
Community Admin
Community Admin
Wow, that is something I have never seen before.
Could you post some screenshots that shows how this looks like?
I will bring to to the attention of GS HQ.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC26
Loving Archicad since 1995

Bruce
Booster
This is my model pen set
Bruce Walker
http://www.brucepwalker.com
https://www.mindmeister.com/65450406
-- since v8.1 --
AC25 5010 AUS Full | Windows 10 64 Pro | 12th Gen Intel i7-12700H 2.30 GHz | 64 Gb RAM | NVIDIA GeForce RTX 3060 32 Gb

Bruce
Booster
This is my Publishing pen set. When it happens (which I can't duplicate at will...haven't figured out what causes it), my Modelling pen set (previous post) looks exactly like my Publishing pen set - colours, pen weights, definitions etc.
Bruce Walker
http://www.brucepwalker.com
https://www.mindmeister.com/65450406
-- since v8.1 --
AC25 5010 AUS Full | Windows 10 64 Pro | 12th Gen Intel i7-12700H 2.30 GHz | 64 Gb RAM | NVIDIA GeForce RTX 3060 32 Gb

DGSketcher
Rockstar
I have had this about three times in v21 but only a projected started in v20. In my case I assume it was the default pen set overriding my personal pens. Impossible to identify when or how it was happening so I settled for just using attribute manager to restore my pens.
Apple iMac macOS Monterey / AC26UKI (most recent builds)

jffgrffn
Enthusiast
I have also had this happen, as recently as today in fact, hence the reason why I'm visiting the message board.

Here's my typical pen set:
https://www.dropbox.com/s/7caqhy779az73id/Pen%20Set.JPG?dl=0

Here's what it changes to:
https://www.dropbox.com/s/dyvxru4mzfl2k6s/Pen%20Set%20Issue.png?dl=0
iMac 27 (2020) 3.8 GHz Core i7; 128 GB RAM; Radeon Pro 5700 XT 16 GB GPU (macOS Monterey)
ArchiCAD 26/25/24 Full (latest builds). User since AC12 (2008).

Daniel Kovacs
Graphisoft
Graphisoft
Hello guys,

Bruce and jffgrffn! Next time you guys experience this (I suppose you will instantly realise that the pens in your floor plans just got messed up), could you get the following and send it to me, so that we can look into it and see if we can find anything?
- When you realize the change, do a save, and put aside the PLN and the BPN files (because the BPN is the previous save, so this way we would have a before-after state).
- Make a not about when you noticed the change (like it probably happened today, between 12:10-12:20)
- Quit ARCHICAD, and go to 'C:\Users\<username>\Graphisoft\ARCHICAD-64 Log Folder\<ARCHICAD version>\FastLogger'. Make a ZIP of the contents of the FastLogger folder, and put that aside for us too.
- Send me the ZIP, the BPN and the PLN in a Private Message, so that we can look at the logs to see what might have happened in the file structure between the given time period that could cause this.
- If you have any guess what it is that you did during that time that has something to do with attrbutes, make sure to mention that as well.

As a short term solution (as you mentioned), it is best if you save out the pen sets, and just overwrite them in the Attribute Manager when they go bad.

Thanks,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Bruce
Booster
Will do.
Bruce Walker
http://www.brucepwalker.com
https://www.mindmeister.com/65450406
-- since v8.1 --
AC25 5010 AUS Full | Windows 10 64 Pro | 12th Gen Intel i7-12700H 2.30 GHz | 64 Gb RAM | NVIDIA GeForce RTX 3060 32 Gb

jffgrffn
Enthusiast
Daniel,

Link to PLN, BPN & ZIP file sent to you in a PM.

Thank you,
Jeff
iMac 27 (2020) 3.8 GHz Core i7; 128 GB RAM; Radeon Pro 5700 XT 16 GB GPU (macOS Monterey)
ArchiCAD 26/25/24 Full (latest builds). User since AC12 (2008).

Daniel Kovacs
Graphisoft
Graphisoft
Hello,

Thank you for the files Jeff, it is exactly what we needed! We can see what goes wrong in the file structure now. We are still investigating the possible cause which is probably going to take some time, but this is a big step forward, so thanks again.

In the meantime, if anyone else experiences this, you should contact your local support, so that they can gather the necessary files/information for us.

Thanks,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Bruce
Booster
I've just encountered an interesting variation: only 3 pen definitions got overwritten, not the whole set. They were three pens that I can recall changing an object from, or to in the last two days.
Bruce Walker
http://www.brucepwalker.com
https://www.mindmeister.com/65450406
-- since v8.1 --
AC25 5010 AUS Full | Windows 10 64 Pro | 12th Gen Intel i7-12700H 2.30 GHz | 64 Gb RAM | NVIDIA GeForce RTX 3060 32 Gb

Anonymous
Not applicable
Hi all,

Just checking if there has been any resolution on this topic? I have had 3 users this week ask me about this problem, or the variation of it where only a few pens change. All users are on AC21.

Thanks in advance,

Richard

DGSketcher
Rockstar
I think within the AC program there is a basic attribute error check that views the pen sets and if they don't meet the required criteria then AC protects itself by creating and overwriting the first pen set with default values. There is no warning, and when it happens isn't clear as I have noticed it in drawings with a cold boot from the day before and just opening a different drawing. If this is what is going on then the first pen set should be hard coded e.g. can't be deleted, and then everything after that is the end users responsibility.
Apple iMac macOS Monterey / AC26UKI (most recent builds)

Daniel Kovacs
Graphisoft
Graphisoft
EJE wrote:
Hi all,

Just checking if there has been any resolution on this topic? I have had 3 users this week ask me about this problem, or the variation of it where only a few pens change. All users are on AC21.

Thanks in advance,

Richard
Hi,

We are planning to include a fix for this in the next update of ARCHICAD 22 (build 50xx) - the next 21 update comes sometime later. Since it is extremely hard to reproduce, we are having a hard time verifying that this will solve the problem 100%, so we are still investigating/testing but I am confident about this one.

We are planning to release a preview version of the update for english speaking languages in a month or so, so you will be able to test it first hand. You will find it as fix #246031, in the release note.

Regards,
Daniel Alexander Kovacs

Professional Services Consultant

GRAPHISOFT



For Troubleshooting and useful Tips & Tricks visit

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!