Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Sluggish 2D Performance Archicad 23 with AMD Ryzen 3900X and 5700XT

jamesMorris
Booster
Similar to my previous post (https://archicad-talk.graphisoft.com/viewtopic.php?f=7&t=59301&p=286446&hilit=sluggish#p286446). I have quite extreme 2D performance Problems with a new system. But this time the other tricks do not work. We have this workstation twice and only the workstations with the newer drivers has this problem.

Sluggish system: Bios AGESA Combo-AM4 1.0.0.4, Chipset 1.11.22.0454, GPU 19.12.2
Working system: Bios AGESA Combo-AM4 1.0.0.3, Chipset 1.9.27.1033, GPU 19.9.2

AMD is killing Nvidia and Intel with the price / performance ratio but Graphisoft is lacking behind proper support
1 ACCEPTED SOLUTION

Solution
Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi James,

We once have a similar case like what you describe, but it happened back when AMD just released the Ryzen line. It was fixed in a BIOS update, but I'm not sure if this is a regression issue with their new driver.

Back then, we suggested the user using "Game Mode". Although it will disable half of the processor's cores, due to Threadripper’s complicated architecture, it presents challenges to applications that synchronize threads for calculations or require frequent fetches from memory, so this setting might improve the slow performance in ARCHICAD.

I would like to try one more thing test as well:
- Run cmd.exe it as an Administrator.
- Type: bcdedit /enum (see bcedit_view.jpg attachment)
- Look for “useplatformclock” and whether the value is set to yes.
- In case the value is yes, run the command: bcdedit /set useplatformclock false
- To be on the safe side, run also the command: bcdedit /deletevalue useplatformclock
- Reboot the machine and check again the responsiveness of the machine with ARCHICAD.

This will disable HPET https://en.wikipedia.org/wiki/High_Precision_Event_Timer

Let me know if the above tests help in any way.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

View solution in original post

3 REPLIES 3

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi,

Thank you for posting this issue here, and I'm sorry about this experience!

Could you provide a little bit more information about the situation? You mentioned that newer drivers system has performance issue, meaning this system worked well before?

Could you provide some context on which operation is causing slowness issue? maybe a demo file/video may help!

One last thing, there are some reports online regarding this new BIOS version (1.0.0.4) makes the average performance lose some 100MHz, but it does not explain the case here.

I am looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

jamesMorris
Booster
It is quite hard to give solid responses to your questions. It differs from project to project and we are now already on the next chipset, bios driver. By clearing all user content and reinstalling ARCHICAD we mitigated to problem again for some time.

What would be the appropriate way to do if it happens next time? Last time we got a tool called sleepy tool to analyse it.

To answer your questions, yes it worked before.
(Sluggish system: Bios AGESA Combo-AM4 1.0.0.4, Chipset 1.11.22.0454, GPU 19.12.2
Working system: Bios AGESA Combo-AM4 1.0.0.3, Chipset 1.9.27.1033, GPU 19.9.2)
No video, but imagine ever click you make takes 5 seconds to load.
OS is Windows 1909

Solution
Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi James,

We once have a similar case like what you describe, but it happened back when AMD just released the Ryzen line. It was fixed in a BIOS update, but I'm not sure if this is a regression issue with their new driver.

Back then, we suggested the user using "Game Mode". Although it will disable half of the processor's cores, due to Threadripper’s complicated architecture, it presents challenges to applications that synchronize threads for calculations or require frequent fetches from memory, so this setting might improve the slow performance in ARCHICAD.

I would like to try one more thing test as well:
- Run cmd.exe it as an Administrator.
- Type: bcdedit /enum (see bcedit_view.jpg attachment)
- Look for “useplatformclock” and whether the value is set to yes.
- In case the value is yes, run the command: bcdedit /set useplatformclock false
- To be on the safe side, run also the command: bcdedit /deletevalue useplatformclock
- Reboot the machine and check again the responsiveness of the machine with ARCHICAD.

This will disable HPET https://en.wikipedia.org/wiki/High_Precision_Event_Timer

Let me know if the above tests help in any way.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

View solution in original post

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!