Setup & License forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Starting slowiness on Windows 10 v2004 update

runxel
Mentor
Anybody else who has issues with Archicad on Windows 10 v2004?
Archicad seems to have big trouble starting. Surely, AC sadly never was blazingly fast and could be much better in this regard, but after I installed (or rather was finally overruled by my PC...) the big update Archicad has really some issues in getting starting. Version doesn't even matter.
Tested it from 24 down to version 20. All are starting significantly slower. Sometimes they don't come up at all and have to be sniped from the task manager (which by the way shows, that AC in these cases seem to fail allocate more than a few mb of RAM and says "unresponsible").
If it starts, it takes now round about 10–15 minutes until I can work.
No other programs are affected.

PS: Before anybody asks: no anti-virus, everything else (drivers etc) is uptodate...
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»
13 REPLIES 13

Barry Kelly
Moderator
Do you have multiple monitors?
And by any chance is Archicad starting on your 2nd monitor?

I have 2 screens but usually have Archicad open on my main (number 1) monitor.
However yesterday while I was setting up 24, I dragged it across to my second monitor.
When I started it again it started on the second monitor but never got past the initial start up screen.
Task Manager showed it was running but nothing much happening in CPU %.
Ended task and started again and it started better.
I am not sure exactly what was happening as I had multiple 24, 23 & 22 running at the same time, and I will need to test it some more to see if I can figure out if there is a problem and what is the cause.

But just curious if you have Archicad on your second monitor?


Barry.

One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

runxel
Mentor
Hi Barry, thanks for chiming in!

Indeed, I normally have a second display attached to my laptop, and start times are even longer then. But I have the same issue when the second display is not attached. I was working (or... trying to) on the train yesterday, which led me to the point writing here.
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

runxel
Mentor
Some news:
Networking seems to be the issue.
Analysing the wait chain with the task manager tells me that Archicad is waiting for some network IO to be finished.

Looking at the Windows resource monitor it says that Archicad is doing an IP loopback on port 22350 and it's listening on ports 60200, 65050, and 65110.

After 10-20 minutes Archicad connects to 99.84.158.126 on port 80 and to 99.84.155.277 on port 443.
Now Archicad finally comes up. After about half a minute those connections will be cut.

WHAT IS GOING ON?
You can't work if you have to wait half an hour everytime you open a file....
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

DGSketcher
Virtuoso
Shot in the dark if AC24 has got slower opening over time, I had a looooong save time issue, this was related to the number of files in the recent list of the start up dialog. Clearing the list brought everything back to normal. This is a known bug with GS. Just thought that you might be seeing the opposite end of the same problem.
Apple iMac macOS Big Sur / AC24UKI (most recent builds)

SeRohde
Enthusiast
runxel wrote:
PS: Before anybody asks: no anti-virus, everything else (drivers etc) is uptodate...
I know you stated this, but what about Windows Defender? I always add Archicad and related folders to the Exclusions with good results regarding overall speed of AC.
runxel wrote:
Looking at the Windows resource monitor it says that Archicad is doing an IP loopback on port 22350 and it's listening on ports 60200, 65050, and 65110.
Port 22350 is the default Port used by Archicad and Codemeter for the Licensemanagement
The other High Ports i don't know about for sure. I assume the are related to AC exchangeing files via UDP with the Teamworkserver.
Admin of BIM [Cloud] [SaaS] [Server] | AC 19-25 [Win&Mac Clients] | VM's

runxel
Mentor
SeRohde wrote:
t what about Windows Defender? I always add Archicad and related folders to the Exclusions with good results regarding overall speed of AC.
Nice trick. I've added the folder now, too. Startup times doesn't seem to be affected significantly, tho.

SeRohde wrote:
Port 22350 is the default Port used by Archicad and Codemeter for the Licensemanagement
The other High Ports i don't know about for sure. I assume the are related to AC exchangeing files via UDP with the Teamworkserver.
Thanks for this info! (:
I thought similar, too.
DGSketcher wrote:
related to the number of files in the recent list of the start up dialog
My first suspect, too. Cleared it with no effect.

-----------------------------------------------------------------------------------

I hope a dev will hop in this thread soon.
Some more info for you, I hope it's valuable.
This time the Archicad Starter.exe didn't respond. Ressource monitor gave the me thread number which made the trouble. Going into Sysinternals Process explorer I had a look at the threads.
The stack for the locked up thread (start adress: ARCHICAD Starter.exe!InitAuto Tester+0xe0fc)is this:

ntdll.dll!ZwWaitForSingleObject+0x14
KERNELBASE.dll!WaitForSingleObjectEx+0x8e
GSRoot.dll!GS::ThreadCpuTime::GetCurrentThreadCpuTimeInNanos+0xf6c
GSRoot.dll!GS::ThreadGuard::~ThreadGuard+0x12fb
ARCHICAD Starter.exe+0x866a
ARCHICAD Starter.exe+0x81ad
GSRoot.dll!GS::Main+0x40
ARCHICAD Starter.exe!InitAutoTester+0xf06c
ARCHICAD Starter.exe!InitAutoTester+0xe08e
KERNEL32.DLL!BaseThreadInitThunk+0x14
ntdll.dll!RtlUserThreadStart+0x21
This thread does also multiple hundred thousands of context switches, which isn't great I guess? At least this amounts to considerable performance drain on the CPU.
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

SeRohde
Enthusiast
I forgot to mention:
since the Defender Dialogue for Exclusions is somewhat unprecise I added Folders, Files & Process like:

- Archicad TW Data:
- C:\Users\NAME\Graphisoft\
For each (!) Archicad installation:
- Archicad installation Folder
For each Archicad File & For each Process
- ARCHICAD.exe
- ARCHICADStarter.exe
- OverwatchServer.exe
- \CinceRender\CineRenderNem.exe
Admin of BIM [Cloud] [SaaS] [Server] | AC 19-25 [Win&Mac Clients] | VM's

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hello,

Thank you very much for reporting the issue and I am very sorry for the experience!

From my experience, we usually see 2 common problems: outdated Intel GPU driver and licensing connection (on Windows). Here, it looks like the computer is having an issue with acquiring/checking license. To verify this, could you start Archicad in DEMO mode and see if it gets faster? There are multiple ways to do this, depending on your license type: upload the software license back to the pool, unplug the CodeMeter dongle, or simply unplug the internet cable.

(Also, please make sure that all drivers, especially the graphics ones, are up-to-date. You may need to look for the installer from Intel and NVIDIA/AMD websites rather than waiting for Windows Update, as it is much faster this way).

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Karl Ottenstein
Moderator
No solutions from me - just a thank you to Runxel for posting the problem. I've put off upgrading to the version 2004 update of Windows 10 for months after initial reports of people having issues with it. Your slowness - and another user who posted that AC keeps crashing on them with 2004 - will keep me off this update until some positive reports come in. Sticking with version 1909 for now.
One of the forum moderators   •   AC 25 USA and earlier   •   MacOS 11.6.1, iMac Pro

runxel
Mentor
Karl wrote:
No solutions from me - just a thank you to Runxel for posting the problem. I've put off upgrading to the version 2004 update of Windows 10 for months after initial reports of people having issues with it. Your slowness - and another user who posted that AC keeps crashing on them with 2004 - will keep me off this update until some positive reports come in. Sticking with version 1909 for now.
Yes, good choice, Karl!

Now it got even worse and Archicad won't start any longer – it just crashes directly....
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
runxel wrote:
Yes, good choice, Karl!

Now it got even worse and Archicad won't start any longer – it just crashes directly....
Hi runxel,

Sorry to hear about the issue!

I'm wondering if you saved/wrote down any bugID you had? When did that happen: did it crash right after the splash screen, at file opening, or at other stages?

Have you tried to test it with my previous comment (start AC in DEMO mode, update graphics card drivers)?

I have 2 Windows machines, one of them is running 1909, the other is updated to 2004. None of them demonstrate the issue mentioned here.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

runxel
Mentor
mnguyen wrote:

I'm wondering if you saved/wrote down any bugID you had? When did that happen: did it crash right after the splash screen, at file opening, or at other stages?

Have you tried to test it with my previous comment (start AC in DEMO mode, update graphics card drivers)?
Hi Ming! Thanks again for chiming in.
This turns out to be more and more mysterious.

So first, yes, the bug reporter came up nearly instantly after clicking on the Archicad icon, but it was all blank! It only showed the "send" button (which was empty, too). So I couldn't copy the bug id 😕

I restarted, and well, it went away. #classic


The second thing is, I'm now at home again, so I have my second display connected, and the start times improved drastically! I can't explain why that would help, and for sure this is something nearly impossible to debug, but:
• External display connected: "normal" startup times, at least not soo bad like:
• No external display connected: super slow startup times.


I know for sure, before win 10 v2004 it never was like this. So surely this update changed something?

And yes, drivers are as uptodate as they can get.
AC 24 [ger] | Win 10 | Developer of the GDL plugin for Sublime Text |
«Furthermore, I consider that Carth... yearly releases must be destroyed»

Minh Nguyen
Graphisoft Moderator
Graphisoft Moderator
Hi,

Thank you for the information! This is very interesting to me, usually we received the similar issue when the external screen is connected, not the other way around

Seems like this is hardware related rather than licensing issue. To confirm this, could you disable the integrated Intel GPU in Device Manager > Display Adapter for a while? With this device turn off, Archicad will have to force itself either running with the dedicated GPU, or simply not touching the integrated GPU part.

If this makes AC start faster, we can narrow down the issue to the Intel driver. Please update it, if that's the case.

But if not, could you please collect the dump file of the ARCHICAD.exe process when Archicad is freezing (open Task Manager, navigate to Details tab, right click ARCHICAD.exe > Create Dump file)?

Also, I would like to have a look at the System Information.

Let me know if you need a place to upload the files if we reach this far.
Thank you very much!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!