cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Wishes forum

ArchiCAD's new/improved .PDF creator needs to be fixed

David Larrew
Booster
My office is currently switching from the old-school .PLT file creation to a more stream-lined .PDF file creation for printing/plotting output.

The ArchiCAD .PDF creator does not embed fonts. We use the free "ArchiTEXT.TTF" that was part of one of ArchiCAD's Goodie packages. This font does not get published within the .PDF (no text).

As an interim work-around, we are printing to our licenced Acrobat .PDF distiller. But I would prefer to to use the built-in .PDF creator due to some of the benefits of the direct-write process.

Graphisoft, please fix this!
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA
7 REPLIES 7

Anonymous
Not applicable
I did a search for articles containing "pdf" and "architext" because I was having the same problem, and yours was the only result, (aside from a question that, ironically enough, I wrote a few years ago that had nothing to do with this topic. I have been using the ArchiTEXT font for years and, like you, was using plt format for virtually all of my plotting. I was told by my Graphisoft dealer that I should switch to the pdf publisher for reasons that make a lot of sense, but I guess in order to do that, I'm going to have to change all my fonts on all my templates. Not to mention the hassle of trying to publish plans created with AC9 in the new AC11 format. Can't this be addressed in a Hot Fix?

Karl Ottenstein
Moderator
Hi David,

Do you have the embedding options checked as in the attached screenshot?

Cheers,
Karl
font-embedding.gif
One of the forum moderators   •   AC 26 USA and earlier   •   MacOS 11.6.8, iMac Pro 10-Core, Radeon Pro Vega 64

David Larrew
Booster
Karl,

Yes. Believe me, this is frustrating because my "ArchiTEXT Bold" font works fine but my "ArchiTEXT" font doesn't even appear. I got both fonts from an earlier Goodies package (maybe AC 6.5-7.0) - They were part of Rex's Envision ATS template system.

To add to my frustration, GS Tech Support "Force Closed" my bug report without an explanation.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

David Larrew
Booster
To give y'all an update...

The built-in .PDF creator is not the same as the Amyuni print driver from AC10. So any changes to the Amyuni settings are irrelevant to the ouput of the built-in .PDF creator.

GS Tech Support reopened my bug report case. Unfortunately, they are having trouble understanding and/or reproducing the problem. BTW, it is also broken in the 1114 build.

Back to converting all of our templates, favorites, and object defaults to use "Arial" font.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

Thomas Holm
Booster
David wrote:
... Believe me, this is frustrating because my "ArchiTEXT Bold" font works fine but my "ArchiTEXT" font doesn't even appear. I got both fonts from an earlier Goodies package (maybe AC 6.5-7.0) - They were part of Rex's Envision ATS template system.
Seems to me you've got some font corruption, or perhaps some missing font ID (that Adobe Acrobat tolerates, but not Archicad) that makes Archicad think it's a system font that doesn't need to be embedded or something similar.
Have you tried re-installing the font? Did you check it with some font utility? (I use the free FontExplorer X, but the Windows version isn't ready yet http://www.linotype.com/3321/freedownloadpc.html?PHPSESSID=b2073932f3c297249b6db43c0abfc005 )
AC4.1-AC24SWE-25INT; OSX11.5; MP5,1+MBP16,1

Karl Ottenstein
Moderator
David wrote:
Yes. Believe me, this is frustrating because my "ArchiTEXT Bold" font works fine but my "ArchiTEXT" font doesn't even appear. I got both fonts from an earlier Goodies package (maybe AC 6.5-7.0) - They were part of Rex's Envision ATS template system.
I imagine you've been in touch with Rex? Those fonts never worked well for me (cannot remember why).

I choose MrHand back then. With ArchiCAD 10 (or 9?) MrHand stopped working properly - as it was a 'symbol' font and did not properly support unicode or something. Text showed up as jibberish.

I bought an updated version and then used a free font editor to fix a few characters in the font that didn't read well (a few digits, spacing between a few characters, etc.). The updated version has been fine - except for the one user in Australia mentioned in your parallel thread who could not see the font even though it was embedded (verified by Acrobat Pro).

Cheers,
Karl
One of the forum moderators   •   AC 26 USA and earlier   •   MacOS 11.6.8, iMac Pro 10-Core, Radeon Pro Vega 64

David Larrew
Booster
And this is not just about one font... I've tried several "hand" fonts with mixed and unpredictable results. One that I tried was an Adobe font family called "Tekton", this one wouldn't show the " (inch) mark.

BTW - My "ArchiTEXTBold" font doesn't work anymore, since the 1086 build.
David Larrew, AIA, GDLA, GSRC

Architectural Technology Specialist

a r c h i S O L U T I O N S



WIN7-10/ OSX 10.15.7

AC 5.1-25 USA

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!