cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Wishes
Post your wishes about Graphisoft products: Archicad, BIMx, BIMcloud, and DDScad.

Quick Layers Palette isn't compatible with hotlink modules

hfy
Participant

Hi all, we always working in big complex projects with using few hotlinks in file and i really like the practicality of 'quick layers' palette. I guess there is some compatibility issue between these two. When i select an element of a hotlink and use 'hide other's layer' button, model completely disappears because it hides hotlink's master layer as well. I know Archicad mainly meant to use layer combinations, not change layers visibility one by one, but in some situations i need to see only that layer. I wish the palette to recognize selected element's master layer and leave it shown too.

11 REPLIES 11
DavorP
Enthusiast

+1 for this!

BIM manager
Barry Kelly
Moderator

I think this will be an impossible wish, because you are telling to hide all of the other layers.

So that is exactly what it is doing.

Archicad has no way to know if you have created a dedicated layer for use as the hotlink master layer or not.

A master layer for a hotlink is just another layer you can turn on or off, it is not a special layer in any way.

You can use any layer you want as your hotlink master layer, you don't have to create a new one just for the hotlinks - unless you need to turn them off, leaving the rest of you model there.

 

This will work though if you place your hotlinks in the 'Archicad' layer.

This layer can never be turned off.

The added benefit in using that as the hotlink master layer, is all of you layer combinations will work without having to add any dedicated hotlink master layers to all of your layer combinations.

The downside is you can not turn off a hotlink, because you can not turn off the hotlink master layer ('Archicad' layer).

 

So if you do not need to hide individual hotlinks, then just use the 'Archicad' layer as the hotlink master, and it will all work as you expect.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

Thank you for your kind answer and practical solution Barry. But not using master layers is just too big sacrifice for us to do.

 

But there is something I couldn't quite understand, this tool recognizes its layer as I select an element. I know master layers are just normal layers, but software already know if selected element is a part of a hotlink. I mean, it could clearly recognize its master layer too.

 

I don't think it's impossible to do. I guess the programmer who coded this part didn't see this coming. I still wish archicad to repair this glitch. 

Generally speaking, unless you are using the hotlinks as design option alternatives, you would not want to turn the entire hotlink off.

Therefore the hotlink would not need its own unique master layer.

Put it in the 'Archicad' layer, and it will behave just the same as the rest of your model.

 

If you do need a unique master layer, that is fine.

You just have to include it in all of your layer combinations.

And if you find you have that layer ON in all of your layer combinations, you may just as well use the Archicad layer.

 

Now here is a very simple scenario for you, lets forget the unique master layer - we know that turns off when you hide all other layers.

Lets say you have around 5 layers, Archicad, walls, floor, roof, beams - just to keep it simple.

Your hotlink has the same layers.

As I said, place the hotlink in the Archicad layer and it all works as you want.

But if you place the hotlink in say the walls layer as the master layer, and you want to hide all other layers except the roof, you would be requiring it to not also hide the walls layer as well.

Otherwise your entire hotlink gets turned off - which is what you have found happens.

So you would need the master 'walls' layer to remain on, which you really don't want, because you only want to see the roof.

 

Now remember hotlink master layers are just like any other layer - nothing special.

So then what you would need is for the master hotlink layers to have an option to never turn off.

Especially if you have multiple hotlinks all with there own unique hotlink master layer.

You would still want to see all of the walls in the other hotlinks and not turn the hotlinks themselves off.

So Archicad needs to detect not only the master layer of the currnet hotlink that you have a roof selected in, but the master layer of all the other hotlinks as well, if you want it to automatically not turn off all of the hotlinks.

 

Which brings us back to square one.

If you are not turning the hotlink master layer off, just use the Archicad layer.

 

 

I am not sure if I have explained it well.

But I am sure it is not just a simple matter of detecting the master layer your current hotlink is in and not turning that off as well.

Also imagine if you were to just pick a roof that is not in a hotlink and turn off all other layers.

How does Archicad know not to turn off the hotlink master layers, as you weren't selecting anything in a hotlink?

And if you can tag your layers as being 'hotlink master layer - i.e. don't turn them off' then how do you turn them off when you need to.

You would have to un-tag them, which means they will hide when you hide all other layers.

 

You are trapped in a nasty circle (catch 22).

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11

"But if you place the hotlink in say the walls layer as the master layer, and you want to hide all other layers except the roof, you would be requiring it to not also hide the walls layer as well.

 

Otherwise your entire hotlink gets turned off - which is what you have found happens.

 

So you would need the master 'walls' layer to remain on, which you really don't want, because you only want to see the roof."

 

I think this is a pretty obvious and accurate result. If someone wants to use master layer properly, shouldn't mix them with other layers. It's a mistake of his/her own, clearly. If you don't want to see the roof, then don't assign it as master layer.

 

I understand you trying to tell me it's not the perfect solution theoretically. But Barry, when I click an element and simply tell hide others, it hides itself too. This is not better from any possible outcome.


@hfy wrote:

But Barry, when I click an element and simply tell hide others, it hides itself too. This is not better from any possible outcome.


No, it is not hiding itself.

It is hiding the master hotlink layer that is not the roof (element) layer.

Because the master layer is turned off the entire hotlink is turned off, including the roof for that hotlink.

The roof layer is still on, but you have turned the entire hotlink off which is why you don't see it.

 

Trust me, if you don't ever need to turn the hotlink off, put the hotlink in the Archicad layer and you will have no issues.

Or put the hotlink in the roof layer and you will still see the roof.

But that doesn't help then whrn you want to see just the walls.

 

Barry.

 

One of the forum moderators.
Versions 6.5 to 27
i7-10700 @ 2.9Ghz, 32GB ram, GeForce RTX 2060 (6GB), Windows 10
Lenovo Thinkpad - i7-1270P 2.20 GHz, 32GB RAM, Nvidia T550, Windows 11
DGSketcher
Legend

You explained that well @Barry Kelly, although I do sympathise with the opening post.

 

There is a possible solution to this that we can base on the Groups workflow. We have a universal option to "Suspend Groups", which allows for individual & multiple element selection that works with Quick Layers, perhaps we could have a similar switch option to ignore the Hotlink master layer and allow selection of Hotlink sub elements?

 

 

 

Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)

Barry, please don't act like I am a total newbie. I know which layer it's hiding, but in the end I see nothing in screen.

 

I trust you, but you don't trust me. We NEED hotlink master layers. We work in huge projects and export them to 3ds max as models. In both processes we have to use master layers, for hiding/showing when working fast and exporting as separate models. And what's the point of master layers if I won't use them. Your solution is just a workaround and it's not helpful in our situation. You can say you don't have time or will to fix this, I understand. I am not here to argue. It's been almost a year since I wish this. After a year you telling me not to use master layers. I better didn't use quick layers. That been my workaround solution for 11 months. I see the conversation is not going anywhere. Still thanks taking your time. 

Erwin Edel
Rockstar

Our work around is having the module master layer as close to the top of our layer name list as possible. CTRL+L to open Layer Manager and turn one layer on after using quick layer tool. It's not perfect, but works relatively quick.

 

An emtpy 'space' before the name generally does the trick, if you don't want to resort to using things like '!' etc

Erwin Edel, Project Lead, Leloup Architecten
www.leloup.nl

ArchiCAD 9-26NED FULL
Windows 10 Pro
Adobe Design Premium CS5