cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
2024 Technology Preview Program

2024 Technology Preview Program:
Master powerful new features and shape the latest BIM-enabled innovations

Archicad C++ API
About Archicad add-on development using the C++ API.

Does it matter which version of Visual Studio you use?

Anonymous
Not applicable
Hi, I'm working on an add-on built for ArchiCAD 11. It was compiled in VS 2005 by another developer and worked just fine. I just recompiled it in VS 2008 (release mode), but I get this error when I try to load it in ArchiCAD (demo mode):

The file is either not an Add-On or an outdated one that cannot be used with this ArchiCAD version.

Could VS 2008 be the issue? I read somewhere that VS 2008 cannot be used for some versions of ArchiCAD.


Thanks in advance.

Rohin.
3 REPLIES 3
Ralph Wessel
Mentor
rohin wrote:
I get this error when I try to load it in ArchiCAD (demo mode):
The file is either not an Add-On or an outdated one that cannot be used with this ArchiCAD version.
Could VS 2008 be the issue?
Definitely. Please refer to the System Requirements in the API Documentation:
On Windows you need Microsoft Visual C++ .NET 2003 installed.
From AC12 onward, you need VS 2005. Do not use VS 2008 for any ArchiCAD API development.
Ralph Wessel BArch
Software Engineer Speckle Systems
Anonymous
Not applicable
To clarify, reading from the source cited in postings below, the current quote is:

"On Windows you need Microsoft Visual C++ .NET 2005 installed."
Ralph Wessel
Mentor
didrik wrote:
"On Windows you need Microsoft Visual C++ .NET 2005 installed."
Only for ArchiCAD 12 and above. For ArchiCAD 11, you need VS 2003.
Ralph Wessel BArch
Software Engineer Speckle Systems