Choose your top Archicad wishes!

Read more
Collaboration with other software
About model and data exchange with 3rd party solutions: Revit, Solibri, dRofus, Bluebeam, structural analysis solutions, and IFC, BCF and DXF/DWG-based exchange, etc.

Unable to import Xref

Andre Gaspar
Contributor
Hi all,
I´m trying to import an DWG file but I´m receiving an error message.
When I try to attach a file this Warning message appears:

"An Xref with the name xxxxx already exists. Choose another file!"

That DWG is on the list "Xref Name:" but does not allow me to attach. The Attach button is grey and the Path: for the file is empty.

Also if I go to the Xref Manager menu the file I want is not there. So is not me trying to add the same Xref twice.

The file was added previously and removed.

Is there anyway to clean the list "Xref Name:" and add the file after?

Thank you.

Andre
7 REPLIES 7
Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni
Dear Andre,

Thank you very much for the report and I am very sorry about the issue!

I was unable to find any similar report in our database, so I am wondering if it's possible for you to share the project plan PLN file and the DWG file with us for further investigation? Let me know if you need a secure place to upload the file also.

Looking forward to hearing from you!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni
Dear All,

We have investigated this issue and concluded that it is a defect. It was quite easy to reproduce, all we need is having 2 DWGs with the same name placing at 2 different locations.

After we attach one of them, then detach it from the plan, attaching the other one from another location will result in the error message. Unfortunately, if you detach an Xref it doesn't get deleted in the background, and when you try to attach a new Xref with the same name but on a different path, it finds the previously attached one and fails. I entered it as defect DEF-3722.

Thank you very much for your understanding, and I am very sorry for the inconvenience!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Anonymous
Not applicable
We are having the same issue however we have cleared our ref manager and renamed our DWG files. Despite this we get the same message and are unable to attach a previously xref'ed file even if it was 'saved as' under a different name.

Is there a work-around to be able to address this issue and get the DWG file attached?
Thanks
Minh Nguyen
Graphisoft Alumni
Graphisoft Alumni
Hello,

Thank you for your report and I am very sorry to hear about the issue!

There was a fix for this similar issue included in Update 3 (build 5000) for Archicad 24. It is being rolled out globally. Could you give it a try to see if it works?

If it doesn't help, would it be possible for you to share with us the project file and the DWG for in-house reproduction? Please let me know if you need a secure place to upload the file.

Thank you very much!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Anonymous
Not applicable
Thanks Minh - we will try it again once we've done an update all computers to the new build.

Hi Minh,

 

We have just had a very similar if not the same problem,

 

I had imported an XREF into my file, to which I then detached at a later date, (none of the layers were removed so had to do this through Attribute Manager, - which I understand is another issue.

 

we then go to import the same xref (with the same name) but from a different folder and it says the same error as above, that another with the same name exists. 

 

I had reported this to the Graphisoft helpline which they confirmed that had not heard of, so I sent them to this post. 

 

Are there any fixes as yet? as we dont really want to have the change the xref name

JB - AC25 - Windows 10 -

Hi Minh,

 

Is this still an issue in 25/26? I just tried to reload Xrefs on a teamworks file from the local work server, but don't have access to the server a home, so I decided to detach the xref and try to reload them off my home computer. I've successfully detached them in the xref manager but now can't reload them as I get the same error message as the original post. Is there a way to clear the "xref names" list that shows when you attach a new xref? 

 

Of course I'm working on deadline, when I discover that this would be an issue, so any help ASAP would be greatly appreciated!

 

Thanks,

Cody