Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Allow 3rd party cookies

Chris Butler
Newcomer
Hi, this is a super basic and frustrating issue, am trying to log into myArchicad, but keep getting turned around with "
×
"In order to log in, you must allow 3rd party cookies."

All cookie options are ticked in the Cookie Settings. Just need to log in to renew student license. Any ideas?
Thanks
9 REPLIES 9

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Chris,

Thank you for sharing the issue and I am very sorry about the experience!

From your description, it is unknown to us which settings you are using with your browser. We had this issue reported first on macOS when the user was trying to login to MyArchiCAD using Safari back in February. I believed this issue has been solved, but I am not so sure.

If you are indeed trying to login using Safari, could you try with another browser (for example Chrome or Firefox), and log in to see if the problem is still happening with these browsers.

Let me know if this helps. Thank you very much, and have a nice weekend!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Chris Butler
Newcomer
Hi Minh,
Thanks for your reply, yes I am using MacOS Mojave, with Safari.
I don't have another browser, but could try getting one.
Screen shot here to show the cookie boxes ticked. No worries, it's not an issue with your site, something I need to sort out on my computer by the sounds of things.

Thanks

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
Hi Chris,

You can try the following options:
- Enable cookies for the browser (https://helpcenter.graphisoft.com/knowledgebase/31667/)
- Try another browser (Chrome for example)

If using Chrome does not solve the issue, try this:
In Chrome:
- Enter this line in the address bar: chrome://flags/#same-site-by-default-cookies
- Set it to disabled. Restart the browser.

I hope this will help you to log in to the site. Let me know the result of it!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

Chris Butler
Newcomer
Hi Minh,

I downloaded Chrome, and it worked no problems at all, so must be some issue with Safari.

Thanks for your help,

Chris

Olga Markina
Newcomer
Hi! Have the same problem. Cant access my account in Safari, when I try enter my password and username it redirect me to main page without login. When im using Chrome and allow 3rd party cookies its comes with error "too many redirects".
When I do this:
"If using Chrome does not solve the issue, try this:
In Chrome:
- Enter this line in the address bar: chrome://flags/#same-site-by-default-cookies
- Set it to disabled. Restart the browser."

Its also comes with error "too many redirects"

Best regards,
Olga

stefan
Booster
I had to use Microsoft Edge in Windows running in Parallels to access the page. I avoid to install Chrome on my Mac (but so many web developers seem to only care for Chrome).
--- stefan boeykens --- architect-engineer-musician ---
ARCHICAD25/Revit2020/Rhino6/Unity2020/Solibri
MBP2019:i9Octo2.4GHz32GBVega20/BigSur+Win10
ARCHICAD-user since 1998

mikas
Advocate
I don't know if this is related, but I am unable to log in to bimcomponents with Safari. Chrome works ok. It's been that way for a long time allready. I use Safari for everything else, so no problem with other sites though. MacOS Mojave, Safari 14.0.
AC24, Rhino6/7+GrasshopperMac Pro DP 3,33GHz/128GB/RVII/10.14.6 • HP Z440 E5-1650v3/256GB/RVII/W10Pro

Nguyen Minh
Graphisoft Moderator
Graphisoft Moderator
mikas wrote:
I don't know if this is related, but I am unable to log in to bimcomponents with Safari. Chrome works ok. It's been that way for a long time allready. I use Safari for everything else, so no problem with other sites though. MacOS Mojave, Safari 14.0.
Hello,

Thank you for your question!

If I remember correctly, on Safari, Apple implemented some stricter rules regarding website tracking. It seems to affect BIMcomponents here, as it gets the credential information via graphisoftid.graphisoft.com from a new tab.

To get around this and get BIMcomponents running on Safari, please open Safari's Preferences > Privacy tab > untick "Prevent cross-site tracking". After that, signing in with BIMcomponents should work.

I hope this answers your question. Please let me know if it works on your end!

Best regards,
Minh

Minh Nguyen
Technical Support Engineer
GRAPHISOFT

mikas
Advocate
Thanks Minh. It worked.
As a side effect, of course, I do have cross-site tracking active now.
😉
I'll let it be and live dangerously.
AC24, Rhino6/7+GrasshopperMac Pro DP 3,33GHz/128GB/RVII/10.14.6 • HP Z440 E5-1650v3/256GB/RVII/W10Pro

Didn't find the answer? Start a new discussion

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!