Design forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Pen 91 w/ Black Background

Anonymous
Not applicable
How do you handle using pen 91(white-out) pen with a black background.

I have tried it as a white pen, black pen, etc.

When using a white background, pen 91 obviously white-outs what you don't want printed.

With a black background, it will still white-out what you don't want printed, however it shows up as white and then you don't know, without going back to a white background what in fact has been whited-out.

Thanks, Grant
12 REPLIES 12

__archiben
Newcomer
if you are using 8.1, there is a pen '-1'. it only shows in the pop-up palettes of background colours (next to the transparent pen) - it has a small monitor as it's symbol and represents 'window background colour'.

i've not used it myself, however my understanding is that it can be used to this end to 'wipe-out' elements below it to the current background colour.

i'm not sure if it displays as such, or whether this is simply an output option . . . anybody care to comment?

~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
Thanks, but can't find. Can you tell me exactly where it is.

Thanks, Grant

__archiben
Newcomer
NOELDESIGNS wrote:
Thanks, but can't find. Can you tell me exactly where it is.

Thanks, Grant
grant

see attached screenshot - this is true for most 'background colour' settings.

alternatively just type '-1' into the pen dialogue - if it stays, it's a valid pen for that setting!

can't seem to find it in the manuals though!

HTH
~archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
Thanks for the reply,. I see that under fills, but what I am looking for is using it for a straight line.

When working in a white background, with a black line to represent a wall edge, I can use pen 91 to whiteout a line(of any color). When viewed and printed the non-pen-91 line is whited-out.

When using a black background, pen 91 won't work since AC shows it was white, and since black pens are converted in AC to white, you can't tell what is whited-out and what isn't.

Also, using a black pen to white-out using a black background doesn't work either.

Thanks,

Grant

__archiben
Newcomer
grant

not sure what it is exactly that you're trying to achieve. i've always personally felt that having to use 'white outs' represent something wrong with the way the program works or the way i'm working . . . both can be addressed one way or another (eventually)!

but that aside:
have you tried turning on 'automatic pen colour visibility adjustment' in the preferences and see what that does? i use it to view DWG files as they were intended (i.e. black pens will view as white on a black screen). as far as i know, this is display only and won't affect the output, but at least you may well be able to see what you're doing?

see attachment . . .

~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
Thanks for the reply. I do have automatic pen color visibility adjustment turned on.

While AC does join walls properly, that does not always translate into having the core composites join properly, as you can see in the attached image.

Here is where the problem is most evidant. First, the drawing without any adjustment just isn't technically correct. The walls have to join properly, but so do the various composite layers, especially the core. In the image provided, the walls do join properly, but not the core composite.

Also, when creating a dwg file for civil/structural, etc, you then have to massage the information in the DWG file so that it appears correctly. In this case, the civil turns off all composites except the core as he/she doesn't care about stone, stucco, siding, etc. As such, the walls do not close properly unless I go into the file and spend hours checking each and every wall. Waste of time.

I can use the proper pen color to make the wall appear as if it is joined in AC, however, I use a black pen for core composite, which when using a black background gets automatically changed to white. And therefore, the white-out pen won't work properly as it appears white and when viewing the plan you can't tell a wall line from a white-out line when the white-out line is covering up part of a wall.

Grant

__archiben
Newcomer
discussion taken to 'wishes' . . .

http://archicad-talk.graphisoft.com/viewtopic.php?t=1885
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
I need a fill with -1 color (windows back ground) to cover up portions of the drawing I dont want to print. I ve noticed that the break line library part (available at GDL object depository) has this feature and this is especially good when translating Archicad drawings to autocad (with a black background). White solid fills can do the same job but if the drawing is translated to autocad with a black background it shows up all over the page and looks ugly.
It is possible to create a solid fill with -1 color? If so, how?

__archiben
Newcomer
jocontreras wrote:
It is possible to create a solid fill with -1 color? If so, how?
yes - use "Empty Fill" and set the background pen colour to -1.

pens 0 (transparent) and -1 (window background/wipeout) can only be used as background pens . . .

HTH
~/archiben
b e n f r o s t
b f [a t ] p l a n b a r c h i t e c t u r e [d o t] n z
archicad | sketchup! | coffeecup

Anonymous
Not applicable
Thank you, I'll try that

Laszlo Nagy
Community Admin
Community Admin
NOELDESIGNS wrote:
While AC does join walls properly, that does not always translate into having the core composites join properly, as you can see in the attached image.

Here is where the problem is most evidant. First, the drawing without any adjustment just isn't technically correct. The walls have to join properly, but so do the various composite layers, especially the core. In the image provided, the walls do join properly, but not the core composite.
This is because you are using ArchiCAD 8.1. The cores did not join properly then, but they do now.
....................................................................................................
Get Archicad Tips at https://twitter.com/laszlonagy
AMD Ryzen 1700X CPU, 48 GB RAM, Nvidia GTX 1060 6GB, 500 GB NVMe SSD
2x28" (2560x1440), WIN10 PRO ENG, AC20-AC25
Loving Archicad since 1995

Anonymous
Not applicable
Works perfectly, thank you very much.

Didn't find the answer? Start a new discussion

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!