Developer forum
cancel
Showing results for 
Search instead for 
Did you mean: 

SaveDialog

Anonymous
Not applicable
If I would like to use an FileSaveDialog window like APIIo_SaveLibPartFileDialogID what is the policy? Is there any posibility to change this kind of dialog.
6 REPLIES 6

Ralph Wessel
Mentor
Andor wrote:
If I would like to use an FileSaveDialog window like APIIo_SaveLibPartFileDialogID what is the policy? Is there any posibility to change this kind of dialog.
Perhaps you're looking for 'DGGetSaveFile'? You can specify the file type, but not much more.
Ralph Wessel BArch

Anonymous
Not applicable
DGGetSaveFile???

This word doesn't figure in the entire apidev kit documentation.
You can specify the file type, but not much more.
That is what I needed. For me APIIo_SaveLibPartFileDialogID is perfect if I can change the filetype what figure in the textbox, from .gsm to something else.

Ralph Wessel
Mentor
Andor wrote:
DGGetSaveFile??? This word doesn't figure in the entire apidev kit documentation.
That's right - it's not documented, but exists in the API headers (see DGFileDlg.hpp). I've used it several time without problems. The meaning of the function parameters can be deduced from their name and type.
Ralph Wessel BArch

Anonymous
Not applicable
Yes. You have right. It's works fine. THX a lot.

Hmmm..
I have an very interesting problem. I develop an addon (I can't get my developer ID for now) so I test my addon in demo mode. My problem is that every time works fine, but on other workstation the same version archicad can not load my addon. ("The file is an outdated Add-On that cannot be used with this ArchiCAD version.")
Do you have any experience with this error?

Anonymous
Not applicable
Where you running the other workstations in demo mode?

also... did you do a 'release' build of the add on and not a 'debug' release?

Anonymous
Not applicable
Yes. I try to use my addon just in demo mode, because I get get my developer id and for that my addon runs just in demo mode.
My addon at my workstation works fine. The debug version and the release version too. But an other workstation, the archicad doesn't load my addon.
it doesn't matter that is an debug version or a release.

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!