Document & Visualize forum
cancel
Showing results for 
Search instead for 
Did you mean: 

Turning off the sun and shadows

Hello All:

Ever since I have been using AC25 my 3D views are distracting. What happening is that when viewed in 3D sides to the west are darker in color or black and the sides to the east show as bright surfaces (whatever color). I would like to know if there is a setting where all sides appear to be on the side where the sun is. The problem with shadows is that they create viewing issues. Some objects have a "no shadow" option but not everything like walls. Is there a generic setting that I can set or release to control shadows for all object?

 

1 ACCEPTED SOLUTION

Solution

Hello Ling:

Tried what you said and it offered some improvement but not what I was hoping for. I would consider this thread completed as it is obvious what I am looking for is not possible in AC today. Maybe in the future.

 

Thanks to all who replied.

View solution in original post

11 REPLIES 11

Lingwisyer
Champion

You could turn off shadows. Maybe create a new style for working in so that your views are not affected.

View => 3D View Options => 3D Styles => [Relevant Style] => Shadows

 

Or you could adjust your sunlight settings.

View => 3D View Options => Perspective Settings / Parallel Projection Settings => Sunlight Settings

 

 

Ling.

AC22-23 AUS 7000
Self-taught, bend it till it breaks.

Win10 | E5620 x 2 | 24GB | K2200 RIP PSU
Win10 | R5 2600 | 16GB | GTX1660

ryejuan
Expert

easiest way to access presets is when you are in the 3d window you right click on an empty space then this dialogue box will appear you can choose the 3D Styles. Hope this helps you. 😎

ryejuan_0-1653539913051.png

 

In the end what is your Objective?
ArchiCAD 9 onwards

Thanks to Ling and Ryejuan for your help. I did as indicated but only  got some relief. I turned off the shadows which is nice but my "sun/lighting" issue still persists. When designing I would like to set the lighting as if the sun was shining from the east, west, north, south, and directly above all at the same time. That way when I orbit around the model the lighting of the model stays the same (sun behind the user shining toward the monitor at an azimuth of approx. 75 degrees). That is, while rotating the model the sun does not rotate with it.

Without global illumination, etc. the the 3D window in Archicad makes surfaces look dark in shade or shadow. About a decade ago, I would compensate for that by adding Emission to the OpenGL Surface recipes. Of course, that meant adjusting the Ambient, Diffuse, Shininess, and Specular colors and intensity to compensate and avoid hotspots and overexposure when in direct sunlight. The goal was to make each surface look good in every situation, indoors or outside. Depending on the textures and base surface color, the settings had to be balanced for each surface through trial and error. These became the US default surfaces for a few years, and I have continued to refine and add to these in my own template which has 172 of them.

Here are few images from a pitch I made to Graphisoft comparing their concrete, stucco, and ceiling tile, with mine, with shadows, and without.

The next screenshot shows the settings for surface index 1, for example, and my surface test object in the 3D window behind the dialog that displays all the surfaces in model.

Ransom Ratcliff
RATCLIFF CONSULTING LLC
Charrette Venture Group
ArchiCAD 4.55 - 25
Autodesk Certified Professional in Revit
macOS + Windows

Awesome work! If there was no available real rendering now I would also do this kind of thing with the materials within Archicad but should also take into account that the material editor in Archicad for the 3d window and the cinerender got very different settings.

In the end what is your Objective?
ArchiCAD 9 onwards

As Ling suggested ...

Or you could adjust your sunlight settings.

View => 3D View Options => Perspective Settings / Parallel Projection Settings => Sunlight Settings

 

Turn the sun intensity down and the ambient light up and you will get a much more even light.

If the sun intensity is up, then surfaces will seem much brighter on the sun facing side, no matter what ambient light setting you have.

 

Barry.


One of the forum moderators.
Versions 6.5 to 25
Dell XPS- i7-6700 @ 3.4Ghz, 16GB ram, GeForce GTX 960 (2GB), Windows 10
Dell Precision 3510 - i7 6820HQ @ 2.70GHz, 16GB RAM, AMD FirePro W5130M, Windows 10

Maybe I misunderstand the suggestion about adjusting Sunlight settings, but I don't think that works.

Using the North American default template, the Ambient is already set to 100% and the Sunlight is set to 95% and the default surfaces are dark and depressing.

Lowering the Sunlight to 45% makes it worse, and even raising the Contribution to Ambient to 100% still does not make it look good.

I'll attach images of what I'm talking about below.

Without brightening the surface settings for the OpenGL, these 3D window settings can't do enough. Indeed, doing it this way will affect the Renderings of the same View.

Again, this is only for the Hardware Accelerated settings; not the Cineware settings. That way the live 3D window is a closer prediction of what the Renderings will deliver.

Ransom Ratcliff
RATCLIFF CONSULTING LLC
Charrette Venture Group
ArchiCAD 4.55 - 25
Autodesk Certified Professional in Revit
macOS + Windows

Tim Ball
Expert

You can also set the location of the sun for each view. That way you can have sun on the north elevation, which is not possible in the northern hemisphere. So you cheat on the sun but it gives a better 3D look

Tim Ball

AC25, iMac

User since V5

Ransom is correct. I am using the American version and the ambient is set to 100% by default and reducing the amount of sunlight only makes the surfaces darker. His picture of the squares and spheres is exactly what I want but I was hoping for a simpler solution. I don't want to have to set things up for each and every surface but rather have a switch/setting that  would change the lighting globally. That is, when activated all surfaces show with the same brightness and when deactivated the 3D view reverts back to proper rendering. I think I am going to have to live with the options available today and hope that maybe the software developers can add the feature I am looking for in a future version of AC.

 

Thanks to all who responded.

Lingwisyer
Champion

I have Contribution to Ambient set to 0... which is brighter than when set to 100...

AC22-23 AUS 7000
Self-taught, bend it till it breaks.

Win10 | E5620 x 2 | 24GB | K2200 RIP PSU
Win10 | R5 2600 | 16GB | GTX1660

Solution

Hello Ling:

Tried what you said and it offered some improvement but not what I was hoping for. I would consider this thread completed as it is obvious what I am looking for is not possible in AC today. Maybe in the future.

 

Thanks to all who replied.

Start a new conversation!

Labels

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!