About Archicad's documenting tools, views, model filtering, layouts, publishing, etc.

Elevations lose auto-Update function


Seemingly randomly some of my elevations lose their ability to auto-update.  This is seen in that those elevations no longer have ability to access the "elevation settings." The stories no longer appear in those sections and little x's appear nodes in the elevations.  This has happened to 5 of 8 elevations I'm working on.  I've deleted them, replaced them with new one's, which worked for a while, then the new ones "flipped" too.  Ugh... Help!


Adam Weiss

Autocad 25

macOS 11.6

64GB memory 

8GB AMD Raedeon Pro 5500XT


Here's what one elevation looks like that works and one that's broken.

Karl Ottenstein

The little x's as you call them are hotspots... which would only appear if you had somehow "exploded" the content of the elevation.  An elevation being on auto-update vs manual would have nothing to do with those appearing.


It appears that at least your beams and columns have been exploded.  Exploded content is no longer linked to the model but is 2D linework, fills and hotspots (x's).  Click on one of the lines for the column or beam and see if it doesn't show it as a line or fill vs an actual column or beam?  I'm guessing that what was an elevation is not an independent worksheet.


One of the forum moderators
AC 27 USA and earlier   •   macOS Ventura 13.6.3, MacBook Pro M2 Max 12CPU/30GPU cores, 32GB

Is there a way in which I may have taken an elevation and indvertantly exploded the content to turn it into linework?  I had 6 elevations on my layout and I was just adjusting there location on the layout when 3 of them seemingly automatically switched over.  I could see the whole sheet when 3 of them made this change.  Is there a way to undo this???

@Adam_Weiss The good news is the model should still be ok. You need to go back to basics and check that the elevation marker for the broken views is still present. Next you should check that the Elevation Marker > Marker Type is set to "Source marker". If it is set to Linked or Unlinked then that is the root of the problem. With the Elevation set to "Source Marker" it should then be a relatively simple job to drag the elevation from the View Map onto your Layout to replace the broken View. I have never had this problem so hopefully the above works. If not, post back here with what you have found. 

Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)

Thanks DG Sketcher.  You solved most of the issue.  The one's that had gone beserk had in fact somehow defaulted back to "linked" marker.  The ones that didn't explode to linework remained "source marker."  Once I switched them back. The ability to see the story levels, set the horizontal extents, etc returned.  This was the critical part, so thank you.

The part that remains, is that the "hotspots" associated with the corners of structrural elements and railings remain.  I can't seem to select them or turn them off.  They don't print so it's not critical, but I'd love to figure that part out too.  See below for image of my layout AFTER the markers have been set to source.  Elevations 3,5, and 6 have been fixed but retain the hotspots.  elevations 1,2, and 4 never broke.


@Adam_Weiss I think the problem is the source view is now merged with linework created by the changed marker type. You could open the elevation Source View in the Project Map, turn on all layers and run Find & Select for all “2D Elements”. Check it hasn’t selected anything you want to keep e.g. annotations, if it has then remove them from the selection and then Delete the remaining selection. You should then be left with a view of the model and any 2D elements you wanted to keep.


This is rough editing so make sure you keep a backup file in case you delete something you need.

Apple iMac Intel i9 / macOS Sonoma / AC27UKI (most recent builds.. if they work)

Thank you!  You were right.  The 2d info previously created was still there.  Just had to select it and delete it as you said.  Thanks!

Start a new conversation!

Still looking?

Browse more topics

Back to forum

See latest solutions

Accepted solutions

Start a new discussion!